Password not filling in automatically on https://live.edirectglass.com/edg/default.asp

Password not auto filling on https://live.edirectglass.com/edg/default.asp. I've tried the various troubleshooting tips listed, but continue to get an error 1password cannot fill any fields. The funny thing is that once the page is loaded, if I click the 1password Login, it will then proceed to fill out the fields.


1Password Version: 4.6.0.592
Extension Version: 4.6.0.592
OS Version: 6.2.9200
Sync Type: Dropbox
Referrer: forum-search:Password entry not working on https://live.edirectglass.com/edg/default.asp

Comments

  • Greetings @2020autoglass,

    Would it be accurate to say that your default web browser in Windows is Internet Explorer? I tried go and fill in IE, Firefox and Chrome and it seemed to work fine in both Chrome and Firefox and less reliably so in IE. I think we might be looking at a timing issue here as every so often I found go and fill would fill while the majority of times it wouldn't. My initial thought is if it is executing a lot of JavaScript after the initial load that could be cause and like yourself I found filling after the page has loaded seemed to be as reliable as ever.

    Does this match with your findings?

  • Yes, exactly. That website only works in IE, so I have to use IE.

  • Hi @2020autoglass,

    Internet Explorer is a very odd beast and the people that develop the extension in Safari, Chrome and Firefox aren't the same ones that maintain the extension in Internet Explorer. My knowledge of it is somewhat limited and so I'm going to try and pick the brains of the person that will.

    While frustrating, at least once the page is loaded the keyboard shortcut ctrl + \ will allow you to fill using the Login item.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @2020autoglass,

    The issue might be that you have 1Password configured to open items in new tabs instead of current tab in Internet Explorer. Try this and see if this helps; open Internet Explorer, click on the 1Password icon and go to Settings > Open In > Current Tab.

    Try again and see if it is faster now and more accurate. There's a limitation in Internet Explorer where it does not allow plugins to reuse the same session in separate tabs. Basically, when you open the item in a new tab, the entire 1Password plugin has to be re-established with 1Password Helper in the background before it can fill in. This is very slow and sometime causes the plugin to find nothing to fill. When you change it to current tab, we can reuse the same plugin session in that tab to fill in quickly.

This discussion has been closed.