An internal error prevented Knox from backing up the vault

Dave CreekDave Creek Member

When attempting to back up I get the following message:
"The vault Finance couldn't be backed up. The copy process ended with an error status 255"

How do I solve this problem?

Comments

  • SeanFosterSeanFoster

    Team Member
    edited December 2015

    Hello, sorry to hear about the trouble! Out of curiosity, are you attempting to backup this vault to an external hard drive?

    Can you let me know which version of OS X and Knox (Open Knox Preferences, click the Version tab) you’re running on your Mac?

  • I am not trying to back up to an external drive. OS X 10.11 2. Knox 2.3.2 (234)

  • Thanks for the follow-up details. :) Is it only happening to that specific Finance vault or do you see the same issue with other vaults?

    Can you try changing your Knox backup folder location for the Finance vault and see if that'll change anything?

  • I only have the one vault. I just tried changing the backup location, but that didn't work

  • By chance have you attempted a reboot of your Mac since experiencing this difficultly? If not, I’d recommend giving that a quick try.

    There is another option if I a reboot doesn’t prove successful, which is to try reinstalling Knox. You shouldn't have to move any files out of their vaults to reinstall Knox. Just delete the app, reboot your Mac, and reinstall it from our https://agilebits.com/downloads page. Just don't use any app cleaner apps (such as CleanMyMac) when deleting it, just manually drag Knox.app from your Applications folder to the trash bin when deleting the app.

  • Since I shut my Mac down every night, I didn't restart. I did trash the Knox app, emptied the trash, downloaded it and reinstalled it. No luck, same problem

  • Sorry to hear that didn’t do the trick! Can you give the following a try?

    Quit Knox.

    Open Finder and select the Go Menu > Go to Folder option. Type or copy the following address in there (include the tilde):
    ~/Library/Preferences

    Move the "com.knoxformac.knox.plist" file to your desktop.

    Reboot the Mac.

    Start Knox. Since Knox thinks this is the first time you've run it on this computer, you will see the Welcome screen.

    If you have existing Knox vaults, go to the Knox's Preferences > Vaults pane. You should now drag from the Finder any Knox vaults that you want to "manage" within Knox to the Vaults area. A green plus-sign ("+") will appear and you can release the vault. Repeat with any other vaults.

    This process discards your license key. Go to Knox Preferences and re-enter your license key.

    Test Knox and see if things are working better. If yes, be sure to check the Backup Preferences to set up the backups for your Knox vaults, along with other preferences you need to update.

  • Sean,

    That did it! Maybe the source of the problem--an extra preference file. Here are the two I found and deleted:
    com.knoxformac.knox.plist looks correct. It was dated today
    and
    com.knoxformac.knox.plist.6nvgZnk weird. It was dated October 20

    Many, many thanks for the help.

    Dave

  • I should add that I wasn't required to enter my license key and my Finance vault showed in Preferences without me dragging a file into place.

  • That’s great to hear, very glad that did the trick. Thanks for your patience this afternoon as we sorted this out!

    Let me know if you have any other Knox issues or questions I can be of assistance with. Happy New Year! :)

  • Hello, trick?! I have the same problem and I think more but they not seen yet that Know made a backup. This must be a bug and should be fixed through an update !?

  • Andrew_AGAndrew_AG

    Team Member

    While I wish I could say this will be resolved in the near future, our developer focus is almost entirely on the 1Password for Teams beta right now, and will be for the next while, so further Knox development is not really happening at this time. We are very sorry for any inconvenience this causes.

    In the meantime, did you try what SeanFoster suggested above?

This discussion has been closed.