Identity form-fill stopped working on internal web site

I'm just wondering if anyone else has experienced this issue.

In my workflow I have to place many test orders through our internal development site and I've always used the identities form fill to do so.

Has affected Chrome, Firefox, and Safari.


1Password Version: 6.0.1
Extension Version: 4.5.2
OS Version: 10.11.4. Beta
Sync Type: Dropbox

Comments

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @rabidsquid. Thanks for your post. I'm sorry for the trouble you're having. It's certainly possible that some recent changes have regressed identity filling on some sites. While not a huge number, our automated testing has dozens of some of the most problematic sites and those tests are currently all passing. The other possibility is that the page itself changed such that 1Password's heuristics can no longer make sense of it. I know internal pages don't tend to change that much but I thought it worth mentioning.

    If it's possible, I would love to get a copy of the markup for that page that's giving you trouble so I can make a test for it and hopefully figure out what isn't working.

    Thanks!

    --
    Jamie Phelps
    Code Wrangler @ AgileBits

  • rabidsquidrabidsquid Junior Member

    Here's a simplified version of the form:

    https://www.dropbox.com/s/y82ecwtbddsxmio/testForm.html.zip?dl=0

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @rabidsquid! Thanks for that form. I played with it for a few minutes and I was able to get a unit test running for it with just a little bit of massaging still to go. But, when I try to use that in 1Password for Mac, there is some crash that is happening that prevents us from generating even a partial fill script. I'm opening a bug report to investigate this. I'm very sorry for the failure in the interim!

  • rabidsquidrabidsquid Junior Member

    Thanks for looking into it, much appreciated!

  • Thank you for reporting it :smile:

This discussion has been closed.