Installation on Apple Watch not possible [resolved with latest 1Password beta]

holgrholgr
edited February 2016 in iOS Beta

Hi,

I'm unable to install the latest Beta on my Apple Watch by moving that little radio slider in TestFlight. I wonder if this is an issue with the 1Password Beta, iOS 9.3 (being on beta 3) and/or TestFlight itself. Anyone else seeing this?


1Password Version: 6.2.2 (622006)
Extension Version: Not Provided
OS Version: iOS 9.3b3
Sync Type: Dropbox

Comments

  • AGKyleAGKyle AgileSupport

    Team Member

    Hi @holgr

    I'm seeing the same thing. Fairly confident this is a TestFlight issue though as it's intermittent, sometimes it works, other times it does exactly what you're describing. If I install the app directly from Xcode or from the App Store, it works no problem. If I try to install from TestFlight it fails. I'm not on iOS betas though, that could also contribute I imagine but given it happens on stable iOS I think it's less likely a beta thing.

    Hope that helps a little but I do wish I had a better way to confirm one way or another what was going on.

  • HRDHRD

    Hi @AGKyle,

    TestFlight has just been updated to version 1.3.2, which I assume fixes the issue you mention.

  • AGKyleAGKyle AgileSupport

    Team Member

    Hi @HRD

    Wish I could confirm, but I'm currently stuck in limbo since we're between internal betas but I will definitely check this out maybe tomorrow if we ship a new beta :)

    Is it working better for you?

  • HRDHRD

    Hi @AGKyle,

    I am using the stable version at present, so will let you know once you ship a new beta.

  • AGKyleAGKyle AgileSupport

    Team Member

    @HRD

    Ah ha, so you're kind of waiting for the same thing as me :) I've made a task to look at this tomorrow and if not tomorrow then we'll take a look on Tuesday. Those are our two beta days normally.

    I'll be in touch!

  • RamsteinerRamsteiner Junior Member

    I have the same issue even with newest TestFlight app installed.

  • WinnieWinnie 1Password Alumni 1Password Alumni

    @Ramsteiner thanks for chiming in. As we are currently in between betas could you check again once the next beta comes out?

  • RamsteinerRamsteiner Junior Member

    Absolutely!

  • WinnieWinnie 1Password Alumni 1Password Alumni

    Awesome! Thanks @Ramsteiner!

  • mirvmirv Junior Member

    I am running iOS 9.3 beta 3 and watchOS 2.2 beta 3. For the last few days, probably since the update to the TestFlight app, I've been getting notifications from TestFlight saying "Couldn't install 1Password; Open the TestFlight app and try again." Opening the TestFlight app shows "Unavailable" near "Offers Apple Watch App." See attached screen shot. I'll report this to Apple as well.

  • MrRooniMrRooni

    Team Member

    Hi @mirv. Thanks for the information. My guess is that once we make a new beta available that this problem will go away for you. Until then you could switch back to the App Store version to get the Watch app installed.

  • HRDHRD

    Hi @AGKyle,

    All good with the latest beta - installation on Apple Watch worked seemlessly.

  • WinnieWinnie 1Password Alumni 1Password Alumni

    @HRD thanks for letting us know! Glad it is working now.

  • RamsteinerRamsteiner Junior Member

    As noted above, all is right with the universe. Latest beta and latest TestFlight app work well together.

  • WinnieWinnie 1Password Alumni 1Password Alumni

    Great to hear @Ramsteiner! Thanks for giving us your thumbs up for this problem being solved.

This discussion has been closed.