Can no longer use 1Password Mini [confirmed issue when Chrome does not have 1P extension enabled]

For the past several weeks, when I try to use 1 Password Mini, it freezes. To unfreeze it, I have to launch the full app.

Are you aware of this issue?


1Password Version: 6.0.2
_Extension Version:
Not Provided
OS Version: OS X 10.11.3
_Sync Type:
Not Provided

Comments

  • Drew_AGDrew_AG 1Password Alumni

    Hi @srohde,

    I'm sorry 1Password mini is misbehaving! We'll figure this out one way or another.

    Out of curiosity, does it make any difference if you try to launch mini by using the ⌥⌘\ ( Option+Command+\ ) keyboard shortcut instead of clicking on it? Also, do you see the "spinning beachball" at all when mini gets stuck like that? If you wait, does mini ever eventually work on its own?

    It sounds like the main 1Password app still works even when mini is getting stuck, so one thing you can try is to restart 1Password mini. From the main 1Password app, go to Help > Troubleshooting > Restart 1Password mini. If you try to use mini after that, does it work?

    If not, please reboot your Mac. After it restarts, does mini work any better than before?

    Please let us know how it all goes, and if it's still a problem, we'll continue from there. Thanks! :)

  • Hi @Drew_AG,

    Thanks for the quick response!

    Didn't know about Option+Command+\ . Nice to know.

    After playing around a bit, it appears that the I only encounter the issue if I try to open mini when the topmost window is a Chrome incognito window. If I try to open mini while a Chrome incognito window in on top by...

    • keying Option+Command+\, nothing happens.
    • clicking the toolbar icon, the icon turns blue but mini doesn't open.

    When the icon is blue, I can restore normal functionality by switching to any non-Chrome window (or launching another app).
    If I switch to a regular (i.e., non-incognito) Chrome window, the icon remains blue but if I click it, mini opens and the blue goes away.

    CONCLUSION: Chrome is the culprit!

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @srohde Thanks for the follow-up. We did make some improvements around this in recent releases but it looks like there are some additional cases we need to consider for this as well. I'm sorry for the trouble!

    ref: OPX-1127

  • Rob AndersonRob Anderson Junior Member

    I've encountered this problem too - it does appear to be related to Chrome incognito windows, i.e. the mini drop-down menu won't display on top of the incognito chrome window (but will on a normal window). Hope you can find a fix for this :)

  • Rob AndersonRob Anderson Junior Member

    BTW - I just discovered that it does work if you allow the 1Password Chrome extension to have access in incognito mode (this is disabled by default).

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @Rob Anderson Yes, we still have some more work to do for supporting situations where the frontmost window does not have 1Password available. The Incognito problem you mentioned is the same problem as not having 1Password in the active profile, only active in the background. We will be looking into this very soon. Thanks!

  • Rob AndersonRob Anderson Junior Member

    @ thanks jxpx777, I appreciate your looking into it! Just curious, are you related to thx1138 by any chance?

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @Rob Anderson Yah, thx1138 is my cousin! :lol: Just kidding… no, my username doesn't derive from that George Lucas movie, but it's a common question.

  • Rob AndersonRob Anderson Junior Member

    :p Heh, and a book before the movie!

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    :blush: Yes, yes, I should have known that. Bad fake sci-fi fan I am!

  • I've decided to move on from 1Password. The v6.1 update did not fix the 1Password Mini incompatibility issue with Chrome incognito windows. In fact, it made 1Password Mini even more unstable.

  • Hi @srohde,

    There is one question I haven't seen asked yet. When you make use of a Chrome Incognito window do you want 1Password to work within the incognito window?

    The reason I ask is there is the issue you've been facing. The cause of it is when you ask 1Password mini to respond but every copy of the extension in Chrome responds saying it's in the background. So we know we have a flaw still to fix as 1Password mini should respond in a more general way if the extension is saying that it should be ignored. The bug appeared because we faced the problem that extensions in multiple profiles were all yelling over each other and causing problems.

    If you want 1Password's Chrome Extension to work in an Incognito window then it's definitely possible right now, the trick is Chrome has to allow the extension to be run. It's a setting in Chrome that only the user can adjust so it isn't possible, as far as I'm aware, to have the extension set it on the user's behalf. Here is what you would want to do to have the 1Password Chrome Extension work in an Incognito window.

    1. Visit chrome://extensions/ in Chrome.
    2. Tick the box titled Allow in incognito for the 1Password Chrome Extension.

    Now if you don't want our extension available in the Incognito window then none of that is of any use and not applicable so I apologise.

    As for the new issue you're experiencing. There are a couple of possibilities and we cover some of the causes on our page Troubleshooting “1Password failed to connect to 1Password mini” (Mac)

    We could also review a diagnostic report and help get this issue sorted but of course that won't be of much use unless you would like to continue working with 1Password. If you do though the following will show you how to send a diagnostic report in.

    The following link is to a guide that will show you how to create a diagnostic report.

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    When sending the diagnostic report to the address above it would help immensely if you could include a link to this thread and your forum handle so we can connect the two.

    Once you've sent the report a post here with the ticket ID will help us to keep an eye out for it. With access to the report we should be able to better assist you :smile:

  • srohdesrohde
    edited March 2016

    I simply want to be able to look up passwords in Mini when I'm in a Chrome Incognito window. This used to work just fine. Now it doesn't (Mini freezes) and I don't want to spend a lot of time trying to get it to work again. I've done a bit a research can have found some compelling alternatives. Thanks for your help but 1Password no longer serves my primary use case (logging into dozen of different Google accounts in Chrome incognito windows).

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @srohde I'm very sorry for the trouble. Right now, there is a bug in the way we handle the 1Password menu bar item when the frontmost window in Chrome does not have 1Password enabled. I've fixed this and it should be available in the next beta as it makes its way to a stable release. In the meantime, you can allow 1Password in your Chrome Incognito windows, switch to another app before clicking the 1Password icon, or use the main app to look up the data. I'm sorry for the trouble in the meantime, but please know a fix is on the way.

  • Just throwing it out there that as a power user of 1Password, this has been an annoyance for several weeks now. Discovering this thread resolved it by enabling the 1Password Chrome extension incognito. Perhaps it might be beneficial to create a support article on this if one does not already exist? I know there are many other power users that would benefit from this information.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @vcantrell! I'm happy to report that this should be resolved in the current beta release and is making its way to the next stable as well.

  • I just brought 1Passwords up to date to see is if the freeze issue with Chrome incognito windows had been fixed. Unfortunately, it appears that rather restoring the functionality that used to work just fine, AgileBytes has discontinued support for incognito windows instead.

    FORMER BEHAVIOUR (before Feb 2016)
    1. Open a Chrome incognito Window
    2. From 1Password Mini, find the desired website login item and click.
    3. Website login URL loads in a Chrome incognito window and 1Passwords supplies the credentials.

    CURRENT BEHAVIOUR (as of 12 April 2016)
    1. Open a Chrome incognito Window
    2. From 1Password Mini, find the desired website website login item and click.
    3. Website login URL loads in an regular Chrome window and 1Passwords supplies the credentials.

    Perhaps three's an option to "enable support for Chrome Incognito windows. Is such an option exists, please let me know.

    Thanks!
    Steve

  • I thought I'd try to use Safari private windows instead of Chrome incognito windows. Unfortunately, when I try to install the 1Password Safari extension, this happens...

  • Hi @srohde,

    Indeed there is. Visit chrome://extensions/ in Chrome and in there you will notice that every extension has to be enabled to work in Incognito mode, by default no extensions are enabled and so the 1Password Chrome Extension is not enabled.

    As for Safari, the generic error you're seeing happens when you try to install a second copy of the 1Password Safari Extension. You already have the extension installed and enabled as the icons to the left of the address bar are for 1Password and I think AdBlock? I agree it would be more friendly if the error message was a little more detailed as to why the extension isn't being installed but what can we do :smile:

    Given you're trying to install the extension again in Safari are you experiencing an issue there, is it not working in some way?

  • Thanks, @littlebobbytables, for helping me get everything squared away! 1Passwords is working exactly the way I expect it to again.

  • :+1: Glad to hear things are working smoothly for you :smile:

This discussion has been closed.