Problems with autofill in Safari

I am running El Capitan, Safari, and the latest 1Password extension, 4.5.3. After I haven't accessed any sites and used autofill for roughly 12 hours or more, when I try to autofill, it doesn't find the entry for that site. The extension is loaded, and mini is running, and it's unlocked. However, the pop-up just has the standard "Favorites", "Password generator", etc. If I quit Safari, and then start it again, it solves the problem. I have uninstalled and reinstalled the extension. I have rebooted. I have disabled the other extensions, but this problem keeps happening. This is not happening on a different Mac running the same software, so it's puzzling.


1Password Version: 6.0.2
Extension Version: 4.5.3
OS Version: OS X 10.11.3
Sync Type: Dropbox
Referrer: kb-search:problems with safari extension

Comments

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @jevarts Sorry for the trouble you're having. When you see this behavior, are you then clicking the button in Safari's toolbar or interacting with 1Password using keyboard shortcuts or the 1Password mini icon in the main menu bar? If you weren't using the toolbar button, could you try it? My suspicion is that somehow Safari is losing the connection to 1Password.

  • jevartsjevarts Junior Member

    Hi - Thanks for the reply on this. After some more testing, including your suggestions, what I have found out is that 1Password does seem to get disconnected. Clicking the button on the Safari toolbar or using the shortcut keys don't work. However, after making Safari the active app, and waiting a minute or so, then it works. So, I guess it reconnects itself. Do you know any way to keep it from disconnecting? Also, this started after I migrated from Kaspersky to McAfee. Once I did this migration on my other Mac, it started behaving the same way.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @jevarts I've heard one other user with this kind of issue recently, but we were never able to fully identify the problem after several emails back and forth over the course of a couple of weeks. I will say that 1Password does have some issues with various antivirus solutions blocking the connection to the main 1Password application from the browser extension. I would start by disabling McAfee temporarily to see if you still have the issue. Some of these security suites act as proxies to monitor and block certain connections. In most cases, though, you can configure them to not block connections on localhost.

  • jevartsjevarts Junior Member

    Sorry for the late reply to your post.... at any rate, I have done a number of configuration items, and the only thing that seems to solve the problem is to disable the McAfee firewall function. I have tried adding rules in the McAfee firewall to allow all localhost access, but that doesn't help. I've also updated the Mac network settings to bypass proxy settings for 127.0.0.1, but there are no proxies configured anyway. I am running McAfee total protection 3.7.2.0, OS X 10.11.4, Safari 9.1, 1Password extension 4.5.3. Note: version 4.5.4 of the extension has the same problem. Any other thoughts or suggestions?

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @jevarts At this point, I think I should point you toward McAfee's support to find out how to address this. For our part, I will say we are exploring other communication channels between 1Password and Safari that should not be subject to these kinds of problems. We're still working on a couple of challenges, but hopefully we will get them ironed out soon and be able to move past the current method.

    I'm sorry I don't have a better answer for you at this time. If you get a good answer from McAfee, I would love to know so we can update our documentation and help other users.

    --
    Jamie Phelps
    Code Wrangler @ AgileBits

This discussion has been closed.