Secure Desktop unlock is broken

Hi, I've updated to 4.6.0.604 on my laptop and I'm not able anymore to use secure desktop unlock.

For example when I press CTRL+\ to fill form in Chrome whole screen turns black and I do not see login box. Only thing that work is CTRL+ALT+DEL to show task manager. After approx. 15 computer turns back to normal operation and unlock screen appears on my normal desktop.

Two of my computers are affected. Cloud I help you with reproducing problem?


1Password Version: 4.6.0.604
Extension Version: 4.5.3.90
OS Version: Windows 10.0.10240
Sync Type: Synology Cloud Station

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @honzakuchar,

    First, reboot your computers and see if it helps. A lot of tiny glitches has been resolved when rebooting after installing a 1Password update.

    If that didn't help, could you answer the following questions:

    1. Are both of your computers running the outdated Windows 10 build, 10240? You should be on the Nov 1151 update, 10.0.10586.
    2. What anti-virus solution are you running? Can you check the logs of your security programs to see if any one of them has blocked consent.exe in the Windows folder and/or any of the exe files in the Program Files (x86) > 1Password files?

    I am not able to reproduce this but we've seen this a few times in the past when a security program has blocked 1Password or Windows from bringing up Secure Desktop.

    If you see it again, use the Task Manager to terminate the consent.exe process and you should be returned to the regular desktop view. For now, unlock, and then go to the File Menu > Preferences > Browsers, uncheck the option for Unlock on Secure Desktop before pressing OK. This should let you get into Chrome without the stuck black screen while we figure out what's causing this issue.

  • I have tried to reboot computer, didn't help. I've upgraded my main computer, there it works without issues.

    I've figured out that Avast! is causing this problem. (on both computers) Both are home computers - so I have Avast! Free Antivirus 11.1.2245 with virus database 160302-1. When I disable Avast shields everything works as expected. Any ideas what can be wrong with Avast?

  • Btw. When I disable Avast! I see process Agile1pLogin.exe in secure desktop. When running with Avast turned on that process is no there. Probably didn't event start.

  • Cool! Found workaround.

    • Open Avast! settings
    • Go to your shields list
    • click change near File system shield
    • click exceptions
    • Add C:\Program Files (x86)\1password to exceptions
  • AlexHoffmannAlexHoffmann

    Team Member

    Hi @honzakuchar,

    Thank you for your work on this. This gives us a fair bit of data to work with.
    We're going to get in touch with our contacts at Avast and will work on fixing this with them.

    We would appreciate if you could report this issue—which is essentially a false positive—to them as well. You can do so via their 'Report a suspected false positive file' page.

    Cheers!

This discussion has been closed.