Can't install 1Password extension in firefox.

MattSlickMattSlick
edited February 2016 in 1Password 4 for Windows

1Password 4.6.0.604
Firefox 44.0.2
Windows 7 Pro
When I try to install the 1Password extension in Firefox, I get this error message, "this add-on could not be installed because it has not been verified"

I've tried to install it manually with several different versions of the .xpi file. Nothing works.

I used two browsers simultaneously, all the time, every day: Chrome and Firefox.

The extension installs no problem in Chrome but I cannot get it to work in Firefox.

please help......


1Password 4.6.0.604
Any version of the xpi....doesn't seem to work.
Windows 7 Pro
DropBox

Comments

  • brentybrenty

    Team Member

    @MattSlick: "Security" software interfering with the installation of the Firefox extension is, unfortunately, all-too-common, so that's the first thing I'd check.

    To double-check, I just re-installed the extension in Firefox on my Windows 7 machine without issue. Make sure you install the current version directly from the AgileBits website:

    1Password browser extensions

    This is digitally signed by Mozilla, which will allow it to work in the current version of Firefox. You can also download it using another browser and drag it to Firefox to install it manually, if your "security" software is preventing you from installing it normally. I hope this helps! :)

  • I tried all sorts of things (turned off security, firewall, etc.) with no luck. I downloaded the beta and it installed. Whew! Hopefully, that will work. Thanks.

  • brentybrenty

    Team Member

    I tried all sorts of things (turned off security, firewall, etc.) with no luck. I downloaded the beta and it installed. Whew! Hopefully, that will work. Thanks.

    @MattSlick: The beta 1Password extension for Firefox? That worked, but the stable version didn't? That's baffling, since they're both signed by Mozilla, but I'm glad that's at least working for you!

This discussion has been closed.