Going crazy !!! Try to download extension to Firefox on my iMAC, it always switches to Safari?????

cpuklutzcpuklutz

Going crazy !!! Try to download extension to Firefox on my iMAC, it always switches to Safari????? It loads onto Safari but not to Firefox


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:Going crazy !!! Try to download extension to Firefox on my iMAC, it always switches to Safari?????

Comments

  • MeganMegan 1Password Alumni 1Password Alumni

    Hi @cpuklutz,

    I'm sorry to hear that you're feeling frustrated by this! Could you tell me a bit more about how you're attempting to download the extension? If we're doing something weird, we definitely want to get it corrected.

    • Are you seeing the 'Add Firefox extension' in mini when you have Firefox open?
    • Are you clicking the Install Browser Extension button in 1Password's Preferences > Browser?

    Our extensions are available for download on our website. If you open this link using Firefox, it should show you the Firefox extension by default. Does that help?

  • Yes, that's exactly what it say's; except when I choose it, the green box says it's for Safari; then I go lower on the page where it asks "not using Safari, choose from Firefox, Google Chrome, etc, I choose Firefox and the browser goes from Firefox to Safari [automatically], and it downloads the extension into my Safari. Many times also, when I try to launch into an app using 1 Password using Firefox, it again automatically switches me to Safari. ! ! ! ! Going crazy with 1Password, bought it over a year ago, and still have so little confidence in it's performance.

  • Drew_AGDrew_AG 1Password Alumni 1Password Alumni

    Hi @cpuklutz,

    Hmm, that's very strange - if you have our extension download page open in Firefox, it should detect that you're using Firefox and the big green 'Install' button should give you the Firefox version of our extension.

    Now, just in case I misunderstood something: From your description, it sounds like you see the 'Add Firefox extension' message while using Firefox, so you click that and our extension site opens, but it says "Press the Big Green Button to install the 1Password Safari extension". At that point, can you confirm that you still see "Firefox" in your Mac's menubar, right next to the  menu? And if so, does it launch Safari once you try to use one of the other links to download the Firefox extension?

    It all seems to be working correctly for me when I try it in each browser, and I haven't heard any reports of this issue happening to anyone else, so I wonder if there's something about the configuration of Firefox on your Mac which is causing it to be recognized as Safari by some websites. If you go to https://whatbrowser.org/ in Firefox, does it correctly recognize that you're using Firefox? Also, out of curiosity, which version of Firefox are you using?

    The questions above might help us figure out why it isn't working correctly, but if you just want to install the correct extension, you can try downloading the Firefox extension from a different browser and then install it in Firefox:

    • Open the following link in Safari: https://agilebits.com/onepassword/extensions
    • Click the link for Show all extensions.
    • Click the Install button for Firefox in order to download the extension.
    • Find the downloaded extension in your Downloads folder and drag it into a Firefox window.
    • Firefox should ask if you want to install the extension - click Install.

    If you have trouble dragging the extension into a Firefox window, you can double-click the .xpi file that you downloaded. It should give you the option to Choose Application, and when you click that, a dialog will open so you can pick Firefox (if Firefox is grayed out, change the "Enable" popup menu to All Applications, and then you'll be able to choose Firefox).

    Does that help? Let us know how it goes, thanks!

  • Drew_AGDrew_AG 1Password Alumni 1Password Alumni

    Hi @cpuklutz,

    I almost forgot to ask you about the other thing you mentioned:

    Many times also, when I try to launch into an app using 1 Password using Firefox, it again automatically switches me to Safari. ! ! ! ! Going crazy with 1Password, bought it over a year ago, and still have so little confidence in it's performance.

    It sounds like you're using the "open and fill" feature in 1Password by clicking on the URL in a Login item, or by double-clicking a Login item in the main 1Password app. When you do that, it will open the site in your Mac's default browser, and it sounds like the default browser is set as Safari in your System Preferences. If so, that's correct behavior. In that case, there are a couple options:

    • On your Mac, open System Preferences > General, and change the default web browser to Firefox.

    Or:

    • Open Firefox, open the 1Password extension, find a Login item, and click on that Login item (in other words, don't click the URL in the item details, but simply select the Login item from the list). That should open the site and/or fill your login credentials in Firefox.

    I hope that helps, but if I misunderstood or you have more questions about that, please let us know! :)

This discussion has been closed.