Slow (2-3 min) unlock, system unresponsive, Backup Failed error message

I'm running 1PWD 6.1 purchased from Agilebits on OS X 10.10.5 and syncing via Dropbox. Since upgrading to version 6, I'd noticed (before today) that unlocking was taking longer the previous, usually ~3-5 seconds. This was a minor irritation but not a major problem.

Today, however, I ran the latest Mac OS X updates via the App Store, and after the computer restarted, I now get a Notification with the error message "Backup Failed - 1Password failed to create a backup: (null)", and worse yet, unlocking 1Password is now taking anywhere from 2-4 minutes, during which time my computer basically becomes unusable, sometimes with a spinning wheel and sometimes just unresponsive. I don't know if these two issues are related, but this is now unacceptable and makes 1Password unusable. This problem occurs regardless of whether I am unlocking the 1Password app, via the browser extension or via 1Password mini. After it finally unlocks, my database appears to be fine. I have tried "Help/Troubleshooting/Restart 1Password mini", restarted the computer several times, rebuilt permissions and repaired the disk using Disk Utility, but it's still happening every time. If I try to run the backup using the "File/Backup" command, it fails with the same message (after failing, my last backup is from yesterday).

Please help - at the moment I cannot use 1Password.


1Password Version: 6.1 (6100005)
Extension Version: 4.5.5
OS Version: 10.10.5
Sync Type: Dropbox

Comments

  • OK, so now the same Backup Failed error Notification is popping up every 30 minutes or so, even though the 1Password app is not running and it's not unlocked via browser or 1Password mini. There were about a dozen such Notifications on my screen this morning.

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @brabin,

    I'm sorry you are having trouble with backing up, and the slow unlock. Note that repairing permissions only fixes permissions issues with OS X, and not necessarily with any third party applications. However, we can certainly diagnose this for you. I'd like to ask you to create a Diagnostics Report from your Mac. First, go into the Preferences, click on Backup, and click "Backup Now" - you may get an error, that's ok for now, it will be recorded in the report. Then, create and send a report as described here:

    Sending Diagnostics Reports (Mac)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

    Cheers,
    Kevin

  • Report sent.

    Support ID is [#TWP-25798-618]

  • MeganMegan

    Team Member
    edited April 2016

    Hi @brabin ,

    We've received your Diagnostics Report - thanks for sending it in! I've updated the email thread with the necessary details from this forum discussion so that it is easier for our support team to get up to speed with the issue. Someone from the support team will get back to you as soon as possible with some further information. We'll keep the conversation going directly via email to avoid complicating things between here and there. :)

    ref: TWP-25798-618

  • brabinbrabin
    edited April 2016

    3 days later and I am still waiting for some kind of response. I have left 1Password permanently unlocked so I can at least use my database, but I am still getting the Backup Failed error Notification about every 30 minutes.

    I've received excellent support from Agilebits in the past, but this is not good.

  • Hi @brabin,

    Yours is the second diagnostic report that I've come across with this error message about backups failings and the also odd behaviour where the diagnostic report tool doesn't create a full report. The incomplete diagnostic report is mostly just a nuisance as we're flying blind regarding a number of basic details. I've just downloaded a fresh copy of the tool and it's creating a full diagnostic report on my Mac which suggests it isn't a general issue running on either the latest version of OS X (10.11.4) or that we've got a damaged copy of the troubleshooting tool on our server.

    As for the much more pressing issue of the backup failures. I believe it's best we have a developer look at it before proceeding. OS X is reporting an Input/output error when trying to copy a file in the data folder and I would feel much safer once we know what a developer says about this. I will raise this with one tomorrow.

  • Thanks for the update, looking forward to a follow up.

  • Drew_AGDrew_AG 1Password Alumni

    :+1::)

  • brabinbrabin
    edited April 2016

    Update:

    At the suggestion of tech support and a developer, I took the documented steps to "start over" on this Mac, and I'm happy to report that after re-syncing to my Dropbox database, everything is working fine now...unlock is snappy and the Backup Failed error message is gone. Thanks!

    I can't be sure yet, but I think these problems were related to a hard disk issue. About the time these problems with 1PWD started, I also got a message from the Drive Genius background tool DrivePulse suggesting my HDD has critical issues and needs to be replaced. I repaired the disk with Mac OS X Disk Utility (no issues) and did a full surface scan using TechTool Pro (no bad blocks reported), so I didn't think this was the cause, however, Drive Genius continues to report a problem with the drive, and when I ran Carbon Copy Cloner today to create a bootable backup, it reported problems reading some files from the disk. Checking the CCC log showed there was only 1 file that didn't copy; it was the 1PWD sql database file which it said was residing on a bad sector. I'm probably going to reformat the drive and restore from backup, and I'm seriously considering replacing it.

  • Greetings @brabin,

    It really does suck when hardware fails but at least there doesn't seem to have been anything permanently lost on this occasion. We're just happy we could help get 1Password up and running again and fingers crossed your hard drive woes will be behind you soon.

This discussion has been closed.