safari extension won't install receiving error message please help

every time i attempt to install the safari extension either from the gallery or developer i received the error message, i'm am updated and using the latest version of 1password and El Capitan. I have restarted Safari several times, and it still does not install, receiving the same error message. Please help


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: kb:safari-cannot-install-extension

Comments

  • brentybrenty

    Team Member

    @Jenks21: What is the error message you're receiving exactly? If something is preventing a secure connection from being established, you won't be able to get the update. Do you have "security" software that might be interfering? Please let me know what you find!

  • @brenty it states "Safari can't install this extension" then "An error occurred while installing the extension 1password". I'll check on the security but I don't believe so.

  • Hi @Jenks21,

    I've fielded this question a lot recently and so far in every instance I've come across it's because the 1Password Safari Extension is already installed. I'm sure there must be other reasons why this error message will appear but so far it has been when Safari has stopped the installation because the extension is already installed.

    To confirm, or indeed disprove my theory can you try the following please.

    Open Safari's preferences and switch to the Extensions tab. If you see 1Password listed on the left hand side the extension is installed.

    If the extension is installed is it that you are experiencing an issue that made you think the extension wasn't installed? I just want to make sure we don't think problem solved if it isn't.

  • Good Evening, I actually have no extensions installed when I switched to that tab. I'm running 1password 6.2.1 and mac os 10.11.4 if that helps any.

  • Ok, I think I have it fixed now, somehow I didn't have my permissions set up to allow me to read and write extensions only read. Utilizing this link ~/Library/Safari/Extensions and highlighting and control clicking and looking at the properties for it I was able to solve the issue. Thanks for checking into it for me, I'm all set!

  • Hi @Jenks21,

    Obviously we're glad everything seems to be resolved although I'm surprised that the permissions were messed up. In older versions of OS X you could check the partition but also check permissions separately. I don't know if Apple merged the two into the First Aid option that is in Disk Utility but it might be worth checking out as it's unusual to see read-only permissions set on a folder in your Library folder.

    Saying that you've given me an example of how it may not be a duplicate install so thank you :smile: always nice to have some variety :tongue:

  • I have the same problem, when i go to install it I also show it is installed. However, when I go to extensions 1Password does not show as being installed.

  • brentybrenty

    Team Member

    @mrmakieve: Unfortunately without some basic information it's hard to say what might be going wrong and how we might right it! Please tell me the OS, 1Password, and browser versions you're using, the exact steps you're taking, and what is (or is not) happening the way you expect so we can figure out the best plan of action.

    The more information you can give, the better. For instance, it sounds like you may have "security" software interfering with the installation. 1Password can't do anything about this, so you'll need to check your settings to make sure that this doesn't happen — either to 1Password or to your browser. Let me know what you find. Thanks in advance! :)

  • The OS is OS El Capitan 10.11.5. I am using 1Password, version 6.3.1. I am using Safari, version 9.1.1. I went to install Safari as the browser for 1Password and when I click on the install button it says that there is an error. It says it is installed but when I go to my preferences pane it does not show 1Password as an installed extension.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @mrmakieve,

    Thank you for the details! The 1Password extension for Safari can be installed from either our own extension download site or from the Safari Extension Gallery. If you've only tried installing it from one, you can try installing it from the other to see if it works. I'm not sure which one you've been trying, so I'll list steps for both:

    To install it from our own extension download site:

    To install it from the Safari Extensions Gallery:

    • Open Safari and go to the menu for Safari > Safari Extensions...
    • If 1Password is listed at the top, click on that (if not, you can search for it in the 'Search' field).
    • Click the Install now link.

    Please let us know how it goes, thanks! :)

  • I have done what you instructed. Again as I mentioned when I click the Install button i get the message "Safari can't install this extension, an error occurred while installing the extension '1Password'." When I go to Safari Extensions it shows 1Password at the top and says it is installed. However when I go to system preferences it does not show 1Password as an installed extension, it does not show 1Password at all.

  • Drew_AGDrew_AG 1Password Alumni

    Thanks for trying that, @mrmakieve. To help us figure out what's going on, I'd like to ask you to create a Diagnostics Report from your Mac: https://support.1password.com/diagnostics/?mac

    Attach the Diagnostics Report to an email message addressed to: [email protected]

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum username so that we can "connect the dots" when we see your report in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report and make sure you receive a reply as quickly as possible. Once we see the report we should be able to better assist you. Thanks in advance! :)

This discussion has been closed.