Lost Pro features after updating to 6.4 (640010) [fixed in 641002]

2

Comments

  • hazmathazmat Member

    I installed the App Store version over the beta and the Pro features are there. Reinstalled the beta and they're gone again with no way to restore them. I reinstalled the App Store version again and they're back and I'll leave it until this is fixed.

  • FolsomRiderFolsomRider Junior Member

    The latest 6.5 beta deployed today still has the issue.

  • ollifiollifi
    edited April 2016

    Same here, still no Pro features (1Pw 6.5)

  • MrRooniMrRooni

    Team Member

    Good morning everyone. I'm terribly sorry for the trouble you're having here. Unfortunately we weren't completely clear in our release notes for 6.5b1. That latest TestFlight release will not longer wipe out your Pro Features if you have them, but it will not restore them if you previously had them.

    The workaround here is to install 1Password 6.4 from the App Store, run it, optionally restore your Pro Features via Settings > Pro Features (if they don't restore automatically), and then reinstall 6.5 via TestFlight.

    Let me know how this works out or if there's anything else I can do to help.

  • hazmathazmat Member

    Like I said above, that didn't work for me. Going to 6.4 from the App Store and then back to 6.5 from TestFlight caused the same issues of not restoring my Pro features.

  • WinnieWinnie 1Password Alumni

    @hazmat I'd like to ask you to create a Diagnostics Report from your iOS device:

    Sending Diagnostics Reports (iOS)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

  • mirvmirv Junior Member

    @MrRooni's method worked for me on my iPad but not on my iPhone. I reinstalled 6.4 from the App Store, then 6.5 again from TestFlight. I'm going to send a Diagnostic Report from my phone.

  • hazmathazmat Member

    @winnie: Here's the support ID. #ECI-86367-498

  • mirvmirv Junior Member

    My support ID is [#XVG-57115-963].

  • Wildcat_1Wildcat_1 Junior Member

    @MrRooni @Penelope Pitstop do you need anything more from us (other logs etc) at this point or are you fully aware and onto a fix already ? Just ask as we're still all seeing this in 6.5 and know this was meant to be addressed by it, therefore didn't know if you needed something else. Thanks

  • WinnieWinnie 1Password Alumni

    @Wildcat_1 we are currently investigating why this is happening.

    @hazmat and @mirv thanks for the Diagnostic Reports. Looking at them right now.

  • Wildcat_1Wildcat_1 Junior Member

    @MrRooni @Penelope Pitstop thanks and just let us know if you need anything from us !

  • WinnieWinnie 1Password Alumni

    @Wildcat_1 we'll definitely do that. Thanks so much for offering help! I appreciate it <3

  • Same issue I'm having. Posted this in the iOS form as well... Any resolution yet?

  • Purchases restored automatically on my iPhone 6 after following @MrRooni's instructions :) Thanks.

    Which iOS version you others are using, could that affect? I have iOS 9.3.2 beta 3.

  • hazmathazmat Member

    I have the same iOS beta version.

  • Okay... @Winnie @MrRooni any news on this issue?

  • Wildcat_1Wildcat_1 Junior Member

    Just as a data point. I too tried @MrRooni instructions above and this did not work for me, still shows the failed restoration even though the App Store public version did have the purchases restored without issue, Tesflight version does not. Running iOS 9.3.2 dev beta 3 for reference.

  • Just an update from me, I installed the App Store version and the purchases restored instantly, then overwrote with TestFlight version and they were no longer there and failed to restore.

    I realise we are partaking in a beta test here and bugs like this will crop up so I'm not worried and please take your time. We can all manage.

    Still a big 1Password fan hoping for a 1Password laptop sticker too somehow! ;-)

    Neil

  • nmottnmott 1Password Alumni

    @ollifi our development team is still working on figuring out the cause of this problem and how to address it.

    @rctneil thanks for the info and your patience! I'm also curious about the sticker situation; I might give the ones @iamecho posted a shot.

    8-)

  • @nmott I found the site on the 1Password blog https://blog.agilebits.com/2016/02/26/agilebits-family-gathering-2016/ and if you look in the comments section @SaraMinisterOfMagic says:
    "That is definitely a link we share for stickers."

  • nmottnmott 1Password Alumni

    @iamecho perfect, thanks!

  • MrRooniMrRooni

    Team Member

    Hi folks,

    We've got a beta update coming out (hopefully today) that will include some additional diagnostic information for us. It will be 1Password 6.4.1. If you are still seeing this problem after installing the App Store version and then installing the TestFlight version please send in a fresh diagnostic report. Thanks!

  • FolsomRiderFolsomRider Junior Member

    Installed the App Store version, then attempted to use TestFlight to install the 6.4.1 beta. Get this error message: "Could not install 1Password - Password Manager and Secure Wallet. The app can't be installed because it is invalid. Try again."

  • Wildcat_1Wildcat_1 Junior Member

    @MrRooni has this been removed from TestFlight now as I don't see 1password showing in TestFlight at all today even though I have the last beta (not one mentioned today) installed still. ?

  • It looks to me like it has also been removed from Testflight as I do not see it.

  • Wildcat_1Wildcat_1 Junior Member

    @Micro23 thanks for confirming you were seeing the same, thought it was just me :)

  • Wildcat_1Wildcat_1 Junior Member

    @MrRooni @nmott @Winnie Can one of you confirm that you've officially pulled 1Password from TestFlight at this time ? Should we be expecting 6.5.1 to show up soon and that will then be available in TF again ? Thanks so much

  • MrRooniMrRooni

    Team Member

    Hi @Wildcat_1. We're experiencing some technical difficulties with TestFlight at the moment. We're hoping to get things back up and running soon.

This discussion has been closed.