Can't delete individual tag when multiple tags are present

Hi peeps,

I have found that when I have an item with multiple tags that I'm unable to remove them individually. I can touch one, and then the cross-in-circle appears, but touching the cross does nothing to delete it. Pressing on the field brings up the cursor for entering a new tag, and pressing backspace will always delete the right-most tag, regardless of if the left-most one is highlighted.


1Password Version: 640010
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • iamechoiamecho
    edited April 2016

    @smallcheese Hey Tom - I just tried what you said on my iPhone 6S and I was able to delete one of three tags in a login. I found I had to hit the "x" exactly to make it delete.
    IP Version: 640010

  • Hey @iamecho!

    I tried hitting it a lot last night and couldn't make it work for me. I reckon you may have got lucky, the touch area must be only a couple of pixels wide!

  • @smallcheese Smaller fingers maybe ;) but I do see what you mean .. try double clicking the "x". I just tried it again and it took me 3-4 hits on the "x" to make it delete, but it eventually did. I think you've probably found something here though ...

  • Just tested this again and you are right, I could eventually do it but it's a bit irritating to get right. The screen focus also moves about all over the place when editing take, whether adding new or trying to edit/delete existing ones.

  • WinnieWinnie 1Password Alumni
    edited April 2016

    Hi @smallcheese,

    thanks for your feedback. I just tried deleting some tags on my 6 Plus and had no problem hitting the x - maybe I just have smaller fingers :(

    I could however reproduce the annoying scrolling of the edit screen after each delete. We will look into this.

    ref: OPI-3496

  • You also have a 6 plus! ;-)

  • WinnieWinnie 1Password Alumni

    @smallcheese it's a great device, isn't it? :) I've been thinking if allowing to tap on a highlighted tag as a whole - not just the x button - would help with deleting tags. Maybe that would be the solution to fix the small tap target of the x button.

  • Tap to highlight and backspace would do the job. That was what I instinctively did the first time I couldn't tap the X, but it deleted the rightmost tag as that's where the cursor was focussed.

  • WinnieWinnie 1Password Alumni

    @smallcheese the way I delete tags the keyboard is not even showing - so using backspace would not be an option. We'll brainstorm solutions in the development team and see what we can come up with.

    Thanks for your input! <3

    ref: OPI-3497

  • Ah, I think the keyboard shows up once you've missed the target and thus 'tapped' into the field and it thinks you want to type a new tag.

  • WinnieWinnie 1Password Alumni

    @smallcheese correct. The keyboard only shows up when you didn't tap on a tag and then you can add a new tag or delete the last one using backspace.

This discussion has been closed.