Changes not syncing back families

Changes made to logins in either the desktop or universal version are not synced back to the Families website (and therefore no other clients). This does not seem to be a problem with newly added entries - only changes appear not the propagate. I have tried a manual sync from both Windows U/D and doesn't seem to help.

Follow-up question: How long should we have to wait to see changes made elsewhere (i.e. Mac, or Families web) reflected in the Windows apps?

Thank you!


1Password Version: 2016.5.2401d
Extension Version: 4.5.6.7
OS Version: Win10 14342
Sync Type: Families

Comments

  • SergeyTheAgileSergeyTheAgile

    Team Member

    @jhamer thanks for reporting of this issue. Normally changes should be sent out with next sync, which is invoked right after edit is saved to local database, on unlock or manually. Please try to unlock app and after 20 seconds type /log in search box, please copy and send it to [email protected] so we can investigate and fix.

    Changes made in other apps should appear in universal app within probably few seconds, desktop app do not listen to change notifications yet, manual sync or unlock is required. It will be added soon.

  • My subsequent tests to gather logs replicated within seconds as you would expect. Worked for both adds and changes. I'll keep my eyes open for future sync delays and grab logs if it reappears. Thanks again.

  • brentybrenty

    Team Member

    @jhamer: Ugh. Of course it works now when you're trying to reproduce the issue! :lol:

    Thanks so much for your attention on this issue. Be sure to let us know if it happens again!

  • MikeTMikeT Agile Samurai

    Team Member
    edited May 2016

    Hi @jhamer,

    Do you by any chance have a lot of items in your 1Password database? Can you switch to the All Vaults view and tell us what item count is next to the All Items category?

  • I haven't moved everything over from .opvault yet, and I only have the Families account added to the Windows desktop versions. 490 items currently listed in Families All Vaults. Not an exceptionally large number I don't think. By my estimate it's taking 5-6 seconds to manual sync, or to sync after opening the app. Then you must click on the various categories to have the number count refresh, or change the view somehow to trigger the field display refresh. The sync time is completely reasonable, and I'm sure the display refresh will smooth out along the way.

    I've tested the syncing several times again in multiple ways and it's working as Sergey describes. Go figure. I'll grab logs if it starts happening again.

  • I will add that moving an entry between vaults on Mac/Web, then waiting for that change to reflect in Windows does seem to take much longer than adds or delta changes.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @jhamer,

    Thanks for the details, that helps a lot. It should be less than a sec to sync but the UI refresh might take up the longest for the moment. We are working on a few things that will improve this.

This discussion has been closed.