Inconsistent 1Password mini launch after restart

mschmittmschmitt Junior Member

I've noticed that apps such as 1Password that use the "modern" method of Login Items, where there's an app bundle in the main app's LoginItems folder, do not consistently re-launch after a reboot, especially after a restart triggered by installing an OS X security update. 1Password is one such app, and in fact it didn't relaunch after I applied the last security update a few days ago. But sometimes it does relaunch, and other apps don't. On the other hand, this morning I shutdown and restarted, and everything launched.

Do you have any idea what's going on here? Is this truly random or is there some hidden consistency? Is it an OS X bug (I'm on 10.10.5), or is it a problem with how the code is enabling the login item, or both? It's like whatever it is doing to set the login status as enabled isn't always sticking.

FWIW, I have 4 modern login items enabled (1Password, Amphetamine, DisplayMenu, Revisions) and I think they've all failed to launch at least once.


1Password Version: 6.3
Extension Version: Not Provided
OS Version: OS X 10.10.5
Sync Type: Dropbox

Comments

  • brentybrenty

    Team Member

    @mschmitt: Can you elaborate on what you mean by "modern method"? Are you referring to having 1Password launch on startup (as in Users pref pane), to launchd opening 1Password mini to display the menubar icon, or something else entirely? Depending on when each of us started using Macs, we may have very different ideas about what's "modern". ;)

  • mschmittmschmitt Junior Member

    By Modern Login Items I meant using SMLoginItemSetEnabled to launch an app or helper from the app’s Contents/Library/LoginItems folder, as opposed to Login Items in the Users & Groups preference pane. I think the reason for the new method is that sandboxed apps aren't allowed to modify the plist that holds the preference pane Login Items.

    I'm not referring to launchd here. I see that 1Password is using launchd to start the 1PasswordAgent. I assumed this launch agent wasn't responsible for starting 1Password mini, just because 1Password mini is having the same inconsistent launch after restart as the other applications that start at login using the "modern" method described above.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @mschmitt,

    Thank you for the clarification! So, it sounds like 1Password mini sometimes doesn't launch automatically after restarting your Mac (but sometimes does). If I understand, other apps on your Mac which work similarly can also sometimes fail to launch on startup? In that case, it might be a general issue on your Mac, but we'll be happy to see if we can help.

    First, is there any chance you explicitly quit 1Password mini before restarting your Mac? If so, it won’t start up again until you open the main 1Password app manually.

    If you're not quitting mini before restarting, please open the main 1Password app and go to 1Password > Preferences, then select the General tab and make sure the option for Always keep 1Password Mini running is enabled. Assuming it's already enabled, please try this:

    • On the Preferences > General tab, uncheck the option for Always keep 1Password mini running.
    • Close the Preferences window, then quit 1Password.
    • A dialog will appear to ask if you want to enable 1Password mini - click the Do not enable button.
    • Open 1Password again, go back to Preferences > General, and re-enable the option to keep 1Password mini running.
    • Quit 1Password again, then reboot your Mac.

    When your Mac restarts, does 1Password mini launch automatically? I know it works after some restarts but not after others, so it might take a few of those to tell for sure if the problem still happens or not. Let us know how it all goes and if you run into the problem again. Thanks! :)

  • mschmittmschmitt Junior Member

    Following the above procedures resulted in 1Password mini, as well as the other apps in question, restarting at login. But I expected that, since the problem seems to occur most often when the restart is for applying a OS X update, such as the recent Security Update 2016-003.

    By the way, when this does occur, it isn't because 1Password has lost its "Always keep 1Password Mini running" setting (nor similar settings on any other affected app). When it occurs, and I manually launch 1Password, 1Password mini launches and it persistent across restarts once again ... until the next time that it doesn't.

  • Drew_AGDrew_AG 1Password Alumni

    I'm glad it seems to be ok for now @mschmitt - but like you said, since it doesn't happen every time you restart your Mac, it's hard to know for sure if/when it will happen again.

    The Always keep 1Password mini running option works by registering 1Password mini with launchd on Mac OS X, and the steps I gave you reset/re-register that entry. If the 1Password mini launchd entry was causing the problem, those steps should fix it. However, since the same problem has also been happening with other apps, I have a feeling something else is causing it. If it happens again for 1Password and other apps, we'll be happy to see if our developers have any other suggestions.

  • mschmittmschmitt Junior Member

    OK, so I just did the following:

    1. Just in case, followed the procedure posted in the May 31 comment: changed "Always keep 1Password Mini running" to disable, closed 1Password, opened again, enabled "Always keep 1Password Mini running" again.
    2. Installed OS X Security update 2016-004.
    3. Computer restarts.
    4. Upon restart, 1Password Mini did not launch. (Which is as I expected.) The only 1Password process running is the other one (the database server? It isn't running at this moment so I can't tell you the exact name).
    5. Opened the 1Password app. 1Password mini instantly launched, because
    6. Verified that the preference is still set to launch it always.

    This confirms what I said before. Whatever method you're using to launch 1Password mini does not (consistently) survive security updates.

  • khadkhad Social Choreographer

    Team Member
    edited July 2016

    @mschmitt,

    Since you said the issue is affecting other apps (not just 1Password) then it sounds like we can agree that is an OS X bug, not a bug in 1Password. It's also something Apple very well have resolved in the current version of OS X. (You mentioned you are seeing this in OS X Yosemite.) I have never noticed this in El Capitan, and this is the only report I've seen of it on any version of OS X.

    It certainly is an interesting issue, though. I am curious to see if anyone else reports the same thing now that this discussion is indexed on Google.

This discussion has been closed.