1Password crashes when trying to use Keyboard extension

I'm trying to use the 1Password keyboard to enter login information, but after unlocking I get a notification with "Unfortunately 1Password has stopped". I tried both fingerprint and master password to unlock, same result.
If I open the 1Password app, it unlocks and shows my information just fine.

This bug is apparently related to the whole account syncing bug. I disabled my account and reenabled it and I can use the keyboard correctly again.

Phone: Nexus 6P


1Password Version: 6.3.2b3
Extension Version: Not Provided
OS Version: Android 6.0.1 (May security patch)
Sync Type: Families

Comments

  • saadsaad

    Team Member

    Thanks for reporting this crash and letting us know how you were able to workaround the issue. I will let the dev team know, so we can look into this further. Thanks.

  • I'm seeing the exact same issue on a Samsung GS7. Does the workaround mean I need to remove my families account and re-add? Not seeing other options for disabling the account. Thank you.

  • Yes, that's exactly what I did.

    Luckily Families syncs really fast, but it's a pain having to grab a QR code to re-enter my details.

  • jhamerjhamer
    edited June 2016

    Thanks @ChaconC, appreciate the clarification. That resolved the issue for me as well. Agreed that it's a pain though.

  • ChaconCChaconC
    edited June 2016

    @saad
    Sadly, the issue has resurfaced today.
    This time I didn't have to re-enter my details. I opened the main app and now the keyboard works. But it was crashing whenever I unlocked from the keyboard.

  • I think this problem is actually from having rebooted my phone and trying to use the keyboard before having opened the app.

  • saadsaad

    Team Member

    Thanks for reporting this, @ChaconC. We were looking into this crash and you helped us figure out how to replicate the crash on our devices. We will have this fixed very soon.

This discussion has been closed.