I cannot create an account for our Team on my local Mac 1Password app

After entering my credentials, I get "The operation couldn't be completed (NSURLErrorDomain error -1200.)

I've tried quitting Safari/Chrome; locking/unlocking 1Password app and rebooting my laptop. Still seeing it.


1Password Version: 6.3.1
Extension Version: 4.5.6
OS Version: 10.10.5
Sync Type: ?

Comments

  • I should add that it was previously there and I had both local and Team access. I had removed it since I was trying to Share an item and it wasn't showing up "in the cloud".

  • rudyrudy

    Team Member

    hi @drewpink,

    That particular error code means that it wasn't able to make a secure connection to the server. Do you happen to be configured with a proxy on your local network or have other software on your mac that could interrupt the secure connection process?

    Rudy

  • No proxy. And I just turned off AVG Antivirus and still no luck. Any other suggestions?

  • And I can log into the Team via Chrome.

  • I tried de-authorizing all browsers and my laptop. Still no joy.

  • drewpinkdrewpink
    edited July 2016

    Here is what /var/log/system.log shows:

    Jul  1 12:35:26 DrewLucidLaptop.local 2BUA8C4S2C.com.agilebits.onepassword4-helper[1983]: CFNetwork SSLHandshake failed (-9824)
    Jul  1 12:35:27 --- last message repeated 2 times ---
    Jul  1 12:35:27 DrewLucidLaptop.local 2BUA8C4S2C.com.agilebits.onepassword4-helper[1983]: NSURLConnection/CFURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9824)
    Jul  1 12:35:27 DrewLucidLaptop.local 2BUA8C4S2C.com.agilebits.onepassword4-helper[1983]: 631006 [SYNC:(Secondary Thread 0x7fbe2704a1d0):<B5ServerController: 0x7fbe24f14aa0>] E loginWithEmail:password:SRPComputedXDictionary:personalKey:completion: | Failed to lookup auth info: Error Domain=NSURLErrorDomain Code=-1200 "The operation couldn’t be completed. (NSURLErrorDomain error -1200.)" UserInfo=0x7fbe22456da0 {_kCFStreamErrorDomainKey=3, _kCFStreamErrorCodeKey=-9824, NSUnderlyingError=0x7fbe224db350 "The operation couldn’t be completed. (kCFErrorDomainCFNetwork error -1200.)", NSErrorPeerCertificateChainKey=(
        ), NSErrorFailingURLKey=https://***.1password.com/api/v1/auth/***/***, NSErrorFailingURLStringKey=https://***.1password.com/api/v1/auth/***/***/***, NSErrorClientCertificateStateKey=0}
    

    So it is a certificate error.

    Edit: Log redacted by AgileBits admin

  • After some more googling, I tried a brew update, but that didn't help either.

    Next things to consider would be trying the latest beta of 1password, or upgrading to El Capitan.

  • JacobJacob

    Team Member

    @drewpink Thanks for the wonderful load of information. :) I'm glad you use Homebrew, too. Love that thing. We're currently investigating this issue, as I mentioned in a 1Password Families thread on the forum. It looks like the common cause is OS X 10.10.x, but I can't be sure quite yet because I'm waiting to hear back from someone who has upgraded to El Capitan. I'd recommend doing that for now. We haven't been able to reproduce the issue on El Capitan. Let us know how it goes!

    ref: CSI-100

  • khadkhad Social Choreographer

    Team Member

    @drewpink,

    We think we resolved this. Can you give it a go again and let us know if things are working for you now? :)

  • Shall I continue you the El Capitan update, or do you have any other tricks up your sleeve?

  • s/continue you/continue with/

  • sjksjk oversoul

    Team Member

    Hey @drewpink,

    Can you try restarting your Mac, if you haven't done that since khad's comment about resolution of the issue, and see if it works for you after that? Thanks!

  • Too late. :-) I upgraded to El Capitan already.

    Unfortunately, now I'm seeing a straight SSL error :-(. More suggestions?

    I'm on

    1Password 6
    Version 6.3.1 (631006)
    AgileBits Store

  • Hmm...and I get errors connecting to the Apple ID server. So something is messed up with SSL for anything but HTTPS websites, it appears.

  • khadkhad Social Choreographer

    Team Member

    @drewpink

    It sounds endemic to your entire system then, not just 1Password. Correct?

    I know you said you disabled AVG, but I've seen some instances where some of that type of software — I can't remember if that definitely includes AVG or not — can keep its claws in things even after it appears disabled and/or uninstalled.

    But it may turn out to be something you can solve in Keychain Access. I remember when I upgraded to either El Cap or Yosemite, I had to actually delete a cert that was causing problems every time I tried to interact with the iTunes Store. I wish I had made better notes about what I did to resolve that.

  • khadkhad Social Choreographer

    Team Member

    @drewpink,

    Yeah, if it wasn't that it was extremely similar. I suspect that's what it was.

    Please do let us know once you figure it out. I am extremely curious, and perhaps it may come up for some other 1Password users as well.

  • marekr22marekr22
    edited May 2017

    I had exactly same issue and found a solution.
    Problem is that NSURLSession is able to share state with other application.
    In my case user used Safari on to visit some service and selected some invalid client identity certificate (which is configured as optional on server).
    From that point my application was receiving this strange error.

    To restore system state where it works again:
    1. close application
    2. go to Safari, go to preferences
    3. select privacy tab
    4. select "Manage Website Data…"
    5. in search type something which will help find problematic site
    6. remove found items (or remove all items if you don't know what should be removed)
    7. Start application again
    8. problematic error will vanish

    System update probably is doing the same thing, that it is why if fixed the issue.
    I was able to reproduce it on OS X: 10.10, 10.11 and 10.12 and also workaround fix the issue on all versions.

  • BenBen AWS Team

    Team Member

    Excellent! Thanks for sharing this information @marekr22. Hopefully it is helpful to others who run across the same situation that you did.

    Ben

This discussion has been closed.