Browser extensions not working in Chrome, Mozilla, IE browser's running windows 7 professional x64.

evankevank
edited July 2016 in Windows Beta

Browser extensions not working chrom, mozilla, IE browser's running windows 7 professional x64. not sure if its the culprit, but the password app for win just updated to v. 6.0.183d. I have uninstalled and re-installed extensions. I click on the 1password extension and it either open the 1password app and that's it or if 1 password is running it does nothing.


1Password Version: 6.0.183d
Extension Version: 4.5.8 Mozilla, 4.5.8.90 chrome
OS Version: Windows 7 x64 pro
Sync Type: 1password 6 beta

Comments

  • evankevank
    edited July 2016

    All browser extensions not working chrome, Mozilla, IE browser's on a windows 7 professional x64 platform. Not sure if its the culprit, but the password app for Windows just updated to v. 6.0.183d. I have uninstalled and re-installed extensions. I click on the 1password extension and it either opens the 1password app and Does nothing else, or if 1 password is running in the background nothing occurs.


    1Password Version: 6.0.183d
    Extension Version: 4.5.8 Mozilla, 4.5.8.90 chrome
    OS Version: Windows 7 x64 pro
    Sync Type: 1password 6 beta

  • brentybrenty

    Team Member
    edited July 2016

    @evank: I've merged your similar posts and moved them to the Windows beta category of the forums since that's what you're having trouble with.

    That update was released a few days ago and we haven't had other reports of it breaking browser integration. Do you maybe have 1Password 4 installed and running in the background? That will take over communications with the browser extensions if present.

    To be clear, 1Password 6 does not work with Internet Explorer. And in order to use the beta with Firefox or Chrome, the 1Password will need to be open and unlocked. If you then click the button or press Ctrl Alt \ it will fill (or offer a list of) logins matching that URL. If there are none that match, it will display "No matches found".

    Please let me know what you find. I look forward to hearing back from you! :)

  • I'm running into the same issue. The browser extension does nothing on either Firefox or Chrome. I've uninstalled 1Password 4 and removed the previous standalone vault from 1Password 6. So now all that's running is 1Password 6 logged into my 1Password account.

  • brentybrenty

    Team Member

    @tsosebee: If you're still having trouble, go ahead and restart Windows. Open 1Password and unlock it. Then open the browser and go to a URL you have a login saved for. Press Ctrl Alt \ and 1Password should fill it. If that's not happening, be sure to check to see if disabling other extensions or "security" software helps, if there's some sort of conflict. Let me know what you find!

  • tsosebeetsosebee
    edited July 2016

    I noticed last night that when I migrated my data from my standalone vault to my personal vault using the 1Password 6 beta (6.0.183d), that the websites in each of the logins didn't get copied over. I manually copied them over to my personal vault.

    After manually copying the websites over, I was able to use the browser extension to fill in the password. There was still no menu on the browser extension in Firefox, but it did get the password from the app and copy it into the login field on the browser.

  • MikeTMikeT Agile Samurai

    Team Member
    edited July 2016

    Hi @tsosebee,

    That's a bug in the migration process from a agilekeychain vault to the vault in the 1Password account, the URLs aren't carried over, we're working on fixing this ASAP. We've already done the first part, which is to implement the 1PIF (1Password Interchange File) import support, this was shipped in the last update and it works to migrate URLs correctly from agilekeychain-created export files as well as the opvault export files. We plan to reuse the same code to redo the migration process next.

    I'm glad you got it to work now with the extension. Right now, it is limited to the basic login filling but a lot of updates are coming to implement the rest of the extension features, including a 1Password menu that should show up when you click on the 1Password icon.

  • so I got it working after removing 1password beta 6 and installing 4. Also I noticed the url's not carried over so I just loaded a backup vault to mitigate that issue for now. Thanks Everyone!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @evank,

    If you want to import it correctly with the URL included, let us know and we'll be happy to help you with that or you can wait for us to fix the migration bug soon.

  • Thanks!! I will let you know. I have to deploy this on 5 endpoints.

  • brentybrenty

    Team Member

    Great! We're here for you! :)

This discussion has been closed.