Autosubmit not working in Chrome or Firefox

This discussion was created from comments split from: Auto Submit not Working.

Comments

  • Same issue here.

    Auto-filling working.
    Auto-submit not working on Firefox nor Chrome, but works on Safari.

    1Password version 6.3.2 downloaded from agilebits.com.
    Firefox version 48.0.2, 1Password Firefox addon version 4.5.9
    Chrome version 55.0.2853, 1Password Chrome addon version 4.5.9.90

  • Auto-submit not working on Firefox nor Chrome, but works on Safari.
    This is really annoying since it's worked before and I'm used to this functionality.

    1Password version 6.3.2 downloaded from agilebits.com.
    Firefox version 48.0.2, 1Password Firefox addon version 4.5.9
    Chrome version 55.0.2853, 1Password Chrome addon version 4.5.9.90

    Auto-filling works.


    1Password Version: 6.3.2
    Extension Version: 4.5.9
    OS Version: OS X 10.10.5
    Sync Type: Dropbox

  • brentybrenty

    AgileBits Team Member

    @juhoh: I hope you don't mind, but I've split you off into a separate discussion in the browser filling category of the forums since you don't seem to be using the Windows beta version the others in the discussion were.

    It sounds like you're actually using 1Password for Mac. Is that correct? Can you also double-check the browser versions you're using? The current version of Chrome is 53 (released last week), so I wasn't sure if that was just a typo.

    Also, can you provide the URLs for two or three sites where you're encountering trouble with autosubmit in Firefox and Chrome, but work in Firefox? I'd like to test this so we can figure out what's going on here. Thanks in advance! :)

  • brentybrenty

    AgileBits Team Member

    @juhoh: It looks like you posted the same thing in a separate discussion, but mentioned that you're using Chrome Canary. That makes more sense. While prerelease browsers are not supported, I didn't have any trouble getting autosubmit to work in the stable release of Firefox. Definitely try restarting your Mac (and therefore Firefox). I actually couldn't get 1Password to work there at all immediately following an update until I restarted, but it worked normally after restarting. Let me know what you find!

  • Just an update.. Upgraded to 6.0.199 this morning and still no love on the Chrome auto submit. Haven't tried any other browsers. Thanks for the hard work guys! :)

  • juhohjuhoh
    edited September 2016

    @brenty: yeah I posted that first comment in the wrong thread and couldn't remove it, my bad.

    I'm using Firefox on a Mac. I have the newest versions of both of the apps and the newest version of the add-on. I found the problem, I'm using the pentadactyl add-on for Firefox (specifically the signed version) and 1Password doesn't autosubmit while I've that add-on installed (whether the add-on is enabled or disabled).

  • brentybrenty

    AgileBits Team Member

    @juhoh: No worries! And just so you don't wonder, I edited your last post to fix the first link. For some reason it ended up going to some random forum post from 2008. :lol:

    While it seems odd that the autosubmit problem would persist even with the add-on disabled, if it's trying to modify or intercept input, that might make sense since 1Password uses a few tricks to simulate user submission of a login form. Thank you so much for sharing this! It's good to know the cause.

This discussion has been closed.