Keyboard shortcut hotkey assignment broken in beta 206, fix coming

brentybrenty

AgileBits Team Member
This discussion was created from comments split from: Keyboard shortcut Ctrl+Alt+\.

Comments

  • Jörg B.Jörg B. Junior Member

    Good evening,

    what has bugged me in previous beta versions already is that 1Password 6 by default assigns a shortcut to [Ctrl]+[Alt]+\ .. however that's exactly the key-combo I need to enter i.e. when entering file paths (well at least for German Keyboards).. which means whenever I want to enter a path in Explorer or the command line.. the 1Password mini window pops-up... and I basically CANNOT enter paths while 1Password is running.. unless I change that shortcut in 1Password options.. which I did.. but still.. it still pops-up with the defaullt [Ctrl]+[Alt]+\ combo (see attached screenshot.. I've mapped the combo to [Ctrl]+[Alt]+# (quite a while / couple system and app restarts ago).

    So.. I can either always close 1Password whenever I want to enter paths.. or well.. not enter paths.

    It would be great if the key combo was a) fully customizable (including the Modifier Keys / Ctrl / Alt / Shift / whatever b) respects / actually considers my changed shortcut and/or c) could at least be disabled altogether.

    -J


    1Password Version: 6.0.206d
    Extension Version: 4.6.0.1
    OS Version: Win10 64bit (German)
    Sync Type: Not Provided

  • I just uninstalled 6.0.186d and installed 6.0.199 manually as I've been stuck on 6.0.186d for a while because the app didn't discover any updates, which it had done before.

    Right of the bat I noticed that the default keyboard shortcut Ctrl+Alt+Backslash now works on my Swedish keyboard layout, which would be a good thing if it didn't mess up my workflow. As soon as I try to write a backslash it just brings up 1Password instead, hence why I had to type it out above...

    I jumped into the options menu and changed it to the same key (n) I used in 6.0.186d and restarted the app, but it's not working anymore, it still uses backslash. I've tried switching to different keys with the same result.

    Have you disabled the option for changing the key?

  • SergeyTheAgileSergeyTheAgile

    AgileBits Team Member

    @Backspaze no, we didn't disable that option, it sounds like a bug. I'll go and check it out. Thanks for letting us know!

  • SergeyTheAgileSergeyTheAgile

    AgileBits Team Member

    @Backspaze you are right, it was registering hot keys before reading your settings. The fix is made and will be available for download tomorrow. Thank you!

  • The latest update broke my keyboard shortcut to fill in passwords. I've tried changing the hotkey, and restarting the app several times. Auto-filling from the browser extension, by selecting the chrome icon works, just not the ctrl + [alt] + key combo.


    1Password Version: 6.0.206
    Extension Version: 6.0.206d
    OS Version: Windows 10
    Sync Type: my.1password.com

  • brentybrenty

    AgileBits Team Member

    @hissingpanda: I'm sorry for the trouble! We've identified a bug with the hotkey behaviour in build 206d, and we have a fix coming in the next update, which should be available tomorrow. Thanks for your patience!

  • brentybrenty

    AgileBits Team Member

    @Jörg B., @hissingpanda: I hope you don't mind, but I've merged your posts with the existing discussion in the Windows beta category of the forums. We're aware of the issue and a fix is coming. Thanks for bringing this up!

  • Jörg B.Jörg B. Junior Member

    Great, thanks @brenty!

  • SergeyTheAgileSergeyTheAgile

    AgileBits Team Member

    An update has been released, please give it a try and let us know if it fixes the problem ;)

  • I just downloaded the update and the shortcut is working fine now. Thank you for the very speedy fix!

  • MikeTMikeT Agile Samurai

    AgileBits Team Member

    On behalf of Serg, you're welcome!

  • I'm using to most current (public) version on Windows 10 (Surface Book) with the Swiss German Keyboard Layout. Is there a way to completely deactivate the shortcut thing of 1password? I'm still unable to type in the Backslash.

  • brentybrenty

    AgileBits Team Member

    @haeme_ulrich: It isn't possible to disable they keyboard shortcut completely, but you can customize it to better suit your preferences — or to change it to something completely out of the way — in 1Password Settings > Options > General. Cheers! :)

This discussion has been closed.