howtogeek login issues

Comments

  • BobArch2BobArch2
    edited September 2016

    Having a similar situation regarding a secondary window (login) not being filled. The site is:

    https://discuss.howtogeek.com/

    In the initial stage, I went to the site, clicked on the Login icon where the overlay (second) window popped up. I entered my userid and password then directed 1Password to save the information. Which it did. Then clicked on the second Login link which took me to my account in the discussion forum. Then logged out of my account and tried using 1Password to enter the site. No go.

    Any suggestions?

    Edited to add: Running 1Password 4.6.0.604. Default browser: IE11. Had tried Firefox and had same result.

  • brentybrenty

    AgileBits Team Member

    @BobArch2: Thanks for reaching out! To be clear, 1Password cannot click to open popup windows like this for you. But once you do that, 1Password can fill.

    I was able to use 1Password to save and fill a new login in Firefox (this won't work in IE since it limits access to frames). In many cases manually saving a new login for the site will allow 1Password to save additional information from the form. Just try these steps to save the login manually:

    1. Navigate to the website
    2. Enter your login credentials
    3. Click the 'keyhole' icon to bring up the extension
    4. Click the 'gear' icon for Settings
    5. Click Save New Login
    6. Give it a name and Save
    7. Close the webpage and select your new login from the extension to have 1Password Go & Fill
    8. Submit the form manually if you have autosumbit disabled

    I hope this helps. Please let me know how it turns out! :)

  • @brenty: tried your approach and no difference. That is, it will not fill the parameters and just stays on the main site. Here is a snapshot of the 1Password attributes (with username and password blurred out) if it helps:

  • brentybrenty

    AgileBits Team Member

    @BobArch2: I hope you don't mind, but I've split you off into a separate discussion so we can focus on your issue, since it involves a different website.

    I'm really sorry about this. My login appears to be the same, so I was trying to figure out what was different. But I see the problem now. It seems like there is some bug in the current stable extension which you're using, but I actually had the beta version installed where this is fixed.

    The good news is that we do have a solution for this! You can either wait until the new version is released to the stable channel, or install the beta extension (no need to use the beta version of the app though) in Firefox now for it to work.

    Again, I apologize for not being on the same page with you there. Let me know if that helps, and if you have any other questions!

  • @brenty: No problem with split up the thread. Glad to hear it "ain't-me" but a bug waiting to be fixed. :-) I'll try the beta extension in Firefox. Since IE11 is my default browser is there any hope that a change will be forthcoming to correct the issue in IE11?

    Cheers,

    Bob

  • brentybrenty

    AgileBits Team Member

    @BobArch2: Unfortunately the problem in IE is fundamental to the limitations of the browser itself. It simply doesn't give 1Password (or any add-ons) access to those fields. And since Microsoft has ceased development there, I don't expect that any changes will be forthcoming. Fortunately — unlike the past — we have some great alternative browsers these days. Cheers! :)

This discussion has been closed.