Windows 10 update 6.0.239 does not install

When I start the app I get asked to update. It goes through the motions of downloading, then Windows asks me if I want the .msi to allow changes, then the window closes. Next time I open the app I get the exact same message and nothing has changed. If I need to send a log file or something I can.


1Password Version: 6.0.183
Extension Version: 4.6.1
OS Version: Windows 10 Anniversary
Sync Type: Family?
Referrer: forum-search:update 6.0.239

Comments

  • AlexHoffmannAlexHoffmann

    Team Member
    edited September 2016

    Hi @liberatr,

    We're sorry to hear you're having this issue. Can you please download the installer manually and run it?
    Here's the link: https://rink.hockeyapp.net/apps/0cb99692bcdb47abb89fad56dfd56d0c

    Please let us know if this helps, or if there's anything else we can do for you.

    Cheers,

    Alex

  • liberatrliberatr
    edited September 2016

    Alex, that link does not work for me. "You are not a member or tester of any apps."

    I had tried to track down an installer through the public website, and I get asked if I would like to repair or uninstall.

    If I choose Repair, I get a message "The specified account already exists".

    Since my passwords are synced to my family account, is there any harm in uninstalling?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @liberatr,

    It looks like there was a typo on Alex's link, this is the right link: https://rink.hockeyapp.net/apps/0cb99692bcdb47abb89fad56dfd56d0c (I've edited his post to fix it)

    Which public website did you download it from? Only download 1Password from our sources, not from anywhere else.

    First, it sounds like 1Password is trying to update but it failed and reverted back to the original version you were on. This may be because your .NET version is outdated. Please download and install NET 4.6.2 from here: https://www.microsoft.com/en-us/download/details.aspx?id=53344

    After rebooting, try installing 1Password again from the above link and see if it works.

  • Thanks Mike, that new build worked much better. I got asked to re-sign-in but that's OK.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @liberatr,

    That's great to hear, thanks for letting us know and on behalf of our team, you're welcome.

    We did a monster database redesign in the 197d update and in order to move the data into the new database, everyone had to sign in again to pull the data into the new database. This should be the last time as we're now able to migrate everyone to newer database versions automatically, we've already did this once successfully so far.

This discussion has been closed.