Login to Chase Bank problem

Hi, not able to solve this myself.

Chase bank has changed their website login algorithm in the last month or so. I can't log in at all using Firefox, but I can log in using Chrome.

  1. What happens:
    Using 1P as my bookmarks page, I select Chase Bank and click it. It arrives at https://Chase.com (seems like after a little more going on than normal, probably on the bank's part) with the fields empty. They will not automatically fill in. I do the ctrl>\ and i get a list of this and other Chase banks listed in my list. When I do the ctrl>| it will work, fill in, and log on.

  2. What I did.
    First, I copied the login and put it on a Notepad window (so I could remember it).
    Then I tried adding a new site but using -update the old one. Didn't work.
    Then I tried making a new one and naming it the same BUT adding a 2 at the end. Did not work.
    I checked to make sure Submit = Always.
    Seems like I always have to semi-manually have to log on.

Is there other things I might try to do?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • brentybrenty

    Team Member

    @Peter_Pappas: Admittedly, I usually use Safari to login to my Chase account, so I had to test this to be sure. Using either the stable or beta version on multiple versions of Windows, I was able to save and fill a login successfully.

    Weirdly, depending on the size of the window, the login form is either added or omitted from the page completely. So based on that observation and some parts of your description, I wonder if the problem you're running into is that chase.com is slow to load the login form at all (since it's trying to decide if it even will). That's why they keyboard shortcut works: you've already waited for the webpage to finish loading before doing this. So you may have better luck with https://chaseonline.chase.com/ (which is the page the "Sign In" button takes you to otherwise).

    If you're still having trouble, be sure to let me know the OS, 1Password, browser, and extension versions you're using, the exact steps you're taking, and what is (or is not) happening the way you expect so we can figure out the best plan of action. Thanks in advance! :)

This discussion has been closed.