6.5B23- Safari extension unresponsive after update

SmudgeSmudge Junior Member

This morning 1P updated to 6.5.BETA-23. However, when I tried to use 1P within Safari (10.0 (12602.1.50.0.10) with extension 4.6.1), clicking on the 1P icon in the Safari toolbar did nothing. No errors, popups, or beeps. Note that Safari was already running before the 1P update was applied.

I quit and relaunch Safari and clicking the 1P icon loaded a web at agilebits.com to get the authentication numbers. 1P Mini in the system status bar asked to authenticate if the numbers showing in Safari were the same, which they were. After reauthorizing Safari, everything is working properly. Normally a restart of the app hasn't been necessary but if one is needed, 1P should let the user know. Or if possible, just restart the extension helper process and relaunch it then start the re-authentication.

This might have just a one-time issue that you can't reproduce but should still be aware of. Isn't that what beta testing is all about? :)

Could this be due to running the 4.6.1 extension? Should I be using a 4.6.2beta extension, if there even is one for Safari?


1Password Version: 6.5.BETA-23
Extension Version: 4.6.1
OS Version: macOS Sierra
Sync Type: Not Provided

Comments

  • AGKyleAGKyle AgileSupport

    Team Member

    Hi @Smudge

    I'm not sure I've heard of this one happening with other users. I admittedly haven't kept up with all of the issues users have been reporting on this but I have answered my share of support requests about it and haven't encountered any like it.

    I wonder if maybe Safari was in a bad state and was unhappy about something that prevented the process for working as it should? Hard to tell but we'll keep our eyes peeled for similar issues from other users. Thanks a ton for pointing this out, hopefully it was a one off issue but if it isn't we'll investigate!

This discussion has been closed.