Bug report: Unable to add multiple accounts on iOS

Adding the initial Families or Teams account to the iOS app works as expected, but attempting to add additional accounts results in an indefinite spinning wheel. This is duplicatable on every clean install of iOS 10.1 and 1Password 6.4.5.

This used to happen prior to the most recent update but jumping out of the screen resulted in the account appearing, so I didn't report it; however, now it simply requires the process be started over, at which point the spinning wheel hangs indefinitely.

How can we add multiple accounts in the meantime until this bug is fixed?


1Password Version: 6.4.5
Extension Version: Not Provided
OS Version: iOS
Sync Type: 1Password

Comments

  • UPDATE: It turns out the additional account will indeed be added if you tap on the Settings icon during the indefinite wheel spin. Still, this bug has been present across all iPhone devices I have set up with clean installs of iOS 10 since launch.

  • BenBen AWS Team

    Team Member

    Hi @beyondthepassword,

    Thanks for taking the time to write in. I'm sorry to hear about the frustration. I just tried to reproduce this with 1Password for iOS 6.4.5. (Un)fortunately it worked perfectly for me.

    What I'd like to ask you to try doing is re-creating the problem and then immediately after I'd like to ask you to create a Diagnostics Report from your iOS device:

    Sending Diagnostics Reports (iOS)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

    Ben

  • Thanks, Ben. Unfortunately, in attempting to duplicate this on an already-configured iOS device results in a new issue: Deleting the Teams account and attempting to re-add it via the QR code on the Mac app results in 1Password on iOS warning me that the Teams account is already added. I then return to the accounts screen in Settings and sure enough, the account appears again—despite having been removed.

    Ultimately, either way the accounts are added, but as someone who's part of one Families account and two Teams accounts, I've run into the original issue on every iOS device I've set up for our users since doing clean installs of iOS 10 on multiple devices. The Families account always adds without issue but the additional Teams accounts always hang with the spinning wheel—however, tapping the Settings icon allows you to exit the final screen and the account appear correctly. It's odd behavior, for sure.

  • BenBen AWS Team

    Team Member

    Agreed -- I have a Families account added, and added a Teams account, and did not experience the issue you described. Is this happening on iOS 10.1? I'm scratching my head as to what may be different enough about our setups such that you'd see this on every device and I'm unable to reproduce it...

    Ben

This discussion has been closed.