Issues logging into TopCashback website

There seem to be problems using autofill on the TopCashback website https://www.topcashback.co.uk/

When I try to login at https://www.topcashback.co.uk/logon?PageRequested=https://www.topcashback.co.uk/Home (which you get if you click on the Login button on the home page) or https://www.topcashback.co.uk/logon?PageRequested=https://www.topcashback.co.uk/account/overview (which you also sometimes get from other locations) the username and password are autofilled and it appears to try to log in, but you simply remain on the login page.

Initially I assumed it was an auto login issue so I set the option to never auto login and tried again. The username and password were autofilled but if I then clicked on login to log into the site, it still returned me to the login page.

The only way I am able to log into TopCashback is if I use manual fill for the username and password.

I'd be grateful if you could take a look at this and see if this is something that can be improved in 1Password. If it isn't and the site is the problem, then exact details on the issue and how it could be fixed would be appreciated as I can then feed that back to the website in the hopes that they might change things.

Thanks!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Hi @Martok,

    I think we're going to need a few more details from you. I visited the site and created a test account given the issue only occurs during submission. I logged out of the freshly created account and logged back in using 1Password. It was successful straight off the bat. So the most likely cause is if I'm testing a different configuration from you.

    I was testing 1Password 6 (beta) for Mac with my preferred browser Vivaldi and version 4.6.2 of the 1Password Browser Extension. I would like to learn:

    • What version of 1Password you have and for what platform.
    • Your preferred browser.
    • The version of the 1Password Browser Extension installed.

    We'll see if it's a version thing and how to proceed from there.

  • Hi @littlebobbytables

    Apologies for not filling in the relevant details as I had the same issue on multiple browsers.

    I have tested this on Mac OS Sierra using the latest versions of Chrome, Firefox and Safari. I have 1Password 6.5.2 (Agilebits Store), 1Password 4.6.2.90 browser extension and I am on a Families subscription.

    I just tested it on Android with Chrome and 1Password 6.5 Beta-5 and it was fine with that.

    Just to double check, if you close your browser, open it again and then try to login, is it still fine for you? I have a vague feeling that when I first created the login and immediately re-tested it (which I always do just to be sure) that it worked fine then and it was only subsequent visits that this issue has manifested.

  • Hi @Martok,

    I'll do a bit more testing and see if we can pin this down. Cheers for all of that extra information, at least we should be getting similar results as we seem to be testing generally the same setup.

  • @littlebobbytables just giving this thread a bump to see if you have been able to replicate this issue and, if so, got any solutions in mind?

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @martok Lil Bobby is off today, so I thought I would try to help. I see that the page is fairly simple and the username and password are indeed filled in for me. So the question is what might be happening on your end that's a little different. There are a couple of things that we see happen from time to time:

    1. Some sites have issues when we perform autosubmit. Could you try disabling submit for this Login by editing it and setting Submit to Never? This will require that you submit the page but it will also help us rule out a strange interaction with our autosubmit.
    2. Some sites don't properly pick up our Javascript events. Could you fill the Login and then in each field, type and then delete a single character. Then, try submitting the form. This will help us make sure that all their various bits have been twiddled.
    3. If you save a new Login in the main application rather than in the browser, does that make a difference? The Login I was testing with I created in the main application. For a simple site like this, it really shouldn't matter, but it's worth ruling out anyway.

    Thanks!

    --
    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

  • MartokMartok
    edited December 2016

    @jxpx777 I have tried each of the steps you suggested. I now have a working login but I still have a puzzling issue from this.

    1. Removed the autosubmit, no change - still returned me to the login page after autofilling details and then manually submitting.
    2. Added and deleted a single character in each field as suggested - still returned me to the login page after autofilling details and then manually submitting.
    3. Created a login in the main application - this worked! This worked with auto submit too

    Following 3, the only thing that was different was the website field. In the one that didn't work, I had https://www.topcashback.co.uk/logon?PageRequested=https://www.topcashback.co.uk/Home whereas in the manually created one I had https://www.topcashback.co.uk/ So, I edited the original one so that the URL was the same ie https://www.topcashback.co.uk/. I tested it and lo and behold - it still doesn't work!!

    So I now have 2 identical logins for the same site. All details are exactly the same as each other. The only difference I can see is when I look at the web form details stored in the login, the original one has these fields:


    (the 3rd & 4th fields are filled with username & password respectively. The 5th field has a long key-type input comprising of letters and numbers with dashes in between groups of these. I've not included the info in case it is compromising in any way)

    whereas the one I created in the main application only has these fields:

    So whilst I now have a working solution, I'd be interested to know what has gone on with the original login, why it's preventing the login working and whether this is a 1Password issue or TopCashback.

  • Hello @Martok,

    Sorry for not getting back to you and thank you for pinging us for the reminder.

    I'm suspecting this field titled ctl00$GeckoOneColPrimary$Login$token is storing something the page uses and we're overwriting it with the old token. The result is the page doesn't like this when it checks the value. What I'm not sure about is why use a text field to store a token if it being altered is a problem. The Login manually created in the main window avoids this by having no knowledge of the page as does a Login item created on the registration form. You've only been caught by this because 1Password created the Login item from the Login page. It's a tough one as there are plenty of sites where we could need to work with a field like the one they're using for the token so I'm not sure what we could do.

This discussion has been closed.