Apple Watch app not showing data

2

Comments

  • Thank you very much.
    Have a nice weekend

  • I sent a report. ID [#RIQ-95198-256]

  • cohixcohix

    Team Member

    Hello everyone. I'm one of the developers of the new watch app, and I just want you all to know we're looking into this. From our beta testing that lasted almost 2 months, we haven't encountered any issues like this one. That said, I know this is a feature that many of you rely on so we're going to get to the bottom of it. I've gotten the diagnostics from @vickurc and I'm going over them now. It would be very helpful if we could get as many reports as possible so we can start looking for a pattern, so please follow Brenty's instructions and get those sent in. This sort of thing is tricky to nail down but we're going to work to get it resolved. For now, I'd like everyone to try the following steps in order:

    1. Disable Apple Watch in 1Password -> Settings -> Apple Watch
    2. Uninstall the 1Password Apple Watch app by tapping and holding on the icon on the watch home screen and tapping the x
    3. Restart your watch and phone
    4. Re-install the 1Password watch app using the Apple Watch app on your phone
    5. Re-enable Apple Watch in 1Password settings

    The leading theory so far is that the migration from the old watch app to the new one has failed in some way we weren't able to foresee, so this should wipe your keychain and enable you to start from scratch.

    Also ensure that there is a device PIN on your Apple Watch, as Brenty has described, as this is a requirement for using the watch app.

    Thanks everyone for helping out, and I know we'll get this sorted out.

  • Still no change after this procedure

  • Finally now it works ...

  • Finally now it works ...

  • I have configured everything ok and it works now.

  • Sorry, but no change after doing this procedure.

  • The procedure worked for me. Initially I was reluctant to use a pin on the watch because I thought it would be a pain to unlock it everytime I wanted to use it. I didn't realise that the watch only locks when you take it off. Now I use it permanently.

  • brentybrenty

    Team Member
    edited December 2016

    @Sticky: Fantastic! Thanks for letting us know that it's working for you, and that the Unlock with iPhone feature helps. I love that feature and probably wouldn't be using a passcode on my watch (and using it for anything sensitive) without it either! :love:

    @Rockake, @alvaro87: Awesome! Thanks for letting us know! I'm glad to hear that @cohix was able to guide you to a resolution! :chuffed:

  • brentybrenty

    Team Member

    @vickurc, @carmels: Thanks for your patience and willingness to work with us on this. The development team thinks they may have identified the problem. As soon as we have more information on a workaround or a fix, we'll get right back to you!

    ref: RIQ-95198-256

  • Followed Cohix instructions, and it works.
    Great
    Thank you very much
    Ira

  • brentybrenty

    Team Member

    @333ira: Thanks for taking the time to let us know! Hopefully we'll be able to get this resolved quickly for those still affected. :blush:

  • The 12/19 update did not correct the problem on the watch

  • brentybrenty

    Team Member

    @vickurc: Thanks for following up. I haven't seen other reports of issues with the latest version, so please try the steps cohix posted above to make sure that the app on your watch is actually up to date. I look forward to hearing back from you!

  • kraibergkraiberg
    edited December 2016

    Same Situation for me; no fix after installing the latest 1Password Release 6.5.1 and reloading App on watch

  • brentybrenty

    Team Member

    @kraiberg: Thanks for letting me know! I've asked cohix to look into this further. We'll get this sorted out.

  • Tried again after update but no success

  • Hey
    i have the same problem but i make a new tremor and a Fake login for the Apple watch an see its works then the Tresor delete and all Ok

  • Hey
    i have the same problem but i make a new tresor and a Fake login for the Apple watch an see its works then the Tresor delete and all Ok

  • Please make it a bit simpler. The app should work flawlessly and not tie the user into knots. Of course I want my login and other passwords secret, but so too did the Democratic National Committee, SONY, etc. If the process is too complex you will drive away your app users.

    It's frustrating that after signing into my iPhone, my laptop, my watch and the 1Password app on one of the linked device, it should sync automatically.

  • brentybrenty

    Team Member

    @bonaprof: Can you elaborate? Are you having trouble adding items to your Apple Watch? 1Password for Apple Watch doesn't involve syncing your vaults, so I'm not sure I understand the context of your comments.

  • brentybrenty

    Team Member

    @RET: It sounds like you were able to get some items on your Apple Watch by adding a new one from a vault. Is that correct? Please let me know!

  • brentybrenty

    Team Member
    edited December 2016

    @vickurc: I'm really sorry you're still having trouble with this after the update. I'll follow up via email so we can get some more information and get this resolved for you once and for all.

    ref: VFA-25123-752

  • @ brenty Yes I have a new vault opened and something entered and the sent to the Apple watch and then everything was there since then the test vault delete and everything good

  • brentybrenty

    Team Member

    @RET: Thank you for confirming. That certainly shouldn't be necessary. I'm glad it's working for you now, but we'll continue to investigate this to see how we can improve it for everyone.

  • New diagnostic sent as requested.

  • @brenty, yesterday I sent another file to you.
    It contains the data after update version 6.5.1 and all the tricks that @cohix suggested.
    I am sorry to say but it doesn't help.
    I am not pushing, just waiting...

  • cohixcohix

    Team Member

    Hey everyone. I'm going to be spending my day tomorrow getting to the bottom of this. We found one avenue of logic in the code that we thought was causing this issue, and the fix for that went out in 6.5.1. Obviously there are still some issues after the update so we're going to continue to look into this. I've read all the accounts here and the fact that adding a new vault fixes the issue gives me a new clue as to where the issue could be. @vickurc could you try that trick and see if it helps for you? I fully agree that you shouldn't have to jump through hoops like this so I'm going to continue to dig in and find out what's causing the issues.

    Thanks all for writing in, and I'll post here when I know more.

  • edited December 2016

    hi all, including @brenty & @cohix
    i have read all the above 'solutions' and 'work arounds' in order to try and solve this issue. but, this has been going on for more than just a day or two ... i find this very frustrating and annoying ... 1Password is a premium and pricey bit of software. i have restarted both my watch (series 2) and phone (6 plus) at least a dozen times, 'enabled' and 'disabled', made sure iOS and WatchOS are up to date ... and still not able to use 1Password on the Watch!
    with respect and without prejudice, Agilebits needs to sort this issue out without further delay!
    thanks in advance,
    Merry Christmas, Chanukah Sameach and a Happy New 2017.

This discussion has been closed.