1Password Crashes on opening [6.6.BETA-4 fixes the crash]

tkeelertkeeler
edited January 14 in Mac Beta

I just updated to today's beta release and it crashes on opening. Mini & browser still work however. What details can I provide to troubleshoot?


1Password Version: 6.6.BETA-3
Extension Version: Not Provided
OS Version: 10.11.6
Sync Type: Not Provided

«1

Comments

  • Have the same problem. Reinstalling didn't work either. Any way to access previous versions of the Beta?

  • jhkjhk Junior Member

    6.6.beta-3 Crashing on my iMac too (10.11.6 - not Sierra). Had to use Time machine to go back to beta-2 and, even then, it was giving me a message telling me it was crashing because it could not connect. I rebooted, and started 1P a couple of times, and it seems to have settled.......

  • I was able to revert back to the previous version of the beta through this link - https://app-updates.agilebits.com/product_history/OPM4#beta

    Oddly though, 1Password still crashes when I launch the app but it still opens up...

    I would attach my crash log but the forum doesn't allow the file attachment or copy/paste. :-\

  • 6.6.beta-3 was a disaster on my 10.11.6 OS X El Capitan 2008 Mac Pro. I had to delete the app, reboot, and install the 6.5.3.pkg. Kept crashing upon launch.

  • I can confirm it installs and works successfully on my MBP running 10.12.2. 10.11.6 may be the common denominator here...

  • NariusNarius
    edited January 14

    That could be true tkeeler. I'm El Cap. Does AgileBits want a video of how it doesn't work? Also thanks tkeeler for the link to the prev version. Great timesaver.

  • Same here. Relevant logs can be sent on request.

  • Obviously not a fix, but I upgraded my system to Sierra (10.12.2) and I'm not having any problems with 1Password.

  • r8ders2kr8ders2k Junior Member

    Ditto on 10.11.6 on my Late 2008 MacBook Pro (5,1).

  • just installed the latest beta on my Mac Pro 2013 running 10.12.1 and the app crashes immediately on open, but the browser extensions seem to still work.....

  • I downloaded the new update this AM and 1Password automatically quits

  • Same issue. Early 2008 Mac Pro running 10.11.6. Fixed by downgrading to BETA-2

  • rudyrudy

    AgileBits Team Member
    edited January 14

    Thanks for the feedback everyone. I have identified the reason for the crash and put up a fix for review by the team, there will be a new beta build shortly.

    Rudy

    ref: OPM-4717

  • I installed the new update and now 1Password crashes every time I open it. Both the App and the Safari extension are not working. I tried to reinstall, but it did not help.

    Working on MacBook Pro with most up to date operating system.


    1Password Version: 6
    Extension Version: 4.6.2
    OS Version: 10.11.6
    Sync Type: Dropbox

  • Same problem. Too bad you guys couldn't pull the beta before I tried to upgrade, this morning...

  • I also downloaded the new update yesterday, and 1Password automatically quits. Unable to see any info on which version it is.

  • Me too.

  • Thanks Rudy

  • rudyrudy

    AgileBits Team Member
    edited January 14
  • krgrahamkrgraham Member

    Same problem. Reverted to BETA-2. Just saw your post about BETA-4 but it's not up yet.

  • rudyrudy

    AgileBits Team Member

    @krgraham,

    It should be now.

    Rudy

  • I have the same crash problem today with 6.6-Beta3

  • krgrahamkrgraham Member

    OK, Got it. Thanks. It crashed first time I opened it but now it appears to be running. I did quit app and mini before running but got a message that mini did not start first time. Anyhow looks OK now.

  • thanks

  • Thanks ! mais quelle peur j'ai eue ! >_<

  • Full ScoreFull Score Junior Member

    Beta 4 fixes it, but I still kept getting the Send Crash Report when booting. Sending the crash report, even after installing beta 4, appeared to get rid of the problem.

  • 2stepbay2stepbay Junior Member

    Beta 4 corrected the launch crash. Thanks for the prompt fix.

  • Beta 4 fixes here, too.

  • brentybrenty

    AgileBits Team Member

    It sounds like 6.6.BETA-4 resolved this for everyone, but please let us know if you encounter any further issues. We're here for you! :)

  • edited January 15

    I updated to the latest beta 6.6-BETA-4 and sync via DropBox. That seems to no longer be working. It reports that it is, but in fact I do not see changes made from that version on any other devices, including another macOS machine with the same (new) beta.

    EDIT: ignore this. Just noticed that Dropbox wasn't running for the last three weeks; it didn't survive a reboot due to an upgrade. False alarm, sorry.

«1

Leave a Comment