6.5BETA-7 won't show fill buttons in Firefox 51.0b13

Recently (and I'm not sure if this happened in with an update to Firefox or to 1Password), I've been unable to get the "fill username / fill password" buttons to appear in Firefox.

I select, e.g., a username field, long-press the lock icon on the 1password keyboard, manually browse to the correct login, but then when I'm returned to Firefox, the fill buttons aren't displayed. This is true regardless of whether "automatic filling" is enabled, and is a regression that appeared sometime in the last couple of months.

Other apps (including Chrome) work as expected. I've been working around it by copying the password to the clipboard, but obviously that's not ideal.


1Password Version: Android 6.5BETA-7
Extension Version: Not Provided
OS Version: Android N 7.1.1 (Pixel)
Sync Type: Not Provided

Comments

  • periperi

    AgileBits Team Member

    Hi @yostinso. Thanks for reaching out! I tested this out with Amazon in the latest version of Firefox for Android, and I'm not able to reproduce. The Fill username and Fill password buttons show up and fill just fine for me.

    Can you try in Amazon and let me know if it works there? Are there any specific sites you could share so I can try there? Thanks!

  • Hi, it actually works fine for me in the non-beta version of Firefox for Android, which I guess answers the question of which app changed.

    The beta has the issue on any form, including Amazon.

    Thanks for looking!
    --E.O.

  • brentybrenty

    AgileBits Team Member

    @yostinso: Ah, interesting. Thanks for letting us know. I haven't used Firefox beta in a long time myself, so I'm not sure if that's just a limitation, or if it's something they'll need to address before the stable release.

  • I am having the same issue with the normal firefox version. The fill buttons just don't show up.

  • Iam sorry, filling works in the normal firefox. I was using the beta and forgot I was using the beta version of firefox :dizzy:

  • brentybrenty

    AgileBits Team Member

    @ntimo: Ah, I hate when that happens! Glad you figured it out. Sometimes I have to do a doubletake to make sure I'm using what I think I am. ;)

  • pCarterpCarter Junior Member

    Using firefox 51.0.3, going to login screen (on amazon or usps for example), long press on 1password keyboard, select the login I want and most of the time when it comes back to the browser screen there are no buttons to fill in the user id or password above the keyboard. Sometimes there are. I can't see a pattern.

    Nexus 5X, Android 7.1.1.
    Using Ghostery, tried pausing Ghostery and it didn't seem to make a difference.

    After rebooting the phone, it worked fine on the first site I tried, did not work on the second, worked on the first site again, did not work on the third, and then did not work on the first site. Quit firefox, restarted and it did not work on the first site.


    1Password Version: 6.5.1 BETA-3
    Extension Version: Not Provided
    OS Version: Android 7.1.1
    Sync Type: Not Provided

  • periperi

    AgileBits Team Member

    Thanks for reaching out @pCarter! I hope you don't mind, but I've merged your thread with this one on the same subject.

    I'm able to reproduce the issue you mentioned regarding the fill buttons disappearing when using Firefox, and I've reported this to our team. Hopefully they can get it fixed soon! ref: OPA-1122

    Let us know if you need anything else!

  • Hello Perl,

    I am also having an issue with this. I want to switch to FireFox, however without 1Password support, it will be hard. I somewhat wish 1Password keyboard was able to pull the current page from Firefox so that it will show matching password entries. I'm sure this could be accomplished, possibly with an add-on. While I hate using the keyboard alone, the auto fill is just so useful.

    Thank you for your support,

    James Coleman

  • brentybrenty

    AgileBits Team Member

    @GRMrGecko: Thanks for letting us know. For now the 1Password Keyboard is the best option, as it can work almost anywhere. But we're working on better ways to fill in future versions as well. Cheers! :)

  • I ran into this problem as well. I tried logging into the Slack app, long-pressed the lock icon, it automatically detected my Slack login, which I selected, but when I returned to the app "Fill Username" and "Fill Password" were missing.

    I had previously experienced this in another app as well, but I don't remember which.

  • brentybrenty

    AgileBits Team Member

    Sorry for the trouble there! The 1Password keyboard should at least work for you in the mean time until this is addressed.

  • The 1Password keyboard is exactly what isn't working. That is where the "Fill Username" and "Fill Password" buttons aren't showing up.

  • brentybrenty

    AgileBits Team Member

    @sadow: Was that a one-time thing? I signed into a Slack account on my Nexus 6P just the other day and 1Password did automatic filling for me. In that case, the buttons won't show up. They're only needed when 1Password doesn't see where to fill and needs you to select the correct field and tap the button for the appropriate credential. Is that what you're seeing?

  • I don't have autofilling enabled. I only use the keyboard. Yes it is still the case.

  • mverdemverde

    AgileBits Team Member

    @brenty asked me to jump in here to provide some clarification about the behaviour that you're seeing with the manual filling buttons in the 1Password Keyboard. Let me start by describing the intended behaviour and then explain why that isn't happening in this case.

    When the 1Password Keyboard shows the manual filling buttons, the intent is that they are only shown for the current login screen or web page and then hidden once that screen is gone. To that end, the 1Password Keyboard hides the buttons whenever it is dismissed.

    The problem in some cases (and I believe, in this particular case) is that sometimes the keyboard is dismissed and shown really quickly. For example, this can happen when transitioning between different apps or activities that have different default keyboard states. Even though it can happen so quickly that the keyboard doesn't appear to have left the screen at all, the 1Password Keyboard still responds to the fact that it was dismissed by hiding the buttons. Unfortunately, that means that manual filling won't work correctly in these situations.

    We can definitely do a better job of handling this kind of situation and the good news is that we're already working on a number of improvements to the filling experience in 1Password. I don't have any details that I can share with you at this point, other than to say it's a very active area of interest for us, but I hope to be able to share more in the not-too-distant future. In the meantime, if you're not using automatic filling, you may need to enter your credentials manually in those apps which are affected by this issue.

    I know that's not the ideal answer, so we'll keep working on those improvements so that I can hopefully give you a better one soon ;)

Sign In or Register to comment.