Fast user switching and extension

Gilles9Gilles9 Senior Member

If I leave Safari ( or Safari Tech Preview ) running and then switch user
when I come back to the original user who had Safari opened, the extension (1P) in Safari does not work
I have to quit Safari and relaunch (best scenario) or completely delete and reinstall the extension ( longer )

was also happening in Beta 3


1Password Version: 6.6.beta 4
Extension Version: 4.6.3 b1
OS Version: 10.12.2
Sync Type: Not Provided

Comments

  • rudyrudy

    AgileBits Team Member

    Hi @Gilles9,

    This definitely sounds like a bug, but we'll need to gather some more information in order to figure out which side of the equation that bug lies. In versions of 1Password after about 6.2 we shut down the extension server when the user gets Fast User Switched out and then we start it back up again when the user switches back in. My initial gut instinct is that the Extension thinks the connection is still active and is still trying to send messages to mini, but mini has hung up on the connection and is expecting to see the hellowelcome dance happen again.

    Can you go through the normal steps you'd take to trigger the behavior and then create a Diagnostic Report to capture the logging that happens through normal use.

    Sending Diagnostics Reports (Mac)

    Attach the Diagnostics Report(s) to an email message addressed to support+forum@agilebits.com.

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

    Rudy

  • Gilles9Gilles9 Senior Member

    It seems I cannot reproduce at will
    unsure which Applications run for each user

    as soon as I reproduce it I'll file as you request

    Thanks

  • Gilles9Gilles9 Senior Member

    Ok I sent the diagnostic report with further explanations

  • rudyrudy

    AgileBits Team Member
    edited January 19

    @Gilles9,

    Thanks for the email, we'll follow up with you there.

    Rudy

    ref: SNN-65364-622

This discussion has been closed.