1Password for Windows not accepting master password with latest version but it worked fine with an o

Hi, everyone

As weird as this appears, it has happened several times. I logged on correctly with my master password into 1Password and checked the latest password notes that I'd created. I went to check for updates and it correctly informed me that there was an update to the latest 1Password for Windows version: 1.0.8.214 and so I installed it.

However, now I can't log in with my password! I sync with Dropbox and my Mac version and iPhone / iPad version are all fine following the updates to the latest version; it's only the 1Password for PC that is not working.

I repeated this process with a now disused PC but it had an old version of 1Password on it. I also decided to take photos of what happened.
1. Logged on correctly :D
2. Requested it to check
3. Downloaded the update
4. Unable to log on (sweat)


Please help!!! I'm assuming that you believe me and I don't need to send the photos!

Thank you in advance.

Comments

  • DBrownDBrown 1Password Alumni
    Welcome to the forum, bottleneck!

    Please launch 1Password for Windows (you don't need to unlock it), choose File > Open 1Password Data Folder, locate your My Dropbox folder, and choose the 1Password.agilekeychain folder within it.

    When you do, you should be able to unlock your 1Password data with the same master password you use in 1Password for Mac.

    Please let us know how it goes.
  • Hi, there. Many thank for the prompt reply. However, I'd already done that. I did it again though just in case but the same response occurs: the 1Password for Mac picks up the new Master Password from the keychain but the 1Password for PC isn't picking up the Master Password change and so I can't log in. I even tried all of my old passwords just in case but they didn't work either.

    Many thanks.
  • DBrownDBrown 1Password Alumni
    It's hard to understand how 1Password on your Mac and PC could be using different master passwords, as they're sharing the same files, sync'ed by Dropbox.

    On the General tab of 1Password preferences on both your Mac and your PC, what's the full path that's displayed for your 1Password data?
  • Hi, there.
    I can't of course now load the PC 1Password but I know the path was pointing correctly to the 1password.agilekeychain file in Dropbox. I checked on the second computer before I upgraded it to the latest version just to make sure that nothing was awry.

    On my Mac it's: users - stephenlong - Dropbox - 1password.agilekeychain

    If I make a new keychain on my PC it will of course load. I then tried to see if it could then point to the original keychain, which it did. Of course, it then required the password. It should, as you say, be the same but the fact that this has occurred on two different machines makes me think something is wrong that I'm unable to resolve. To reiterate: it works perfectly correctly on my Macs, iPhone and iPad; it fails on my PCs. Yet, all point to the same keychain.

    Many thanks again for your endeavours with this; much appreciated.
  • DBrownDBrown 1Password Alumni
    edited August 2011
    I'm stumped, bottleneck. :( I'll have to ask the developer to weigh in on this one.

    Thanks for your patience!
  • Rest assured I am and always will be a 1Password user. I'm sure that we'll get the answer and in the meantime I can use my iPhone / iPad for the details on the PC whenever I need it.

    Many thanks for all your endeavours with this; greatly appreciated. (y):rolleyes:
  • edited August 2011
    Hi botttleneck,

    You're saying you can log into your keychain on Mac, correct? If that is the case, then please go into the Mac version and change your master password. Wait for Dropbox to sync everything to your Windows PC, and try again.

    Then please send me your old (now deprecated) password. I would love to reproduce this.

    Thanks, Stefan.

    stefan AT agilebits DOT com
  • DBrownDBrown 1Password Alumni
    edited August 2011
    Please try this, too, bottleneck:
    1. Launch 1Password for Windows, press Ctrl+O, and select the Dropbox-sync'ed 1Password.agilekeychain folder.

    2. Choose Help > Diagnostics Report > Export to File, and note where the file is created.

    3. Open the resulting 1Password.zip file, and open the 1Password.elf file in a text editor (like Notepad).

    4. Scroll down to these lines:
        8.1 1Password Data              : (interesting bit)
        8.2 Dropbox installed           : (interesting bit)
        8.3 Dropbox directory           : (interesting bit)
        8.4 .ws.agile.1Password.settings: (interesting bit)
      

    5. Copy those four complete lines into a post in this thread.

    If there's anything in those four lines that seems confidential, please write us at [email protected], with the whole 1Password.zip file as an attachment, and include a link to this forum thread.

    Thanks!
  • I have solved the issue; despite Dropbox reporting that it was up to date: every time and was 'updating' every time, it is clear that it wasn't. I uninstalled Dropbox and reinstalled it; that forced the agile file to update correctly. Many thanks for your help with this.
  • DBrownDBrown 1Password Alumni
    That's great news, bottleneck! Thanks for updating the thread.
This discussion has been closed.