6.6.BETA-5 - trial expired again

dmkahndmkahn
edited February 4 in Mac Beta

heads up ... The update notes said some licensing changes, so asked for the feedback again.

After the update it 6.6.beta-5, I guess it couldn't find the license again. I thought we solved before.

Had to download 1p from the mac app store again, run that, then 1password6.6.beta-5 found the license again. Not sure where my license file is, but I couldn't find anything to point it to.

It also didn't start itself after the initial install/relaunch when I updated (initially) to 6.6.BETA-5 again.

After I did all that, I moved the mac app store one to the trash. Is there a file there somewhere I should be saving to make this easier next time it happens? I see a file named receipt in _MASReceipt in the package. Is that the file I should save? Unfortunately I didn't save it in 1p itself last time we had this :)

-David


_1Password Version:6.6.BETA-5
_Extension Version:660005
_OS Version:macOS Sierra 10.12.3
_Sync Type:Dropbox

«1

Comments

  • Ton55Ton55 Junior Member

    6.6.BETA-5 turned my registered 1Password into an expired trial version. Pretty annoying!

  • norio_nomuranorio_nomura Junior Member

    Launching Mac App Store version of 1Password did fix this issue on my Mac.

  • I can confirm that Launching de Map App Store version did remove the Trial Expired warning for me too. I did however not have the MAS Version installed, so I had to re-download it from the Store and launch it.

  • ag_kevinag_kevin Junior Member

    AgileBits Team Member

    Hi @Ton55 ,

    It appears to be an issue with some of those that purchased from the Mac App Store. When you purchase from the Mac App Store, it validates the Mac App Store receipt instead of the license. Are you still having this issue? If so, can you send in a diagnostic report? The instructions are here:

    Sending Diagnostics Reports (Mac)

    Attach the Diagnostics Report(s) to an email message addressed to support+forum@agilebits.com.

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

    Thanks,
    Kevin

  • MrRooniMrRooni

    AgileBits Team Member

    It would be great for everyone in this thread this send in a diagnostic report according to Kevin's instructions above.

    Also, it would be worthwhile for us to know when the last time was you ran 1Password from the Mac App Store on your machines and anything that might have happened that would clear out the receipt file.

    I would also be curious to have anyone who is still having this problem (@Ton55 ?) to download the previous beta and see if it shows the same problem. You can find the previous beta here: https://cache.agilebits.com/dist/1P/mac4/1Password-6.6.BETA-4.zip

    To give you all a little background info into how this works: When you launch 1Password from the Mac App Store it will copy your purchase receipt file to a shared location. When you launch the beta of 1Password it will find that receipt, validate it, and license itself.

  • Sent the report :) Yea im on the MAS version paid and then got on the beta.

  • Ton55Ton55 Junior Member

    I re-downloaded the regular MAS 1Password, launched and quited it and re-opened 1 Password 6.6 BETA 5 this morning. No trial stuff there. This afternoon I redownloaded 1Password 6.6 BETA 4 from the link above, checked to see if it still had a valid license, upgraded to BETA 5 and everything went fine. The license is still there. So the problem's gone for now. But then again, the orginal 'trial expired' message popped-up some time after BETA 5 was installed. So I'll wait and see what happens.

  • Edit here's my number : [#PUC-74729-147]

  • ag_kevinag_kevin Junior Member

    AgileBits Team Member

    For those that had this problem, have you cleaned the Group Container lately? The group container is
    ~/Library/Group Containers/2BUA8C4S2C.com.agilebits

    Thanks,
    Kevin

  • ih8quarkih8quark Junior Member
    edited February 6

    PDF-32882-562

    this behavior is not in Beta-4

  • Never done that @ag_kevin

  • Submitted a diagnostic report with id #WYQ-78473-557.

    I'm also a MAS purchaser who moved to the betas, but have definitely not taken any intentional action to clear out the container. I'll also add that the MAS version has long since been deleted from my system, in case that makes a difference.

    Reverting to beta 4 resolved the issue for me.

  • benfdcbenfdc Perspective Giving Member

    @ag_kevin

    What do you mean by "cleaning" the group container? Should I delete the container folder? The contents of the folder? My folder is dated 11/19/2014 and contains an App Store Receipt, but IIRC I purchased version 3.9 from the App Store in September of 2011.

  • ag_kevinag_kevin Junior Member

    AgileBits Team Member
    edited February 7

    Hi everyone,

    Thanks for for letting us know. No, @benfdc, you shouldn't delete the folder. I was just wondering if you had.

    We'll be looking at a few of the diagnostic reports that have been sent in and will post more information here. Thanks everyone for the feedback!

    Cheers,
    Kevin

    ref: PUC-74729-147, PDF-32882-562, WYQ-78473-557

  • benfdcbenfdc Perspective Giving Member

    This is a royal pain, but also a good reminder of how valuable this app is. (And of how valuable we beta testers are.)

  • I'm also affected by this...I followed the advice and re-downloaded 1Password from the Mac App store. Interestingly, the full app wouldn't load past putting in the password. The 1Password Mini did load. I then opened 1Password6 beta, and the problem has been fixed. Thanks for the tips guys!

  • ag_kevinag_kevin Junior Member

    AgileBits Team Member

    Hi @benfdc ,

    We couldn't agree more! There will be a new beta released soon that should fix this. If you still have an issue with this, please let us know right away. Ideally, email us with a DR as indicated above. We've updated both the beta and the DR tool to give us more information about this, and fixed a receipt copying bug.

    Thanks,
    Kevin

  • benfdcbenfdc Perspective Giving Member

    Installing the Mac App Store version cured my problem too. Also, I just looked in the Group Containers folder in ~/Library and the App Store receipt is dated today.

    Awaiting the next beta with bated breath. :-)

  • benfdcbenfdc Perspective Giving Member

    Just installed beta 6 and things look fine and dandy.

  • [#SIQ-69118-125] is from me. 6.6 Beta 6. HAVE NOT reinstalled MAS version. Still says trial expired. If you want me to install it and send another report, lemme know.

  • rudyrudy

    AgileBits Team Member
    edited February 8

    @failgunner

    Thanks for sending in the report. I have emailed you back via our support system to request additional information.

    Rudy

    ref: SIQ-69118-125

  • My support id is support ID is [#VYN-56982-583].

    After re-installing 1Password from the Mac App Store, I was able to get it running again -- and therefore, I was able to log into this website so that I can post my results. Otherwise, all my passwords are locked up in 1Password and I'm screwed.

  • ag_kevinag_kevin Junior Member

    AgileBits Team Member

    Hi @brad_knowles ,

    I'll respond to your email with more information.

    Cheers,
    Kevin

  • Thanks @ag_kevin !
    Much appreciated!

  • @rudy replied with the information you needed. Thanks :)

  • rudyrudy

    AgileBits Team Member

    @failgunner,

    Thanks so much for doing that for us, it looks like the receipt you've got in your group container was generated prior to Apple's CA cert expiry so when we try to verify it against the current root CA cert it fails to verify.

    If you download the latest Mac App Store version and then re-run the beta (running the MAS binary isn't necessary), you should be in good shape again. We've also posted another beta in the interim that fixes a couple other issues.

    Rudy

  • @rudy yea this worked. I had to launch 1P from MAS install for it to recognize though. It wasn't recognizing until I had both open. Thanks. Can I delete 1P from MAS now?

  • rickfillionrickfillion Junior Member

    AgileBits Team Member

    @failgunner : yes, you can delete the MAS copy of the app again. It should have copied what the other version needed out to the shared container and no longer be required.

  • @rickfillion thanks. Sorted now. :)

«1

Leave a Comment