6.6.BETA-6 won't launch - failed to connect to mini

Upgrading from beta 5 to beta 6, won't launch after install. "1Password failed to connect to 1Password mini" dialog. Have restarted, etc, but no luck. Happy to send any logs you might want before I revert back to beta 5.

Thanks!


1Password Version: 6.6.BETA-6
Extension Version: 4.3.2
OS Version: macOS 10.12.3
Sync Type: Families, Teams

«1

Comments

  • Same issue here. Once I updated to beta6, no matter what I try or do I get the same error as jhamer.
    I am running OS Sierra 10.12.4 as I am an Apple Developer. No issues with anything until todays update to Beta-6.

    I did run the diagnostic tool and have forwarded all of the log files it creates.

  • ME TOO

    Back to 6.5.3

  • DianeoforegonDianeoforegon Junior Member

    Add me as a "me too". Sent report [#ARP-54951-739]

  • baggendbaggend Junior Member

    I couldn't log in here and say "me too" because I couldn't get to my password! :) Submitted report [#UGQ-38157-165] and downgraded to 6.5.3 for now.

  • pftqgpftqg Junior Member

    Same here (but on 10.12.4 beta 1/2)

  • tigertontigerton
    edited February 8

    Same here. Never had any issues before starting the app, this concerns me. Have testing been flawed lately?
    6.5.3 wont work either after download again.
    You who have updated to old versions, where are they available to download? Thanks
    (10.12.3)

    Update
    Beta 5 will start after reboot, but the error report window is stuck over the app, cannot send, cannot remove, it pops up again. Oh wait, after it is stuck in sending mode, a forceful restart now the popup is gone. Guess error report was stuck as well but pushing the send button triggered a save for next start even though the message was unsent.

  • Same issue here, 10.12.3. Submitted report #GSV-79991-585

  • Same here. Had to revert to Beta-5 in order to get working again. OS X 10.12.4 beta 2

  • guydguyd Junior Member

    Same for me. I am running 10.12.3 on a previous generation MBP13r. I have reverted to 6.5.3. This is the first issue I've ever had with betas from Agilebits :) Gave me one hell of a fright ;)

  • iamechoiamecho
    edited February 8

    I'm unable to access 1P - receiving the unable to connect to 1P mini message. I have restarted mac but 1P mini can't connect and 1Password won't open at all. I can't access the web 1P because I can't access my passwords ;( Any ideas please?

  • Update: I followed the instructions and this did not solve the problem - still can't connect to 1P mini.

    Reset extended attributes

    If 1Password still does not start correctly, you may need to reset its extended attributes. This will only help if you downloaded 1Password from our website. You do not need to attempt this if you installed 1Password from the Mac App Store.

    Open Terminal, which is in the Utilities folder of the Applications folder.
    Copy and paste the following into Terminal and press Return:

    xattr -d -r -s com.apple.quarantine '/Applications/1Password 6.app'

  • Initially I tried uninstalling the failed beta, scrubbing OS Sierra and then fresh install of Beta-6 but had the same result.
    Only solution was to uninstall and scrub OS Sierra of any and all agile/1password files then install the production release.
    At that point functionality was restored.

  • rudyrudy

    AgileBits Team Member

    all,

    if you run this command does it find any errant copies of 1Password floating around?

    mdfind kind:application 1Password

    Rudy

  • @rudy Please explain what you want me to do .. open terminal and run that command?

  • sjksjk oversoul

    AgileBits Team Member
    edited February 8

    That's correct, @lamecho.

    Open the Terminal app, run the mdfind kind:application 1Password command in it, and see if there are multiple copies of the 1Password app in its output. For example:

    bash-3.2$ mdfind kind:application 1Password
    /Applications/1Password 6.app
    /Applications/1Password.app
    /Users/agilebits/Applications/1Password5Troubleshooting.app
    
  • @sjk This is what I received after running the command:
    Last login: Wed Feb 8 08:42:55 on ttys000
    OPC:~ OPC$ mdfind kind:application 1Password
    /Applications/1Password 6.app
    OPC:~ OPC$

  • rudyrudy

    AgileBits Team Member

    @iamecho,

    Thanks for running that command. we think we have a reason why its doing that. We're working on an update now.

    Rudy

  • @rudy @sjk Thanks for the update .. I'll sit tight and wait for the update rather than trying to figure out how to revert to an earlier beta!

  • FYI - command output:

    jhamer$ mdfind kind:application 1Password
    /Applications/1Password 6.app
  • ag_kevinag_kevin Junior Member

    AgileBits Team Member
    edited February 8

    Hi all,

    Thanks for reporting this. We've identified the problem and will be issuing a fix in 6.6.BETA-8 this morning.

    Cheers,
    Kevin

  • @ag_kevin Thanks for acting so quickly!

  • @ag_kevin: Can you please post a download link when ready? I don't think my 1P is launching far enough to pick up the Check for Updates. Thank you

  • Thanks so much for getting on this so quickly.

    How would I go about reverting to the previous version in the meantime? Is there a download link kicking around somewhere?

  • tnelmstnelms Junior Member

    To revert back to a working version you can drag the 1Password6.app to the Trash then download the current non-beta version and install it. That fixed it for me. I did not need to delete all the 1Password6 files, just remove the beta app.

  • Gilles9Gilles9 Senior Member
  • Thanks @tnelms and @Gilles9 - I picked up the previous version from that list and it worked like a charm.
    I appreciate the help.

  • rudyrudy

    AgileBits Team Member
    edited February 8

    all,

    6.6.BETA-8 should be up now with a fix for this issue.

    https://cache.agilebits.com/dist/1P/mac4/1Password-6.6.BETA-8.zip

    Rudy

  • Confirmed - back in business with BETA-8. Thanks again

  • @rudy Thanks, crisis averted :)

  • ag_kevinag_kevin Junior Member

    AgileBits Team Member

    Glad to hear it. Let us know if you see anything else odd.

    Thanks,
    Kevin

«1
This discussion has been closed.