1Password 1.x vaults are not yet supported in 1Password 6

edited February 17 in Windows Beta

Hello again. Six months ago, I started a, then, short journey in order to move from 1Password 3 to 1Password 6. It was a failure, but I also promised to give you gals and guys and your software a second chance. Well, the moment has come.

I won't deny it, I can see that some things have improved. I can finally use attachments, even though they still do NOT get imported from the exported 1password file, I could at least manually create a Document type of entry and save the attachment there. Also, interface has improved a bit, even though I still see a ton of place for improvement.

One single thing I absolutely don't understand though, and it has me amazed that you and your testers did not see or find this, is that 1Password doesn't import password or other login related fields of a password item if there is no proper website specified. I've got a few entries that have only passwords (or username and passwords), but no website. I've also got an entry that contains the AgileBits Master Account Key (and nothing else). They are NOT shown within 1Password, not the desktop version, not the iPad version, and not the browser version. Not imported, that simple. But it goes even further. When opening the Dropbox account on the desktop version, it's not shown there either, even though I can access and see it without any problem through my iPhone (which is still set up to the Dropbox account, fortunately) or the old 1Password 3 version. In order to illustrate it, I'm adding screenshots from the desktop version (no password on either imported vault and Dropbox vault), browser version (no password on imported vault), and iPhone (password shows up on Dropbox vault).



Of course, this I found out only after upgrading from the trial to paid account. So, I really hope you will push this critical bug up to the very first spot of your pending bug fixes list, since this effectively stops people from migrating their accounts correctly. Again. Still.

I for myself will now have to double check every single of my entries in order to make sure all data is in the new vault, and add whatever is missing.

Seriously, that's a shame.


1Password Version: 6.3.359d
Extension Version: 4.6.3.b3
OS Version: Windows 10
Sync Type: 1Password Account

Comments

  • brentybrenty

    AgileBits Team Member

    @me_and_myself: Thanks for following up on this! That definitely seems like a bug. Not an excuse for this, but I've only ever encountered one other case of logins without URLs, so I can't say that it comes up frequently. Can you tell me more about what format you imported data from and the process you used? I wonder if the data is in fact still there, but 1Password is just not displaying it for some reason. You could try exporting to CSV to see if it shows up there, preferably with information that is less sensitive since that would be plaintext. Either way, you're 100% right that you shouldn't have to go through and double-check all of your data after importing. I'm sure we can get to the bottom of this and get things sorted out — for you and others who may encounter it in the future. I look forward to hearing back from you!

  • Ok, so here's the thing. This is what I did in order to get my data into the new vault.
    1) Opened 1Password 3 (1.0.9.342) and went to File -> Export.
    2) Chose export All Items and 1Password Interchange File format, saved to desktop.
    3) Went to 1Password 6.3.359d "Import" option and imported said file into a new vault.

    I did some testing now, and here are the results which should hopefully help to find this bug.

    1) I exported the data as Comma-Delimited-Text and Tab-Delimited-Text, "All Logins" both times, as these two options don't allow for single logins to be exported. In both cases, the entry is not being exported and can't be found in the source code of the files. Makes sense, as the item I am looking for is not a Login, but Account type entry.
    2) I exported the data as 1Password Interchange File, both "All Items" and "Selected Items", and then opened the source files, both times the entry is there (with all its fields!), so it definitely gets exported correctly, but rather not imported correctly afterwards. This is what shows up (I changed the real content for obvious reasons):

    {"keyID":"somelonghexnumber","locationKey":"","typeName":"wallet.onlineservices.GenericAccount","location":"","uuid":"anotherlonghexnumber","updatedAt":1471910534,"createdAt":1471910513,"title":"AgileBits Master Account Key","contentsHash":"somehashvalue","securityLevel":"SL5","secureContents":{"notesPlain":"","username":"","password":"herewasthepassword"}}

    Here's what it looks like in 1Password 3:

    I've meanwhile located another entry that didn't get imported correctly (sorry, didn't have time for more), it's another Generic Account entry and has Username, Password and Note fields. It gets exported correctly with all its fields (I checked the .1pif file), but after importing, only the Note field shows up, Username and Password are missing.


  • brentybrenty

    AgileBits Team Member

    @me_and_myself: Thank you for those details! I completely understand that you don't want to go through and enumerate all of your entries that may be affected, and of course they'll probably contain sensitive information so that you won't be able to share much detail. But this at least helps us narrow things down.

    While we investigate this on our end, I wonder if opening the actual vault in 1Password 6 might get you a better result. That's why we have read-only local vault support in the app after all: it's a lot easier than manually exporting and importing data if you've already got a 1Password vault. I can't guarantee that will solve all of this for you, but 1Password for Windows version 1 had much more limited export capability, so it wouldn't surprise me if reading the vault directly (instead of going through these intermediary steps — "middlemen") in the new version produced better results. Granted, a lot has changed since we stopped developing the first version of the Windows app, but I think that's at least worth a try to hopefully save you some trouble. Let me know how it turns out!

  • brentybrenty

    AgileBits Team Member

    @me_and_myself: Actually, something just occurred to me. I know that 1Password 4 has special handling for the legacy data, since later versions (4+, on macOS as well) use an entirely separate section that supports custom fields and other advanced features we added more recently. I think there may be a solution. I'll get back to you shortly.

  • MikeTMikeT Agile Samurai

    AgileBits Team Member
    edited February 17

    Hi guys,

    @me_and_myself:

    1Password 6 does not support importing from the legacy 1Password 1.x vaults, only from the 1Password 4 vaults and even there, any item created from 1Password 1.x carrying over to 1Password 4 would not be imported correctly in 1Password 6. There is also no 1Password 3, it's a Windows 7 error that shows it as 1Password 3 in the start menu.

    We do plan to add support for these legacy items but there is no workaround directly from 1Password 1.x to 1Password 6. If you want to fix this, you'll have to open the vault in 1Password 4, quickly update the items (without any changes) and then export it from there.

    Here's how:

    1. Open 1Password 4, unlock that vault, and select the All smart folder on the sidebar, sort it by oldest item on top by clicking on the Modified header on the top right of the item list.
    2. Select the oldest item on top and press enter twice. This will update it and should no longer be on top. If you see it open in your browser, your setting is configured to open it instead of edit it. To change this, go to the File Menu > Preferences > General and change the Double-click option to Edit the selected item in 1Password and press OK. Now, try to press twice on all of the items you have until you reach the most recent update. It shouldn't take long.
    3. Export the items and reimport the data into 1Password 6.
  • That's far from an ideal solution, but I guess you absolutely knew that when you decided to release a software that does not allow an upgrade from a older version to the newest.

    I was able to download and install 1Password 4 in trial mode, update all items as you said and then export them and re-import them into 1Password 6. All fields seem to appear correctly now (also when opening the now updated Dropbox vault in 1Password 6), so at least that saves me some headache. As a sidenote, the file attachment still doesn't get imported, but then again, I can create a new item for that one. So thank you for that "solution". I guess you got this quite high on your priority list because you probably want more people to upgrade their 1Password software and not go with another solution.

  • MikeTMikeT Agile Samurai

    AgileBits Team Member

    Hi @me_and_myself,

    You are correct, it is not an ideal solution, actually it's not a solution at all. The very first thing that a new version of an app should do is completely migrate from the older version of 1Password but this didn't work out for us, we had a different goal in mind and why we still do not offer 1Password 6 as an upgrade to 1Password 4 customers. The longer we wait to finish everything in 1Password 6, the more 1Password.com customers go on without a Windows program, so we had to roll it out in stages with limited features set and implement everything as fast we can.

    We do apologize for the inconvenience.

    As a sidenote, the file attachment still doesn't get imported, but then again, I can create a new item for that one.

    Check out New Item > Import files as Documents in 1Password 6, you can select multiple attachment files from your export folder and 1Password 6 will upload them all as Documents for you.

This discussion has been closed.