Firefox Extension Not Registering/Opening Unless Main App Used

JM552JM552
edited February 2017 in Windows Beta

Hello,
I've browsed many of the other related threads but don't seem to see any solutions that apply.
Anytime I open Firefox (version 51.0.1) and the 1PW extension to login to a given site I get a tab that opens stating the extension has failed to open. At the same time the main 1PW app opens prompting me to login. Once logged in I then get the small site specific cue. Previously with Chrome this was not an issue.

I have uninstalled/reinstalled the extension and also turned on beta but no luck.

I've exported the logs per other thread instructions and can send when needed.

Thank you


1Password Version: 6.3.359
Extension Version: 4.6.3.b3
OS Version: Windows 10
Sync Type: 1PW

Comments

  • brentybrenty

    Team Member

    @JM552: Thanks for reaching out. I’m sorry for the trouble! I'm a bit unclear as to what you're referring to here though:

    Once logged in I then get the small site specific cue.

    Can you elaborate? This first part I understand:

    Anytime I open Firefox (version 51.0.1) and the 1PW extension to login to a given site I get a tab that opens stating the extension has failed to open. At the same time the main 1PW app opens prompting me to login.

    It sounds like things are working normally at that point, since if 1Password isn't already running, the browser extension will need to launch it (this is done from the new tab that opens). It sounds like there may be some delay on your system though where it takes the app a bit longer to open than expected, so the extension thinks it failed. Do you have "security" software that may be interfering? We'll get to the bottom of this!

  • Thanks so much.
    To clarify the first part of my post, what I mean is only once I've logged in to the main app and then click the 1PW extension icon will the small window open next to the extension that displays the vault entry for that specific site, ready for me to click to confirm for autofill.

    If I attempt to access a site without the main app open I simply get a new tab w/ the browser extension failed message alongside the main app prompting me to login. I hope that helps.

    It does appear that there's something interfering with the extension. The only security/AV software I've got installed is the basic Windows 10 defender av application.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @JM552,

    Nothing is interfering with 1Password, that's normal behavior at the moment when 1Password is not configured to run automatically when you reboot the computer. Both the main 1Password app and 1Password mini will show up because 1Password extension is being aggressive at getting 1Password mini to run.

    To improve this, configure 1Password to run as soon as you sign in to Windows. Open the main 1Password app, unlock, and go to Settings on top right (gear icon) to select Options. In General, check the box next to Start 1Password automatically when I sign in to Windows.

    After that, 1Password mini will show up right away in your browser because 1Password is already running in the background.

  • Great, thanks Mike. I will give it a try and if there any further questions I'll reply back here.

  • MikeTMikeT Agile Samurai

    Team Member

    You're welcome!

This discussion has been closed.