1Password App and Chrome extension broken after hibernate

I have a Dell Latitude E7470 laptop that I use at work. Windows10, 16GB RAM, SSD drive; very good performance. Using Chrome 56.0.2924.87; it says it up to date. Plugin version

I installed 1Password6 (6.3.359d) app (Family version) and the Chrome extension, and I am able to use 1Password as expected. Synching between different computers seems to be working fine.

What triggers the problem:

  • I bring the laptop back and forth between home and office.
  • When I leave home, I hibernate, then turn on again at the office.
  • At home, I am on my personal wifi. At the office, I am in a docking station with a wired connection (not on the wireless).
  • 1Password app is logged out prior to hibernation, but still open in the background.


  • Upon logging into Windows at the office, I cannot browse any web sites in Chrome. All web browsing is broken until I disable the 1Password extension. Nothing fixes web browsing until 1Password extension is disabled.
  • On top of that, the 1Password app is non-responsive. I get a password box, but as soon as I type anything, the app freezes and eventually I have to kill it in Task Manager.
  • I have tried browsing with 1Password app closed, but it does not work (except if the extension is disabled).
  • There is no action I have found to make 1Password useable again other than rebooting. After rebooting, everything is working fine.

Other notes:

  • Generally I don't really use 1Password while I am in the office. If it wasn't for web browsing being broken, I might not even notice.
  • I am an administrator on the laptop.
  • I have not done more scenarios like just hibernating at home and then turning on again to see if it is specific to turning on in the office. Likewise, I have not observed what happens when hibernation at the office and turning on at home because I generally do not use 1Password at the office. But I do plan on trying these scenarios in the next few days.

Again, when 1Password is working, everything seems fine. Are there any known issues with hibernation that can cause an issue like this? Are there are any workarounds or updates that I should be looking for?

1Password Version: 6.3.359d
Extension Version:
OS Version: Windows 10
Sync Type: Family Version


  • MikeTMikeT Agile Samurai

    Team Member
    edited February 2017

    Hi @kwiltse,

    Thanks for reporting this. There are certainly no known issues like this and even stranger, it should not be technically possible. Our 1Password extension has no method of blocking your web browsing experience, we cannot override this. That's one of the advantages of sandboxed browser extensions, so they can't mess with your stuff like this but it may not be the extension itself.

    The reason I've said that is we use a localhost connection (ws://) between the 1Password browser extension and the main 1Password process to securely communicate; the extension itself has no data or UI, instead it handles the filling and saving in the website while working with the main 1Password app to process the data. If this network stack gets in a bad shape, it can loop back into 1Password, thus the freezing app and the extension may be overreacting to that by trying to reconnect forever but we do have the fallback code to stop after 10 attempts. Disabling the extension kills the connection as well.

    Can you tell me what anti-malware or security program you're using on your computer, could they interfere with your network like this by interfering with 1Password as well?

    If you get into this state again, try looking at Edge first, 1Password doesn't support Edge at the moment, see if web browsing works in Edge. If it is the same problem, then the issue is wider than 1Password. However, you should always be able to terminate the 1Password process via Task Manager.

  • So I seem to have found the issue for this. When I first installed 1Password it was while I was at home with my laptop on a 3 day weekend. After my first two days back in the office I simply rebooted and then didn't bother with 1Password while at the office. Thus 1Password never ran while connected to the office. On day 3, I rebooted, then opened the desktop app and logged on, and ever since then everything has worked normally. Now I take my laptop back and forth, hibernate both directions, and everything is working totally normal.

    So it appears it was just a side effect of coming out of hibernate and connecting to a network it had never been on before. Once 1Password had run on the network at least once, hibernate had no problem at all. Not sure if this will cause any problems in the future, but at least I know now that it does not present a problem for my every day use case.

  • Hey @kwiltse,

    Thanks for letting us know that 1Password works as expected now. We're still not sure how this might've happened. What you're describing shouldn't have had any influence on 1Password at all.

    If you run into any issues in the future, please let us know.



This discussion has been closed.