Playstore says 1Password not compatible with my Galaxy S7 Edge Nougat 7.0

I recently upgraded my AT&T S7 Edge to Nougat 7.0 and 1Password would update all of my passwords each time I used it. It would rewrite every password record, which takes a long time. I uninstalled 1Password to try to resolve this issue and when I try to install it again it says it is not compatible with my device.


1Password Version: 6.5.1
Extension Version: Not Provided
OS Version: Nougate 7.0
Sync Type: DropBox
Referrer: forum-search:Playstore says 1Password not compatible with my Galaxy S7 Edge Nougat 7.0

Comments

  • It says "Not compatible with this version."

  • brentybrenty

    Team Member

    @ebertojr: That's very strange, as 1Password for Android version 6 definitely supports Android 7...and I haven't heard of issues with recent Galaxy devices either. Do you mean that the Google Play store won't even install 1Password now? Under the circumstances, I'm not sure what 1Password can do to help, since we won't even be able to get diagnostics — it isn't even there. Have you "rooted" the device to run a custom OS, or otherwise modified the Play store? Let me know what you find!

  • Stranger yet, I just tried it and it installed with no issues! Thanks for following up.

  • periperi

    Team Member

    Thanks for the update! I'm glad to hear that. Please let us know if you have any trouble again in the future.

  • I'm having the same issue. But there's no option to install it on the Google play store.

  • brentybrenty

    Team Member

    @buzzby75: Unfortunately that isn't something we can help with, as the Google Play store is owned and operated solely by Google. Do you perhaps already have 1Password installed, or your device/software is not compatible? What are you seeing exactly? Ultimately you may need help from Google or the device vendor, but I can at least try to point you in the right direction if you'll provide some basic information. Thanks in advance!

  • I've manage to get the app on to my phone. But can't remember any of my log in details. I want to purchase the pro version of the app.

  • periperi

    Team Member

    Hey @buzzby75. If you're being prompted for an email address, Secret Key, and sign-in address, then this is for a 1Password account. You're welcome to sign up for one if you like. With an active account, the Pro features are unlocked automatically.

    Otherwise, you'll need to sync an existing vault. Were you previously using 1Password on another device? If so, had you configured sync with Dropbox or another method?

  • Hello :)

    If anyone else runs into this, they might want to try installing the app remotely using Google's Web version of the play store. If you get the same error, I believe the web version of the play store will allow you to click on a "+" sign on the error message for some insight as to why you can't install it. There are tons of reasons such as carrier block, wrong or not supported Android version, maturity rating (although I think the latter wouldn't apply to 1Password), etc.

    I hope that helps.

  • brentybrenty

    Team Member

    I'd never thought to try that. Can always view 1Password in the Google Play store here in a desktop browser. Not a bad idea! :)

  • I´m having the same problem with my galaxy s7 running on 7.0 nougat, playstore says i can´t download it because is not compatible with my device. Tried downloding trhu the desktop version but didn´t work, shows the same message

  • periperi

    Team Member

    Hi @msimoes. Can you go to Settings > Display and change the resolution to the highest setting? Then go to Settings > Apps > Google Play Store > Storage and tap Clear Cache. Once you do that, reboot the device. Are you able to install after following those steps?

  • edited February 17

    I have the same issue with my Samsung S7. First time I am unable to install an application. I followed the steps above to no avail.

  • brentybrenty

    Team Member

    @richard_gruzin: I'm sorry to hear that. Unfortunately the Google Play installation process isn't something we have any control over, and it sounds like there may be a deeper issue on your device if Google Play is saying it isn't compatible even after clearing the cache. What else have you tried? Do you have Google Play itself up to date, and are there any other customizations that might be confusing Google Play into thinking your device is incompatible?

  • I have everything up to date and all my settings are generally default, I use many applications from google play store. This is the first time I cannot install an application from google play store. This is unlikely that this is an issue with my phone.

  • brentybrenty

    Team Member
    edited February 17

    @richard_gruzin: I hear you, but it would be preferable for it to be an issue on your device since the alternative is the Google Play store itself...and the likelihood of Google finding and releasing a fix just for you is not high. So again, besides clearing the store cache as Peri suggested, what else have you tried? Have you rooted your phone? (Edit: I am not suggesting rooting your phone, though I realize it may have sounded that way! Just asking if it is currently rooted.)

  • brentybrenty

    Team Member

    @richard_gruzin: For example, did you try remotely installing the app from a desktop web browser as Thelauffer suggested above?

    https://play.google.com/store/apps/details?id=com.agilebits.onepassword

    This is a pretty nice guide to doing that:

    http://joyofandroid.com/remotely-install-google-play-and-third-party-apps-on-android/

    Let me know how you get along!

  • edited February 20

    Hello, No my phone has never been rooted. I tried to install this app by play store in google chrome, but when I choose my phone Samsung Galaxy S7 (SM-G930F) it says that the app is not compatible with my phone. Unbelievable. One of the most used phones out there. You must have selected that this phone is not supported when you deployed the app into google play store.

  • brentybrenty

    Team Member

    Hello, No my phone has never been rooted.

    @richard_gruzin: I didn't think so, but thanks for confirming, as this is really strange.

    I tried to install this app by play store in google chrome, but when I choose my phone Samsung Galaxy S7 (SM-G930F) it says that the app is not compatible with my phone. Unbelievable. One of the most used phones out there. You must have selected that this phone is not supported when you deployed the app into google play store.

    Nope. We have people using 1Password on S7. I'm not sure why Google won't allow you to install it onto yours. What resolution are you running at? That's the most common cause for issues like this. What model is this exactly? I wonder if it's a regional version we haven't tested, though I've never heard of others being completely unable to run 1Password on a Samsung device.

  • Samsung Galaxy S7 (SM-G930F)

  • brentybrenty

    Team Member

    @richard_gruzin: Thanks! I saw that in your screenshot, but I'm not super familiar with different regional models. Maybe it doesn't apply to that device. But for example, when I purchased a "Nexus 6P", there were at least two very different SKUs for different regions. Very confusing. What about your display setting?

  • I checked HD (1280x720), FHD (1920x1080) and WQHD (2560x1440) all the same.

  • edited February 20

    @brenty in general I have never ever come across an app that I was not able to install. It means that it is an issue with your app, not my phone. :)

  • I am have the same issue on my S7

  • @brenty you must have changed something in the play store, I was able to install the app today.

  • saadsaad

    Team Member

    1Password does have a minimum screen requirement, enforced by the Play Store app, as our app is not designed to work on devices with a smaller screen. We found that in some cases this restriction is applied to the Samsung Galaxy S7 if the device’s resolution is changed. If you are experiencing this problem, please change the device's resolution to WQHD, clear the Play Store app’s cache, and reboot the device by following these instructions:

    1. Open the Settings app on your device
    2. Go into Display and change the resolution to WQHD
    3. Go back to Apps > Google Play Store > Storage
    4. Tap Clear Data
    5. Restart your Samsung Galaxy S7

    Try installing the 1Password app from the Play Store again and let us know if you are successful this time!

  • saadsaad

    Team Member

    @MattMCG Could you try these steps and let us know if you’re able to install the 1Password app? Thanks!

  • saadsaad

    Team Member

    @richard_gruzin We didn’t change any requirements in the app, but I'm glad to hear you can install 1Password again! Did you change your screen resolution since the error?

  • That worked. Thank you!

  • brentybrenty

    Team Member

    Awesome! Thanks for the update. Glad that did the trick for you. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file