Cannot update to the latest version [6.3.359/360 is required to update to the next versions]

edited February 2017 in Windows Beta

Hello,

I have ver 6.3.352d installed on home & work PC's. Recently, an option to update to ver 6.4.376 displays in the lower left-hand corner of the app, and in Options/Check version/update.

At one point in the past several months, these links worked correctly to install the newer version. But again, they are broken. I have to manually navigate to the HockeyApp website to manually download and install ver 6.4.376.

When I click on either link, the app shuts down. And that's it. After clicking update link, I get a blank screen. No download prompt. No save/save as prompt. To resume using the app, I must relaunch the 'old' version and go to HockeyApp. It worked, once, with upgrading to an earlier version, a few months back, but the process is again broken.

I know you guys are working hard at improving the app in several areas, but please tell me you guys have a plan for fixing this mechanism in the production version?

Using Win7.

thanks,
@southernforge


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited February 2017

    Hi @southernforge,

    Thanks for writing in.

    6.3.352d is not a production version, that's a beta version. There was a mandated 6.3.360 beta update that everyone had to install or they won't be able to update to any future updates. Majority of our users were able to update properly but I assume you weren't able to get to that version in time. In that case, you must uninstall all 1Password 6 versions and install 6.3.376 manually. If you are still having issues, let us know and we'll look at what's going on.

    Unfortunately, there is no way for us to mandate updating to 6.3.360 first, so that's why the updates are failing for you as it jumps straight to 376 but you cannot update from 352 to 376 at all, 360 is required.

    We have shipped 6.3.359 stable three weeks ago, to give everyone a chance to update to it, so it'll support the next stable update. The beta channel had a smaller timeframe as we have a small registered list of beta testers that we can notify via emails to update.

  • Hi @MikeT ,

    Please accept my apology: I am a beta tester, and I am using the beta version with my email address entered in the necessary field on the app's update screen.

    Had been away on business and not regularly checked the beta forum for the last month+

    Thank you for the explanation - it makes perfect sense. Before reading your reply, I had manually downloaded and installed 6.4.376; do you recommend I uninstall and reinstall, to clear out stray file system or registry data?

    Thanks much,
    @southernforge

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @southernforge,

    No apologies needed, this is all on us for not having the ability to mandate a specific version for updating. This is something we'll look into adding in the future.

    If 6.4.376 is already installed and running fine, you don't need to do anything. The main issue is because the updater in the previous versions did not understand the new installer we've built in 361+ builds, so it cannot update using the new installer. If you manually install the latest versions, the installer will do its best to remove the older versions and clean up registry keys before installing the new version for you. If not, it will fail and notify you.

    If everything is fine with 6.4.376, you're all set now.

This discussion has been closed.