3 fields - It only fills 2

Hi! When I manually save my details from this Visa site (https://inetserv.visa.com.ar/visahome/login?windowId=f86) I can log in successfully (the app fills all 3 fields). But strangely (and randomly), after a while, the app only fills the first two fields... What can I do?


1Password Version: 6.5.3
Extension Version: 4.6.3
OS Version: OS X 10.12.3
Sync Type: iCloud

Comments

  • Hello @marianoam,

    I wondered at first if they were generating new name and ID attributes as this is something some sites do. It doesn't look like that though as if it were I would have expected filling to fail after loading the page in separate browsers. It may mean it's a little tougher to pin down. I have a couple of questions though.

    1. Do you have autofill in the browser enabled at all? If you do could you try disabling it please, our page Turn off the built-in password manager in your browser will help with this if you're unsure.
    2. When this happens, does saving a new Login item result in all three fields being properly filled again and does it too break after a while? To save a new Login item the steps on our page How to save a Login manually in your browser will help but given the choice of words in your post I suspect you already know this.
    3. While it appears random I wonder if there is a pattern that hasn't been identified. Are you trying to log back in after being logged out by the site? Are you first noticing it after maybe a new day has started?

    I created a Login item yesterday and tested it to see if it worked. The same Login item today still works so it may take a while to pin this down.

    Something that may be of interest. Test to make sure your existing one works. Wait for it to not work. Create a new Login item using the manual steps but don't delete the old one. Confirm the old still doesn't work but the new one does. We'll probably have to take it to email afterwards but I would be very curious to then start comparing the JSONs for these two items and see if we can spot something that is different. Please don't post the JSONs here as we will need to help ensure nothing sensitive is shown and even then, there's no need for that sort of level of detail to be public at all. Your privacy and security is important to us after all :smile:

  • Hey!

    First of all, thank you for taking your time writing this very complete answer. Strangely, now it's working every single time.
    I will report back to you if it's start happening again.

    Thanks again.

  • :lol: Isn't that always the way @marianoam, it waits for you to report it and then decides to behave. No wonder we anthropomorphise the damned machines.

    Please do let us know if it returns, otherwise I hope 1Password behaves and serves you well :smile:

  • Hey, @littlebobbytables, it's happening again. I've got the old entry (which now doesn't work) and a new one working properly. How can I get help?

    Thanks,
    Mariano

  • littlebobbytableslittlebobbytables

    Team Member
    edited March 2017

    Hi @marianoam,

    I'm going to contact you via email :smile:

    ref: XXR-72226-694

  • Thanks, @littlebobbytables. I've sent the files you requested privately.

  • Hi @marianoam,

    The site does turn out to be altering the ID and name attributes of various fields and this throws 1Password off. I've replied via email with what I hope is a working solution and a more reliable Login item :smile:

  • Perfect, @littlebobbytables. I've received your email. I'll try that as soon as I get home from work.

    Thank you very much!

  • Fingers crossed :smile:

  • Hi, I have exactly marianoam´s problem with the same webpage, and also using de ios app.
    Can you help me with this? thank you

  • matthew_agmatthew_ag 1Password Alumni
    edited April 2017

    Hey there @jleiro17,

    I'd just like to confirm in marianoam's case, he was able to fill in all three fields for a while and then his Login item stopped working. Is this what happened with your Login item?

    I followed his link to the Visa log in web page and with 1Password for iOS I was able to create a Login item that was able to fill in the three fields. I'm not sure if this particular Login item will stop working after a while.

    My approach was:

    1. Open that link in 1Password for iOS's internal browser called 1Browser.
    2. Entered some test credentials into all three fields on the web form.
    3. Tapped "Done" at the bottom of the screen.
    4. Click the key icon and tapped "New Login" on the screen that popped up.
    5. Created a new Login item.

    With this Login item I was able to fill out this particular page immediately afterwards.

    I hope that helps. Please let us know if we can be of further assistance.

    Best regards,
    Matthew

  • Hi, thanks for your response.
    Your approach is correct! but the problem is random, the new login works for some day or weeks and one day stop working, and only fill in 2 of the fields, in this web page "numero" (id) and "contraseña" (password). The 3rd field "usuario" (user) remains blank. The information to fill in this field is not visible, you have to pick it from "data in web form".

  • littlebobbytableslittlebobbytables

    Team Member
    edited April 2017

    Hi @jleiro17,

    I have a couple of questions if you don't mind.

    1. Do you only use 1Password on an iOS device?
    2. Do you make use of a 1Password account at all?
    3. If you don't make use of a 1Password account do you use Dropbox?

    What I discovered with marianoam's assistance was that this page is altering certain fields that affect the strategies we will try when filling. This is why the item will work for a while and then "break". There is a way around this and what I did was to send marianoam a 1PIF (1Password Interchange Format) file as they had a Mac they could import this with. I'm happy to send you the same stuff if we can ensure we've got a way for you to add it :smile:

    ref: XXR-72226-694

  • Hi, thanks for your response.
    No, I use 1Password on my iPhone and also on my Mac, the latest versions on both.
    I dont use a 1Password account, and I use Dropbox for sync.

  • Hi @jleiro17,

    If you use 1Password for Mac we're good :smile:

    1. Here is a link to the 1PIF I would like you to download please.
    2. Drag and drop this 1PIF onto the 1Password icon in your MacOS Dock and 1Password will ask if you wish to import it into the current vault.
    3. Located the new item (it will be titled simply Visa) and enter edit mode.
    4. Click on the ** show web form details** button.
    5. You will definitely need to update the following fields: loginFrm:docNumber, loginFrm:password & loginFrm:nickname.
    6. Save those changes.

    You should find this item fills but more importantly doesn't stop filling over time. I have made assumptions about the loginFrm:docType and loginFrm:gender fields that may mean they need altered too. If you find it doesn't work for you please do let us know.

  • ok, for the time been is working. Lets wait some days to see whats going on.
    Thank you very much!!

  • Last question, why I can not see the "show web form details button" on the ios app?

  • Hello @jleiro17,

    The good news is we never heard back from marianoam which would strongly suggest it just kept working. I'm hopeful you'll find the same but as you note, it's a case of waiting long enough to have confidence that it has gone away (absence of a negative result rather than the immediate presence of a positive).

    In 1Password for iOS you should be able to view the web form details but the option will be titled Saved form details (To ensure consistency between platforms) and will be closer to the bottom of the detail screen. It cannot be edited in 1Password for iOS and 1Password for iOS also doesn't have the ability to import a 1PIF hence needing 1Password for Mac to add a working Login item for this page.

  • Regarding the IOS app, I can not find the "saved from details".
    I dont have the PRO features installed, probably thats why....
    Thanks!

  • Greetings @jleiro17,

    You could very well be right. I purchased 1Password 4 for iOS a few years ago so it's far too easy to forget what is included in the in-app features. If it's any consolation it wouldn't have helped here, 1Password was exactly what was needed :smile:

  • marianoammarianoam
    edited June 2017

    Hey guys!

    It's marianoam here! I wanted to confirm everything is still working perfectly thanks to @littlebobbytables.

    I thanked him privately and forgot to do it here.

    Thanks!

  • yes, thanks! I purchased the PRO features and now I can see everything.

  • I'm glad everything seems to be good for both of you :smile: If you run into any further troubles please do let us know.

  • Actually, @littlebobbytables, I'm in the middle of another issue, now with my bank...

    https://discussions.agilebits.com/discussion/comment/377278#Comment_377278

  • Drew_AGDrew_AG 1Password Alumni

    @marianoam, littlebobbytables and I have replied to you in that other discussion (it looks like you noticed after posting here). To avoid confusion, we'll continue the conversation in that thread. :)

  • Of course. Thanks.

  • brentybrenty

    Team Member

    :) :+1:

This discussion has been closed.