how to disable the "always" asking for master password?

JamesXJamesX Junior Member
edited August 2011 in 1Password 4 for Windows
how do you disable this in 1password for windows? It always pops up

in my security preferences I have only the lock when my computer is locked checked, neither the lock after certain number of minutes nor lock when screen saver is activated are checked.

Comments

  • I assume you're referring to 1Password inside the web browser (IE, Firefox, Chrome). We have a setting for this here: File > Preferences (Ctrl+P) > Browsers > "Keep extensions unlocked".
  • JamesXJamesX Junior Member

    I assume you're referring to 1Password inside the web browser (IE, Firefox, Chrome). We have a setting for this here: File > Preferences (Ctrl+P) > Browsers > "Keep extensions unlocked".


    That's it! :)
    Tx
  • twynnetwynne Junior Member
    This doesn't actually work in Chrome. The Chrome extension seems to always ask for a password. Is there another way that I've overlooked?
  • DBrownDBrown 1Password Alumni
    twynne, there was a version (possibly a Beta build) of 1Password in which Chrome ignored the auto-lock settings, but we believe that problem is fixed in the current release.

    Please make sure you've updated 1Password to the latest release, and let us know whether you still see the problem.

    Thanks!
  • twynnetwynne Junior Member
    edited September 2011
    Hi,

    I'm running 1P for Windows v1.0.8.215 (updated yesterday) and the Chrome extension says it's the same version. Nonetheless, it prompts me every single time I invoke it to sign on to 1P. That's when it loads at all... it seems to take *forever* sometimes, unlike on Mac which is instant.

    My prefs set as follows:

    Lock after XX minutes - disabled
    Lock when computer locked - disabled
    Lock on screen saver -disabled

    Browsers - keep extensions unlocked - enabled

    Shout if any further info needed.
  • How are the IE and Firefox extensions working for you? Are they equally slow?
  • twynnetwynne Junior Member
    Slow as well, but not as slow as Chrome. I usually give up and type the login details before the 1p dialog even appears.
  • Are you running any anti-virus "solutions"?
  • twynnetwynne Junior Member

    Are you running any anti-virus "solutions"?


    Hi,

    It's a corporate laptop, so it has McAfee installed. Looks to be 8.7.0.570. Is there any issue?
  • McAfee is notorious for slowing 1Password down.
  • twynnetwynne Junior Member
    Argh. And I of course don't appear to have access to an exclusion. Any workaround to this?
  • DBrownDBrown 1Password Alumni
    edited September 2011
    Can you not configure McAfee to ignore 1Password?
    (I haven't used McAfee in 10 years or more, so I don't know what's possible in the current version.)

    Perhaps your IT folks can offer a solution. They must encounter this kind of problem at least occasionally.
  • twynnetwynne Junior Member
    See above. Corporate laptop and I have no access to add exclusions.
  • JamesXJamesX Junior Member
    I thought I had this figured out but I find 1password asking for my password way too much, is it necessary to have 1password program minimized?
  • DBrownDBrown 1Password Alumni
    twynne wrote:

    See above. Corporate laptop and I have no access to add exclusions.

    twynne, I did recall your earlier post. That's why I suggested consulting with your IT folks. I think they are your best bet, as we have no control over McAfee's behavior.

    We're sorry not to have a more satisfying suggestion at this time.
  • DBrownDBrown 1Password Alumni
    edited September 2011
    JamesX wrote:

    I thought I had this figured out but I find 1password asking for my password way too much, is it necessary to have 1password program minimized?

    James, I'm not positive I understand the question.

    As explained in Why is my 1Password data locked? in the FAQ section of the user's guide, the options on the Security and Browsers tabs of 1Password preferences are your tools for controlling 1Password's locking behavior.

    I hope that helps.
  • JamesXJamesX Junior Member
    edited September 2011
    I can't explain it but there is does not seem to be any consistency with the windows version of 1password, it bothers me, it either works or it doesn't - its locked or its not, now the short cut ctrl+\ is not working, very frustrating . I am coming from the mac version and never had any problems but the windows version is too finicky for me.

    Oh, and more nuissance, why does 1password ask me to save a password for a site that I allready have a login for??
  • DBrownDBrown 1Password Alumni
    edited September 2011
    Well, I think you mean sometimes it works, sometimes it's locked, etc.

    If you can describe the way in which it doesn't work or the sites where it doesn't work, we definitely want to look into those.

    As for the keyboard shortcut, here's a list of related topics. The first and third are of particular interest:

    The most common reason for 1Password to ask you to save a Login at a site for which you already have one saved is that something on the login form has changed. Whenever that happens, the first thing to try is save a new Login for that site, as described in this article:

    With some specifics, James, I hope we'll be able to help.
  • JamesXJamesX Junior Member
    so for example if I unlock first thing in the morning and I PC does not lock - shouldn't 1password not ask me for my password anymore if I have keep extensions unlocked when browsers are closed checked and auto lock only checked for lock when my computer is locked setup
  • DBrownDBrown 1Password Alumni
    The main 1Password program maintains its lock/unlock status separate from the lock/unlock status of each extension, so normally you have to unlock each extension each time you open the corresponding browser, even if you've already unlocked the main program.

    If you enable the "keep extensions unlocked" option, the extensions should share an lock/unlock status, though it's still independent of the status of the main program.

    The main program should follow the auto-lock settings you've set on the Security tab of 1Password preferences.
  • DBrown wrote:

    The main program should follow the auto-lock settings you've set on the Security tab of 1Password preferences.


    ...and so do our browser extensions.
  • DBrownDBrown 1Password Alumni
    That's news to me, Stefan. (blush)

    To clarify, the extensions should obey the "after N minutes," "when computer locks," and "when screen saver activates" options on the Security tab, just like the main 1Password program should?
  • DBrown wrote:

    To clarify, the extensions should obey the "after N minutes," "when computer locks," and "when screen saver activates" options on the Security tab, just like the main 1Password program should?


    Correct
  • JamesXJamesX Junior Member
    I don't think my locking system is working then, I can try and access the the same site later on and it still asks me for my password
  • DBrownDBrown 1Password Alumni
    edited September 2011
    James, do you mean that the site requires you to enter your username and password when you visit it again, or that 1Password requires you to enter your master password before you can get it to fill the login form at the site?

    (I ask because 1Password's lock/unlock behavior is unrelated to any specific site's requirements for logging in on subsequent visits.)
  • JamesXJamesX Junior Member
    edited September 2011
    1password asks me for my master password pretty much 9/10 times , hence my frustration
  • JamesXJamesX Junior Member
    JamesX wrote:

    1password asks me for my master password pretty much 9/10 times , hence my frustration


    it's like the Auto-Lock "lock after certain amount of minutes of inactivity" is not working since after a certain amount of time I need tor re-enter my master password again
  • What 1PWW version are you running?
  • JamesXJamesX Junior Member

    What 1PWW version are you running?


    version 1.0.8.216
This discussion has been closed.