After entering passphrase into 1Password I always have to enter macos keychain password. Why?

I have a MacBook Air running macos Sierra 10.12.3 with 1Password 6.6.3 Family version, including the Chrome browser extension.

1Password was working great, but after the last update, every time I unlock 1Password I get a dialog box pop up asking me to enter the password to unlock my keychain. Is that a new security feature? It's pretty annoying to have to enter the passphrase followed by a password every time. I don't remember changing any settings on the Mac.

This happens whether I unlock 1Password using the Chrome extension or the icon in the Mac's menubar.

The message in the dialog box is something like com.agilebits.onepassword4-helper wants to use the Local Items keychain.

Is there a way to stop this new behavior?

1Password Version: 6.6.3
Extension Version:
OS Version: macos 10.12.3
Sync Type: family


  • rickfillionrickfillion Junior Member

    Team Member

    Hi @rstoeber,

    It sounds like you might be running into an issue we've seen a couple times. Would you mind trying something for me? Could you go into System Preferences > Security & Privacy > General, and changing the password setting to something else then setting it back to what you had?

    Let's see if that makes the prompts go away.


  • Hi Rick,

    Happy to test whatever you want. I opened the security settings, clicked the padlock to unlock it, then changed a few of the options before closing the window. After that I opened the security settings again to make sure my changes "stuck" and they did, but I noticed the padlock was locked again - I had left it unlocked. Not sure if that matters to 1Password, but I wanted to mention it.

    Anyway, after making that change I clicked the 1Password icon for the Google Chrome extension and entered my passphrase. No extra password prompt for the local keychain this time, so I think it's fixed.

    Thanks very much for the help. Hopefully it stays fixed - I will report back with another comment if I see the problem again after rebooting and using the computer for a while.

  • rickfillionrickfillion Junior Member

    Team Member

    Great to hear that it sounds like it fixed it. I haven't heard of anyone having the problem come back after they did that, but there's a first for everything.



  • Yep, I can confirm that it stays fixed after stopping/starting the Chrome browser and reboot the computer.

    Another job well done!

  • rickfillionrickfillion Junior Member

    Team Member

    Woo! :)


  • Hi, this problem has returned.

    Now I'm running version 6.7.1 (Family edition). Following your instructions the problem seems to go away, until I reboot. After rebooting the computer (which I normally only do ever 2 - 3 weeks) I always get the pop-up dialog box telling me the Agilebits 1password helper needs access to the "Local Items" keychain.

    Any idea how to fix this permanently?

  • Drew_AGDrew_AG 1Password Alumni

    @rstoeber, do you happen to be using a MacBook Pro with Touch ID, and are you using Touch ID with 1Password?

  • Hi Drew. No I'm using a MacBook Air with macOS 10.12.4

  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member

    Hi @rstoeber!

    Do you have anything else installed on your Mac that is trying to "harden" or tinker with security settings? It may be tinkering with some of the settings when you first log in. I am just speculating, but that is my first guess.

  • Thank you @jpgoldberg

    I think that was it. A few weeks ago I started testing something called Key Lemon ( which uses face recognition to "unlock" the MacBook. Basically when I wake up the sleeping computer it scans my face to see if it recognizes me. It's not perfect, but it works pretty well, and when it works it's much easier than typing a long password.

    I had no idea this could interfere with 1Password. But now I've deleted Key Lemon and I haven't had the problem with 1Password since then.

  • Drew_AGDrew_AG 1Password Alumni

    That's good news, thank you for following up to let us know what you found! I hadn't heard of that app before, and while it sounds very interesting (and somewhat "futuristic"), I'm sorry to hear it also seems to have been causing the prompt to enter your macOS keychain password. But I'm glad you were able to solve that so it no longer happens!

    Hopefully you're all set now, but if you need anything else, just let us know. Cheers! :)

  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member

    I'm glad you found out what it was, @rstoeber!

    I haven't heard of key lemon before, but if you do experiment with it again, you might want to see how easily it can be fooled by a picture of you. I'd be curious to know.

  • I have been having this problem, too. I'm running macOS 10.12.5 on a MacBook Pro Late 2011. I've been encountering this problem for a few months, now--I've just put up with it, figuring that maybe an update will fix the problem, but 1Password has probably been updated one or two times in the interim, and the problem persists. Basically, if I wake my computer from sleep and have to enter my Mac account password to unlock the screen, the first time I use the 1Password extension with any browser, I have to enter my master password AND my Mac's Keychain password (I have my Keychain set to use a different password than my login password). Any suggestions will be appreciated.

  • beyerbeyer

    Team Member

    Hello @PeteChien,

    Thanks for taking the time to reach out to us!

    From your description:

    I have my Keychain set to use a different password than my login password

    It sounds like everything is working as intended by Apple. If you're using a different password to log in to your Mac and your keychain(s), then you'll continue to be prompted for the keychain password after each login.

    To fix this, you can follow Apple's support guide on updating your keychain password.

    Let me know if that helps.


    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

  • Hi,

    I am having the same issue and none of the solutions presented above helped. Could it be that Near Lock is interfering with 1P (same as Key Lemon)?


  • LarsLars Junior Member

    Team Member

    Hi @maartenvosselman -- it certainly could be, though I don't have experience with that particular application. Are you able to temporarily disable Near Lock to test? I wouldn't want you to have to delete or uninstall anything just for testing purposes, but I'm wondering: when did you install Near Lock, and did the problem(s) with 1Password start happening around that time?

  • Hi @Lars, I temporarily disabled it, but the issue persists. There are no items in my local items keychain by the way. I have changed my passwords in both Login Keychain and my computer login (new passwords and they are the same). I have no clue what to do. Also not entirely sure if the problem occurred after installing Near Lock... I think the problem was there before. Any checklist with steps that I can try (again) maybe? It is so annoying. I have to do this each time I am not logged in yet in 1Password mini... Thanks, Maarten

  • @Lars it works again. After rebooting and not automatically opening Near Lock it is fixed. Do you have any idea why this problem occurs? Near Lock was really helping me out not having to type in my password on my computer each time (this happens 20 times per day at work). Would be nice if these programs would work together... Best, Maarten

  • bundtkatebundtkate

    Team Member

    @maartenvosselman: My best guess, based on what Beyer mentioned in response to older comments here, is that macOS may be interpreting Near Lock's tinkering with security settings as setting your keychain password as something different than your login password, which lands you with this issue. If correct, I doubt there will be a workaround available here, but as stated, this is just a guess. Without knowing more about the inner workings of Near Lock and how it affects macOS settings, it's unlikely we'll be able to do more than guess at why it doesn't play nice with 1Password. :frown:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file