Autotype breaks after upgrading Kaseya to version 9.4

I use the autotype function in Kaseya 9.3's remote control application. It normally works great, but they recently released a new version 9.4, and since we upgraded the autotype function is not typing special characters correctly. For example, if a password contained @, it would type 2 instead, as though it were not hitting shift for that character.


1Password Version: 4.6.1.618
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Dropbox
Referrer: forum-search:kaseya 9.4

Comments

  • brentybrenty

    Team Member

    @jaredslayton: We haven't changed how Auto-Type works in years, so this really sounds like it's unrelated to 1Password. Try this:

    1. Restart Windows
    2. Use Auto-Type to see if it works.
    3. If not, uninstall Kaseya.
    4. Try Auto-Type again to see if it works now.

    If 1Password works without Kaseya installed (or with an older version), it seems like that's the problem. 1Password is just sending keyboard commands to Windows, and unfortunately there's no way to prevent other apps from interfering with or modifying this. Let me know what you find!

  • I saw a thread elsewhere on the site that led me to believe that you guys tweak the code for different applications. If that's not the case, my mistake! Note that Autotype works in other applications, just not in the Kaseya remote control software.

    I uninstalled and reinstalled Kaseya and did a reboot, but it is still doing the same thing when special characters are present in the password (which is most of the time at our company).

  • brentybrenty

    Team Member

    I saw a thread elsewhere on the site that led me to believe that you guys tweak the code for different applications. If that's not the case, my mistake! Note that Autotype works in other applications, just not in the Kaseya remote control software.

    @jaredslayton: Ah, sorry for the confusion there, and thank you for confirming. I wanted to be sure there wasn't some strange bug.

    I uninstalled and reinstalled Kaseya and did a reboot, but it is still doing the same thing when special characters are present in the password (which is most of the time at our company).

    I'm not sure I understand. From your previous comments it sounded like Auto-Type is working normally with other apps. When Kaseya was not installed, did you have any issues using Auto-Type?

  • Not that I recall. Let me see if I can explain more thoroughly. We use Kaseya LiveConnect to remotely access workstations and servers on our network. It is convenient to then use Autotype from 1Password to input credentials into those remote machines in the Kaseya window. Removing Kaseya won't solve the problem because I need Kaseya more than I need AutoType - AutoType is just a great time saver.

    I hope this makes more sense.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @jaredslayton,

    Could it be related to this issue: https://discussions.agilebits.com/discussion/comment/364309/#Comment_364309

    Try checking the keyboard settings in your Kaseya's client to see if there's something that can help.

  • It sounds very similar, yes. Unfortunately Kaseya does not appear to have any settings similar to those described in that thread.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @jaredslayton,

    Sadly, this isn't something we can fix. We can only tell Windows what keys to emulate and that's pretty much it. We have copy/paste as a hardcoded workaround for certain apps but this doesn't work for remote session type of apps either.

    We are considering a different implementation of how Auto-Type will work in 1Password 6, so we could have a better solution but I don't have an ETA when that'll happen.

  • I appreciate the attention and quick responses. Thank you.

  • brentybrenty

    Team Member

    Likewise, it helps to get a sense of the challenges you're facing so we can take that into account as we develop future versions. Cheers! :)

This discussion has been closed.