Prompted for PIN instead of Touch ID on iOS 10.3

edited March 2017 in iOS

Hello,

Updated my ipad air 2 yesterday to ios 10.3. All was working fine with 1 Password before the update. But now I do not have an option for touch id. It is not visible in 1 password. Instead I have a pin option. I removed the program and installed it again. After that the touch id was there again to be used, but after closing the program and starting it again no touch ID to be found. Instead the Pin comes up again. Hope you can solve it.


1Password Version: 6.5.3
Extension Version: Not Provided
OS Version: Ios 10.3
Sync Type: iCloud
Referrer: forum-search:Touch id for 1password on ipad air is not visible or working after ios update 10.3

Comments

  • BenBen AWS Team

    Team Member

    Hi @hans_dingler

    I'm sorry to hear about the trouble. I'd be happy to help with that. I'd like to ask you to create a Diagnostics Report from your iOS device:

    Sending Diagnostics Reports (iOS)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

    Ben

  • Hello,

    An update about on my earlier remaome strangesoftware behaviour in 1 Password. As I closed it (swiping) and restarted the programm I went to Security tab and there it said no more PIN but Touch ID. I am somehow confused what is the matter. What kind of bug do we have here?

  • Hi Ben,

    Thanks. Somehow all is working well at present. I do not know who fixed something behind the scene. When the incident re-appears I will send you the report.

  • BenBen AWS Team

    Team Member

    Thanks for the update @hans_dingler. We didn't fix anything, but I'm glad to hear it is working. Magic! If we can be of further assistance, please don't hesitate to contact us.

    Ben

  • Problem is back. After some unsuccesfull attempts with Touch ID (garden work finger print in Touch ID) was not accepted. So 1 password asked for full login. After that I looked for changing it to Touch ID but it only mentioned PIN where Touch ID was first mentioned. See attached file.

  • Hello Ben,

    Same issue appears on iPhone 6 of my wife. With same protocol that I used on my iPad air2: Touch ID of fingers not regocnized after some attempts. Program asks for whole password to open. I go to security tab and instead of Touch ID we see Pin Code.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @hans_dingler,

    Sorry to hear you're having trouble with Touch ID in 1Password again! From your description, it sounds like something in the operating system might not be working correctly. It's difficult to tell for sure though, because we're using Apple's API and hardware for Touch ID and don't have much control over it. When you use Touch ID to unlock the 1Password app, iOS is really doing the authenticating - in other words, 1Password asks iOS to authenticate you with Touch ID, you scan your fingerprint, and iOS tells 1Password whether or not Touch ID worked. If it doesn't work, that's because iOS is telling 1Password that your fingerprint wasn't accepted.

    Similarly, the option you see in 1Password > Settings > Security depends on whether iOS tells 1Password that Touch ID is enabled on the device. If it tells us Touch ID is enabled, 1Password will show the Touch ID option. Otherwise, 1Password will show the PIN Code option. If iOS isn't consistently telling 1Password that Touch ID is enabled, that could explain why you don't consistently see the Touch ID option in 1Password. (But it's strange that the same thing is happening on your wife's devices.)

    Rebooting the iOS device might help (i.e. completely power it off and then boot it up again), but if not, you might want to try some more thorough steps to disable & re-enable Touch ID on your iOS devices:

    1. Open 1Password, go to Settings > Security, and disable Touch ID.
    2. Open the Settings app and go to Touch ID & Passcode (enter the device passcode when prompted).
    3. Disable the "Use Touch ID For" settings.
    4. Hold down the power button for a few seconds and "slide to power off", then turn it back on again.
    5. Unlock your device with the passcode.
    6. Open the Settings app and go to Touch ID & Passcode (enter the device passcode when prompted).
    7. Enable the "Use Touch ID For" settings.
    8. Open 1Password, go to Settings > Security, and enable Touch ID.

    Let us know how it all goes and if that helps, thanks! :)

  • Ok, I understand. Touch ID is leading in this. And indeed after a hard day of garden work with my fingers, they are not accepted on the devices so it is no wonder that the devices switch to another option to log in. I will see what the future holds and certainly will do a clean install as you describe. Thanks for your respond.

  • Repond came from Drew_AG. So issue closed.

  • Drew_AGDrew_AG 1Password Alumni

    You're very welcome! Hopefully disabling & re-enabling Touch ID on your iOS devices will help, although it sounds like part of the problem might be due to your fingers after all the garden work. Either way, we'd love to hear how it goes! :)

This discussion has been closed.