6.6.403 Beta: Shortcuts doesn't work when booting up, app restart is required [Fixed in 6.6.405]

pawopawo
edited April 2017 in Windows Beta

Ctrl-# shortcut which I am using a hundred times every day in my Chrome browser suddenly doesn't work anymore after the update to 6.6.403! Can you please fix this quickly! Thanks. pw

P.S.: I have already done all the usual stuff: restarting everything (PC, 1Password, Chrome), deleted and re-installed the browser extension etc.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

«1

Comments

  • @pawo sorry for the confusion, it is supposed to work only when it is invoked over a connected browser where it can auto fill. When you want 1Password mini to appear without auto fill - please use Ctrl+Alt+#. Hope that helps :)

  • Meanwhile I could fix it myself, it works again with no problems so far. Here is what I did, in case others might have the same problem:
    As mentioned above I had already restarted everything but htis did not do the trick - at least not that alone. However, I would still recommend to first restart everything before you try more. What I did then in addition was cleaning up the whole PC including of course my browser with CCleaner. Having done that, it worked again. pw

  • thank you @SergeyTheAgile. I know the difference between Ctrl-# and Ctrl-Alt-# and how that all is supposed to work. However, none of this worked anymore at all after the update. Anyway, I fixed it now and explained above how I did it. thanks again pw

  • @pawo I'm glad it works for you now. I'm still interested to figure out why neither Ctrl+# nor Ctrl+Alt+# worked for you, please let us know if it happens again. Meanwhile I'll make sure we have some useful logging in the next update. Thank you!

  • @SergeyTheAgile I'm seeing this same behavior by the way, neither Ctrl+\ or Ctrl+Alt+\ work in Chrome after upgrading 1Password to 6.6 Beta 1. I haven't restarted yet. The browser icon works fine but it means I have to open each Chrome App window in a tab to get to the browser button and log in and then switch back to and reload the Chrome App window (I have at least 3 I use every day in Chrome Apps). I assume restarting (Chrome or computer?) will fix if it did for @pawo but it's still a repeated issue so I figured I'd mention it :-)

  • @dszp thanks for letting me know, can you try to restart 1Password itself (click Exit in taskbar notification icon menu) to see if it helps? I've bumped in it today once, but it was after computer was at sleep with some nasty reboot overnight. My guess would be that our registered system wide hotkeys simply was "forgotten" somehow due to power cycle or something else. Trying to figure out how to provoke it again. Thank you!

  • Same here Ctrl \ or Ctrl Alt \ stopped working. Cured by restarting 1Password. Happened twice today, first time after installing the new Beta and then again after Windows 10 Creative update.

  • brentybrenty

    Team Member
    edited April 2017

    @cbb: Thanks for letting us know. I'm sorry for the trouble there! I haven't encountered this myself, but if if happens again the best thing to do will be to send diagnostic information so we can look at the logs to determine exactly what is happening:

    1. Click on the start button to search for Event Viewer, open it.
    2. On the left sidebar, expand Applications and Services Logs, 1Password should show up below here
    3. Right click on 1Password to select Save all events as and save it as 'logs.txt', set Save as Type to Text (tab delimited) (*.txt)

    Please send it to [email protected] with a link to this discussion and your username in the email so we can 'connect the dots', and post the Support ID you receive here. We will get to the bottom of this! :)

  • @SergeyTheAgile My computer had a BSOD on resume from sleep when I got back to my office this afternoon. So, forced reboot :-) Had the same issue in Chrome. No Ctrl+\ would work, but Ctrl+Alt+\ was working. I used standalone Mini, opened the same site (in a tab rather than Chrome app), and used the extension to fill. THEN the hotkey Ctrl+\ worked...even back in the Chrome App. Restarting 1Password before the steps above with Mini didn't resolve the issue (I changed the hotkey setting, restarted 1P, changed back, restarted, and it still didn't work). So I'm not consistent on how it starts working again but it doesn't seem to work in Chrome until after I use the icon to fill and then it works normally after that, across sites.

  • XIIIXIII
    edited April 2017

    Ctrl+\ and Ctrl+Alt+\ both not working here, despite these entries in the Windows event log:

    AgileBits.OnePassword.SystemHotkey Registering system wide hotkey for Ctrl+\ with virtual key code 220.

    AgileBits.OnePassword.SystemHotkey Registering system wide hotkey for Ctrl+Alt+\ with virtual key code 220.

    No other entries that seem useful.

    After a manual restart of 1Password both worked again.

  • brentybrenty

    Team Member

    @dzsp, @XIII: If you encounter this again, please send a diagnostics report at [email protected] :

    Sending Diagnostics Reports (Windows)

    Just post the Support ID here and we'll see if we can narrow down the cause. Thanks in advance!

  • With me this is happening when I restart my computer, I thought it might be and I've just confirmed it. Restarting 1Password fixes it.

    I've sent diagnostics as requested. Support ID: #RPP-93527-217

  • Thanks @cbb, i can confirm it happens to me too when 1Password is autostarted. We are investigating what can be done.

  • @pawo @dszp @cbb @XIII can you please let us know your Windows build number? Thank you!

  • It continually happens to me again as well. I didn't have the time so far to do some more investigation or diagnostics report, but restarting 1Password doesn't always do the trick. I usually have to restart the PC :-(. My windows build is:
    Windows 10 Pro
    Version 1607
    Build 14393.1066

  • Build number is 15063.138

  • Thank you @pawo & @cbb, at least I can discard "oh it's probably new Windows build issue", I'll look into other leads then.

  • @XIII can you please let us know your Windows build number?

    Microsoft Windows 10 (Pro) Creators Update, Version 1703 (OS Build 15063.138).

    With me this is happening when I restart my computer

    Same here.

  • This is super annoying when you 100% rely on 1Password for working in the web, to be honest. I have now taken the time to create a Diagnostics Report and have sent it via email. The ID number is Diagnostics for 1Password v6.6.403d 1492264877. PLEASE help us to resolve this quickly. Thank you. pw

  • MikeTMikeT Agile Samurai

    Team Member
    edited April 2017

    Hi guys,

    This is not related to Windows 10, I managed to reproduce it on Windows 7. No need to send in the diagnostics report anymore but thank you so much for sending them in.

    @pawo, if it is too annoying, you can switch back to the stable version as it is not affected there. We will get this fixed, we have it narrowed it down to the way 1Password starts when it boots up and it only affects the latest beta build; we did make some changes to work with the automatic update feature and that may be the cause.

  • thanks @MikeT! You are great and dedicated guys hence I will wait for your solution rather than switching back which is another effort... :) . pw

  • MikeTMikeT Agile Samurai

    Team Member

    Great, thanks for your patience! Stay tuned for the update, hopefully 1Password will automatically update itself for you guys if you have that turned on. :smile:

  • I'm a little late to the party (working and sleeping and all :-) but I have the same build, 14393.1066, of Win 10 Pro, and I had the same issue this morning after Chrome and 1Password were working last night, I put my Surface Pro 3 to sleep and then woke it up this morning, unlocked 1P which was already running and tried to Ctrl+\ to a Chrome App that was already open and it won't work again. Similar but slightly different circumstances. Still on 6.6.403d.

  • brentybrenty

    Team Member

    Thanks for confirming. We're on the case! :)

  • The fix is made and will be available with the next update, sorry for the trouble and thank you all for help!

  • @SergeyTheAgile I'll wait for the update, but I thought I'd mention that after an upgrade to Windows 10 15063.138 (Version 1703 Creators Update), the shortcut keys are no longer working at all, even after using Mini from a tab one time with the icon. So it got worse. Hopefully the fix works on that build as well :-)

  • @dszp I believe it should work regardless of Windows build, it appears that hotkey registration was done a bit "earlier" than usual when started with /silent. Let's see how it works once update is out :)

  • cbbcbb
    edited April 2017

    I can confirm 1Password updated itself silently and this is now fixed. Well done.

  • Thank you @cbb, glad it works as expected now :)

  • Same for me! Thanks a lot for the quick solution.

This discussion has been closed.