1Password: Painfully slow

Has anyone else notices that 1Password has now gotten painfully slow. It is now taking 5-20 seconds to accept the master password. This has been happening for a couple weeks now, both across reboots and across two different Macs (iMac and MBA). Both machines are running the latest version of OSX (10.12.4).


1Password Version: 6.6.4
Extension Version: 4.6.4.90
OS Version: OSX 10.12.4
Sync Type: DropBox

Comments

  • brentybrenty

    AgileBits Team Member

    @kevinashaw: I haven't heard of this before myself, and if you're experiencing the same problem on both Macs I wonder if they have something in common. Have you tried restarting? It definitely shouldn't take your Mac that long to decrypt your data on unlock unless it's super old — like, too old to run Sierra.

    If you're still having trouble, the best thing to do will be to restart your Macs, reproduce the same issue, and then generate a diagnostic report for each so we can look at the logs to determine exactly what is happening:

    Sending Diagnostics Reports (Mac)

    Please send it to support+forums@agilebits.com with a link to this discussion and your username in the email so we can 'connect the dots', and post your Support ID here. Also, knowing your timezone and the date/time of the incident will help us find it in the logs. Once we see the report we should be able to better assist you. Thanks in advance!

  • I have seen this issue as well, for about the last month to month and a half. I have 8 users, all on Macs. Some of use have 2 Macs, most of us use it with iOS devices as well. On Mac it is super slow, iOS is not. I see the issue not only on unlocking the vault, but also when clicking between individual items. Often see a 5-20 second lag.

    If it helps we have about 170 Vaults currently.

  • JacobJacob

    AgileBits Team Member

    @jakemckean Sorry about that. With a high number of vaults, there was an issue in 1Password for Mac just like what you're describing. We've fixed it in a recent beta, and it'll be fixed in the stable release as soon as we're finished testing things. You're welcome to give the beta a try if you'd like to get things moving now. :)

  • Awesome. Love to hear a fix is in the works. I will give the beta a look, but will probably wait to roll out until general release.

  • I've seen a similar issue...on both of my Macs when entering the master password it is sometimes extremely slow. For example, I finish typing my master password and wait anothe 5 seconds for the obfuscation bullets to appear. After entering the app I don't notice any slowness. Quitting the app has resolved it. Could it have something to do with Secure Input?

  • brentybrenty

    AgileBits Team Member

    @kevlar: Are you also using a large number of vaults? Otherwise, if you're able to resolve the issue simply by relaunching the app, I wonder if something was just hung up temporarily. Something similar happens to me sometimes when switching between versions.

  • sjksjk oversoul

    AgileBits Team Member

    Hi @jakemckean,

    I will give the beta a look, but will probably wait to roll out until general release.

    If you're running the version of 1Password for Mac from the Mac App Store (MAS), my suggestion would be to wait rather than switch over to the website version and use beta builds. Sometimes it can be confusing to choose which 1Password data to use when switching between MAS and website versions, especially if it's not all being stored in a 1Password account.

  • Aha! Hopefully this will address the slowdown I've been experiencing!

  • brentybrenty

    AgileBits Team Member

    :) :+1:

  • edited April 21

    I'm only using one vault and it just took 21 seconds from the time of entering the password to the login list opening up.

  • brentybrenty

    AgileBits Team Member
    edited April 22

    @kevinashaw: Were you able to send diagnostics as I suggested originally? I didn't hear back from you until now, and I'm not seeing anything in our inbox under this address. Unfortunately we can really only guess what might be causing this issue for you without more information. :(

  • I'm guessing this is the issue. Here is a screengrab from the Activity Monitor showing current memory usage by 1Password. It shows 1Password using a little under 600MB.

    If I quit and restart 1Password, the new memory usage is:

  • I just submitted the Diagnostic Report. -K

  • brentybrenty

    AgileBits Team Member

    @kevinashaw: That's odd. I've had my Mac going for 10 days and it's showing 200MB. Not seeing anything in our inbox from this address. Can you post the Support ID I asked for? Thanks in advance! :)

  • There doesn't seem to be a way to reply in-private. So posting publically: #TKQ-21986-777. -K

  • brentybrenty

    AgileBits Team Member

    @kevinashaw: The Support ID itself is completely random and refers only to the ticket in our internal system, so it's no problem posting it here. Anyway, thanks for sending that. We'll take a look at the diagnostics and get back to you shortly! :)

    ref: TKQ-21986-777

  • deviantintegraldeviantintegral Junior Member
    edited April 25

    I also just had some pretty poor performance in the OS X app. I spent an hour working in it auditing items (with lots of deletes), and there was significant CPU use and UI lag scrolling, moving items to the trash, or restoring them. Even now, 1Password 6 is sitting at ~2.4GB of RAM, though I saw it peak at 2.75GB. Ouch!

    TFN-37611-722 is the support ID with the diagnostics report.

  • Drew_AGDrew_AG AG Alumni

    Thanks @deviantintegral! We received your diagnostics report, and someone will get back to you as soon as possible with more information. We'll keep the conversation going directly via email to avoid complicating things between here and there. Cheers! :)

    ref: TFN-37611-722

This discussion has been closed.