Keyboard shortcut to copy password from 1Password Mini

I'd really like to be able to copy the password from an entry in the 1Password Mini window without having to right-click it with the mouse. However there's no specific reference to that shortcut in the Mini section of https://support.1password.com/keyboard-shortcuts/.

I've tried Shift+Ctrl+C which doesn't work for me in Mini, nor in the main 1Password app.

I don't have any custom key shortcut managers like AutoHotKey running so I'm not sure why this isn't working for me. I'm on Windows 10 Anniversary Update.


1Password Version: 6.5.401
Extension Version: 4.6.4.90
OS Version: Windows 10
Sync Type: 1Password

Comments

  • GregGreg

    Team Member

    Hi again @sjstreeting,

    Thank you for using 1Password 6! It means a lot to us, as we are working every day to make it better.

    Ctrl+Shift+C should work in the main 1Password app when you select a certain item. For example:

    1) I click on a test item in my vault and then press Ctrl+Shift+C.
    2) I get a little context menu next to the cursor, so I can quickly click on what I need to copy:

    At the moment, this shortcut works in the main 1Password app only. We are improving 1Password 6 for Windows constantly, so please stay tuned. It would be cool to use 1Password without a mouse. I wonder if the next step will be using it without a mouse or keyboard... :lol:

    Thank you for your suggestion! If there is anything else we can help you with, please let us know.

    Cheers,
    Greg

  • brentybrenty

    Team Member

    @sjstreeting: We don't yet have advanced keyboard shortcut support in 1Password mini itself, but Ctrl Shift C will bring up this menu when a login is selected in the main 1Password window:

    We'll be adding more keyboard shortcuts in the future though, so it's good to know you'd like a quick way to do this in 1Password mini (though I find I prefer Ctrl \ to fill quickly). In the mean time, as you mentioned, right-clicking an item in 1Password mini will give you a menu to copy a field. Thanks for bringing this up!

  • Thanks for both your answers! I'm mainly interested in 1Password Mini because I'd like to be able to press Ctrl+Alt+\, find the item via search, select with the cursor keys then press a keyboard shortcut to copy the password. The reason I need this in addition to Ctrl+\ is that I use a bunch of desktop apps which request logins which autofill can't cope with.

    However, Ctrl+Shift+C does not popup with a context menu in the main 1Password app for me. I don't know why this is - this Windows 10 machine is actually less than a month old so doesn't have a lot of custom configuration to it that could be hanging around that I'd forgotten, but Ctrl+Shift+C does absolutely nothing in the app for me. Any idea how I can diagnose that?

  • Oh FWIW this does work for me in 1Password for Mac (including in Mini), it's a use case I'd really like to see fully supported in Windows too.

  • brentybrenty

    Team Member

    @sjstreeting: Ah, looks like Greg and I replied at the same time. Glad that between the two of us we were able to help! :lol:

    Indeed, we want constant functionality between platforms. Even if it will take us some time and work to get there, I think it's worth the effort.

    I'm not certain why the keyboard shortcut isn't working for you, but there are two possible causes. First, we've fixed a bug (available in the latest betas) which caused 1Password to not respond to keyboard shortcuts sometimes if it was launched after restarting Windows. If other shortcuts are working for you though, that's probably not it. In that case it's more likely that some other app is already listening for that, though I couldn't tell you what that might be.

  • mh4llmh4ll
    edited April 2017

    Helpful workaround: the Windows context menu key (right side of the spacebar on my keyboard) will let you simulate the right click. So you can copy a password entirely from the keyboard with Ctrl+\, tab/arrow keys to select item, context menu key, arrow key to select "password", enter, escape to close Mini. Sort of clunky, but no mouse required. I really hope AgileBits fixes this soon -- a simple Ctrl+C seems like a no-brainer.

  • brentybrenty

    Team Member

    @mh4ll: Ah, that's a great hack! I haven't had a keyboard with that key (and never really knew what it was called anyway) for a while, so I forgot it even existed. We'll definitely be adding additional hotkeys in future updates. Thanks for sharing that tip! :)

  • @brenty: I've tried updating to the beta (6.6.406) but the keyboard shortcut still doesn't work for me. I don't know what other app can be listening for this, it doesn't seem to do anything and this is a pretty new machine as I said so I have nothing hanging around. I guess the solution is to support changing the keyboard shortcut?

    @mh4ll: thanks for the suggestion, unfortunately though the context key opens the right-click menu at the location of the mouse cursor, not based on the UI focus from navigating from the keyboard, so for me it doesn't really help since I'm trying to avoid using the mouse. The mouse pointer is always in the top-left corner of the window after opening it so the context menu is the window one, which only has generic items: disabled Cut/Copy and an enabled Paste.

    Looking forward to improvements to 1Password for Windows in future - I've used it for years mostly on Mac, and the current Windows version is way better than back in the 1Password4 days, it just needs a tiny push to bring it up to the same level as Mac :)

  • Aha, I found the culprit for Ctrl+Shift+C in the 1Password app - the AMD software that came pre-installed binds that key for something, it just doesn't do anything unless you're already recording the screen. Changing it has made Ctrl+Shift+C work in 1Password at least, just waiting for Mini support now :)

  • brentybrenty

    Team Member

    Wow. That's impressive! If I ever lose a needle in a haystack, I'll come to you first. :lol:

This discussion has been closed.