Autofill not working for Atlassian JIRA webapp

I'm going through my 1password logins and verifying that they autofill correctly. If they don't autofill, it's usually because the URL is wrong, so I adjust it and everything is well.

However, I can't get autofill to work for one site: http://aijira/login.jsp

This site is hosted on my company's private network and is not accessible outside the network. At first, I assumed this was the issue. However, autofill is working correctly for the following site, which is also hosted on my company's private network: http://aistash/login

Any ideas on how to fix this? I've tried manually creating a new login with the correct url and I've tried filling in my credentials and selecting "Save new Login" from the 1password extension in the browser. In both cases, the page still refuses to autofill.

Thanks.


1Password Version: 6.5.401d
Extension Version: 4.6.4.90
OS Version: Windows 7 Professional 64-bit
Sync Type: 1Password Families
Referrer: forum-search:AutoFill not working for Atlassian JIRA

Comments

  • matthew_agmatthew_ag 1Password Alumni
    edited April 2017

    Hey @ssteigen,

    Thanks for writing in and sorry about the trouble with filling in your Login item. It sounds like you're well versed in 1Password's features so I'm sorry in advance for nitpicking :) 1Password never Autofills, just in case you were expecting 1Password to automatically populate your login details would when you open that page in your browser, like a Chrome's password manager would for example.

    Instead, 1Password always relies on an action from the user in order to do the filling, e.g. the 1Password keyboard shortcut ( ⌘ \ ) or using Go & Fill.

    1Password will work on websites that aren't accessible from the public internet - the entire filling process is done on the local computer. Only 1Password data syncing requires public internet access. It sounds more like there is something strange or unusual with the web page itself that is causing 1Password to not fill. I take it that it has never worked before for you with 1Password? Since you have already tried saving a new Login item manually then the next step would be for us here at AgileBits to take a look at the web page itself that you're trying to fill.

    Since it's an internal web page - I obviously cannot access it via that URL however I can take a look if you go to the web page, save a copy of the page and then forward a copy of it to us here at AgileBits. It would probably be best if you sent us a copy directly using the AgileBits contact form. That will open a ticket in our customer support system and then I can take a look. I can then test the log in page out myself and see if I can offer any guidance on how to create a Login item that will fill for you :chuffed:

    If you'd like to do ahead with this:

    1. First go to the web page and then save the page (from the menubar, choose File > Save Page As...)
    2. Let's say you saved it to your Desktop, then go to your Desktop and select both the folder and HTML file that were saved there. Then right-click on them and choose "Compress 2 items".
    3. A new .zip file will be created.
    4. Go to our 1Password Contact form. Choose "I have a different Question" > "Something Else".
    5. Unfortunately, you can't attach a file at this point but please write a note here any way linking to this thread and you will receive a automated reply from our support responder. If you have a file sharing service like Dropbox, just include a link to the uploaded .zip file.
    6. You can then reply to this responder with your .zip file.
    7. Once that's all done, you can reply to this thread with the code of your ticket to allow me to find it and I'll investigate :) The code should look something like this:

      CQT-59442-155

    Looking forward to hearing back.

    Best regards,
    Matthew

  • ssteigenssteigen
    edited May 2017

    I understand what you mean about this feature not technically being "autofill." You're correct that I'm referring to the "Go & Fill" feature.

    I've opened another ticket linking to this thread, recieved the auto-responder email, and replied with an attached zip file of the webpage I'm having issues with.

    Here is the code for the new support ticket: [#QAS-24919-582]

  • matthew_agmatthew_ag 1Password Alumni

    Thanks @ssteigen,

    I just got your email and the attachment is just what I needed! I'll be in touch over email once I investigate more.

    Thanks for your patience and assistance while we work with you on this.

    Best regards,
    Matthew

This discussion has been closed.