browser integration problems after update to ver 6.7

Updated to 1Password6 ver 6.7. New version could not see that browser extension already installed & enabled in Safari 10.1, offered to download. I let it but it would not install, "an error occurred". I had to uninstall the extension and reinstall it; then communication between 1Password6 and extension was reestablished.

Trying to use 1Password in Chrome 58 gave an "unable to verify browser" error; a system restart solved that.

No problem with Firefox 53.


1Password Version: 6.7
Extension Version: 4.6.4
OS Version: 10.11.6
Sync Type: Dropbox

Comments

  • Drew_AGDrew_AG 1Password Alumni

    Hi @RichBT,

    Thank you very much for taking the time to report the problems (and solutions) you ran into after installing the update! I'm glad the Safari and Chrome extensions are working now. The error you received in Safari when trying to install the extension is normal if that extension is already installed. It's strange that the extension wasn't connecting properly to 1Password, but it's possible that restarting Safari or 1Password (or rebooting your Mac like you did for the extension problem in Chrome) would have solved that.

    Earlier I noticed another thread about a similar problem (I think restarting the Mac solved that as well). That could be a coincidence, but I'll keep an eye out for other reports of this in case it's something others are also running into.

    Thanks again, we appreciate it! :)

  • Hey Drew,

    Thanks for the good words. I continue to have problems. Just now I went to use 1Password6 to log into a ecommerce site I use a lot. 1Password did not display the correct login at the top of its list but rather a suggestion that I install the Safari extension. Even though the Safari extension is installed and enabled. I had to uninstall the Safari extension, reinstall it & restart Safari to get things working properly again. So, at least on my system, 1Password is having intermittent problems seeing that the Safari extension is in fact installed and enabled.

  • Hi @RichBT and @Drew_AG,
    Same problem here, but when I tried uninstalling the extension and reinstall it I got the installation error message.

    MacOS 10.12.4
    Safari 10.1
    1Password 6.7.1
    Extension 4.6.4

  • rudyrudy

    Team Member

    @RichBT and @freedog,

    I think you're seeing a side effect of an issue we identified with Safari extension gallery installed 1Password extensions. You can read more about it at https://discussions.agilebits.com/discussion/78160/

    Rudy

  • @rudy Thanks. I tried searching some answer in the forum, but failed identifying some good answers. Thanks again for your support.

  • Drew_AGDrew_AG 1Password Alumni

    On behalf of Rudy, you're very welcome! Please let us know if you need anything else. :)

This discussion has been closed.