"Browser could not be verified"

Getting "Browser could not be verified" on Chrome Version 58.0.3029.96 (64-bit), extension 4.6.5.90, macOS 10.12.4 (16E195), 1Password 6.7 (670008).

I have deleted the extension, successfully re-added it, and problem persists. Works fine under Safari.


1Password Version: 6.7
Extension Version: 670008
OS Version: 10.12.4
Sync Type: iCloud

«1

Comments

  • Same issue here. Happened after that latest Chrome update. Reinstalled the extension countless times already. I switched to Firefox for the time being since it works there but Firefox is terribly slow.

  • srisri
    edited May 2017

    A little more information...and yes, me too, BTW. Same problem.

    1P extension for Chrome (version: 58.0.3029.96 (64-bit)) on MacOS 10.12.4 (on MacBookPro) sayeth "Browser could not be verified"

    As a result, while I can search for stored passwords the data will not get filled on the login fields. For example if I pull up my entry for AgileBits Forum, instead of filling the login credentials another Chrome tab is opened and it is directed to the AgileBits Forum page (again).

    I have taken the following steps in an attempt to fix it:
    1. Deleted Chrome by moving Chrome.app to trash
    2. Deleted ~/Library/Application Support/Google/Chrome (yes the entire directory)
    3. Restarted laptop
    4. Installed Google Chrome again
    5. I did not sync with my Google account (so as to prevent automatic loading of extensions such as 1P)
    6. Manually installed 1P extension for Chrome

    No change. IP extension still says "Browser could not be verified.

  • rickfillionrickfillion Junior Member

    Team Member

    There were changes in both Chrome and 1Password lately that could be affecting this. Are you running the AgileBits Store version of 1Password or the Mac App Store version? Is Chrome living in /Applications or elsewhere?

    Thanks

    Rick

  • Rick:
    In my case,

    • 1Password I am using is the AgileBits store version
    • Chrome.app is in /Applications
  • rickfillionrickfillion Junior Member

    Team Member

    @sri : Have you've updated to 1Password 6.7?

    Rick

  • Whoa! I'm on 6.3.2....when did 6.7 happen? What happened to 6.4, 6.5....
    1P isn't talking to me no more..sniff.

    Updating. stay tuned.

  • @rickfillion :
    Trouble!
    Installer downloads the package and ask if I wish to "install & relaunch".
    When I confirm it extracts the package & then starts another download and then...

  • rickfillionrickfillion Junior Member

    Team Member

    Hi @sri,

    Aha... ok that would explain why you can no longer connect. Chrome changed their codesignature recently and the old version you're using won't recognize it. You're also getting affected by an issue that caused us some grief and you'll need to manually do this update. You'll want to follow this guide's instructions:

    https://support.1password.com/kb/201702/

    Once you've done the update things should work for you again.

    Let us know how that goes.

    Rick

  • srisri
    edited May 2017

    @rickfillion :
    That did it!
    One minor tweak on your instructions. I had to manually uninstall 1P extensions for Chrome & Safari before I could reinstall them. It doesn't update an existing extension.
    Thanks for all your help.

  • rickfillionrickfillion Junior Member

    Team Member

    @sri : Great to hear that that did the trick. Those instructions shouldn't have had anything related to extensions though... I'm not seeing anything about them there?

    Rick

  • @rickfillion :

    Those instructions shouldn't have had anything related to extensions though... I'm not seeing anything about them there?

    Fair. However, right after the installation completed stuff popped up in rapid succession --

    Go to 1pw.ca/browser blah blah, validate this 6 digit code with what you see in 1Password, etc.

    I had no idea what was going on. What code? What do you want me to do?

    Everything got answered once I re-installed the extension.

  • rickfillionrickfillion Junior Member

    Team Member

    Gotcha. Yea the app could do a better job at explaining all of that.

    Rick

  • So what about the app store version? I'm having the same issue but it seems I'm up to date...

    1Password
    Version 6.6.3 (663005)
    Mac App Store

  • Hi. I am having the same issue, although I don't see the app store offering me an update. I see that it has 6.7 posted. How do I update to that?

  • Drew_AGDrew_AG 1Password Alumni

    Hi @revurb,

    It looks like your version of 1Password is a little out of date: You have 6.6.3 installed, but the latest version from the Mac App Store is currently 6.7. If you launch the Mac App Store and click on the Updates tab at the top, it should give you the option to install the 6.7 update (you'll need to be signed into the Mac App Store with the same Apple ID you used when you originally downloaded it from there). If you don't see the update listed there, check the Purchased tab to make sure 1Password appears in the list of your purchased apps.

    Hopefully this helps, but please let us know if you have any trouble with that. Thanks! :)

  • Drew_AGDrew_AG 1Password Alumni

    Hi @revurb,

    After posting my previous reply, I noticed you also asked about this in another thread. To avoid confusion, I merged that post into this discussion. Please let us know if you have any trouble installing the 6.7 update from the Mac App Store. Cheers! :)

  • Thanks. I appreciate your help. I tried all that, however 1Password is not showing as an update in the app store. This seems to be more of an issue with the app store than anything else, but I logged out, logged back in, checked the purchases list and it is shown there. I keep refreshing the updates page and it is not appearing as an app ready for updating. ODD.

  • brentybrenty

    Team Member

    @revurb: It sounds like you may have "purchased" 1Password from the Mac App Store (that's in quotes, because you may have gotten the free version, which will still require a purchase) but installed it from the AgileBits website. In this case, the Mac App Store will still see that 1Password is installed, but be unable to update it because it isn't from there. But on the other hand, there may be some glitch causing this. You can always drag it to the Trash, restart your Mac, and install a fresh copy, but I'd encourage you to find your purchase receipt to see where you actually paid for it, so you can be sure you use the appropriate version.

  • Same problem for me. Have tried reinstalling. No go, keep getting the Verification message.
    Chrome Version 58.0.3029.96 (64-bit) + OSX 10.11.6 + App store version of 1P.
    I need some guidance.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @wrrn,

    Sorry to hear you're having trouble with this! Can you please let us know some more details about your setup:

    • What exact version of the 1Password app is installed on your Mac?
    • What version of the 1Password extension is installed in Chrome?
    • You said you reinstalled - did you reinstall the browser extension in Chrome, or did you reinstall the main 1Password app?
    • When did you start seeing that error message?
    • Do you happen to use the 1Password extension in other browsers? If so, is it working correctly in those browsers?

    Thanks in advance! :)

  • @Drew_AG
    I have 1Password Version 6.7 (670008) Mac App Store
    Chrome extension 4.6.5.90
    I reinstalled the browser extension (not the app). The problem began about 5 or so days ago. I also use the same setup on my desktop and do not have this issue. On the problem laptop I can use Firefox without an issue.
    I did try adding the web http proxy IP 127.0.0.1 (from one of your support pages), but it did not help and so removed it.
    Thanks for your help.

  • Drew_AGDrew_AG 1Password Alumni

    Thanks @wrrn! By any chance, is the Google Chrome app located somewhere other than the Applications folder on your Mac? If so, please quit Chrome, move the "Google Chrome.app" file to Applications, then open it again. Does that make a difference? (Just to be thorough, please make sure the 1Password app is also in Applications.)

  • @Drew_AG Both apps were already in the /applications folder

  • @Drew_AG I just deleted the app from applications folder, reinstalled from App Store, and it's working again. Looks like an overly zealous little bug needs squishing. Thanks for your help!

  • Drew_AGDrew_AG 1Password Alumni

    Awesome! That's great news @wrrn, I'm glad it's working now after deleting and reinstalling the app. I think macOS caching may have been the culprit in this case. Thanks for letting us know how it all turned out!

    If you need anything else, we're here for you. Cheers! :)

  • I'm having the same problems: the extension works in Canary but not normal/stable Chrome:

    Chrome: 58.0.3029.110 (64-bit)
    1Password: 6.7.1 (671001) (AgileBits Store)
    extension: 4.6.5.90

    Chrome is in /Applications

    After (re)installing the extension, the authorization step doesn't show.

    Working correctly in Firefox and Safari, but same problem with Opera.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @joeyconnick,

    I'm sorry you're having trouble with this! Thank you for the details about your setup. Please try restarting 1Password mini to see if that makes any difference: From the main 1Password app, go to Help > Troubleshooting > Restart 1Password mini. After it restarts, unlock 1Password and try again to use the extension in Chrome.

    If that doesn't help, try rebooting your Mac. After it restarts, does the same problem happen?

  • Hi @Drew_AG

    Thanks for those steps... restarting 1Password mini didn't do anything, and either did rebooting my machine. Same issue. mini doesn't recognize that the extension is installed in Chrome and offers to let me install it again. Once I reinstall it, the authorization phase doesn't happen.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @joeyconnick,

    When you reinstall the extension, do you uninstall it first, or do you just install a new copy over the existing one? If you don't uninstall it first, you might want to try that before reinstalling, and then you should definitely get the browser authentication prompt.

  • @Drew_AG I've tried both... problem persists if I reinstall over or if I uninstall first.

    In fact, I just tried uninstalling the extension, shutting down Chrome and 1Password, starting them both up again, and using mini to reinstall the Chrome extension and same thing: authorization does not happen. :(

This discussion has been closed.