Touch ID doesn’t work after (manual) locking on initial launch (i.e. after update; after reboot)…

So I noticed this after having migrated to a TB-enabled MBP last week and having enabled Touch I’d in 1PW’s preferences…

  1. Restarted Mac
  2. Fired up 1Password
  3. Followed instructions to unlock vault with my Master Password after having rebooted → vault unlocked
  4. Manually lock vault via shortcut key sequence
  5. Presented with the same screen as (3), only option for unlocking was to enter the Master Password again (i.e. Touch ID was not available)

However, if I quit 1Password at this point, and relaunch the app, only then the Touch ID option rightly becomes available.

I don’t think this is normal, right?

Besides the current beta, I have experienced this in the previous versions too.


1Password Version: 6.8.BETA-3
Extension Version: 4.6.5.b3
OS Version: 10.12.4
Sync Type: 1Password.com

«1

Comments

  • ag_andrewag_andrew

    AgileBits Team Member
    edited May 12

    Hi @Kinny,

    Thanks for the report.

    I've noticed this behaviour as well. It doesn't happen every time, but when it does there isn't a lot of feedback about why it's happening. And that's something we can do a better job on.

    I've logged the issue as {OPM-5048}, so keep an eye on the release notes for that tag, and you'll know we've addressed it.

    Cheers,
    – Andrew

    ref: OPM-5048

  • Hi @ag_andrew,

    For me, it always seems to happen after the first instance of starting 1PW after a cold boot.

    On virtually all instances, it occurs when I manually lock the vault immediately after opening it.

    I haven’t gone and tried it again after leaving my comments here. Will do so again on my next cold boot.

    Cheers,
    -K

  • ag_andrewag_andrew

    AgileBits Team Member

    Hey @Kinny,

    Interesting, I'll try that. Thanks.

    – Andrew

  • I have been having a similar issue. I have 1PW set to require my master password every '1 day' and as expected once a day I will get prompted for my master password to re-enable Touch ID. The problem is that after entering my master password, if I manually lock 1PW or let it lock due to inactivity, it still requires my master password to enable Touch ID. The only way I can get Touch ID to work again is to quit 1PW and reopen it.

  • brentybrenty

    AgileBits Team Member

    Sorry about that. Thanks for letting us know what you're experiencing. We'll see what we can do to get this working more consistently. :blush:

  • Similar problems. Now since updating to Mac OSX 10.12.6 it seems more prevalent. I find 1Password wants me to enter my master password almost everything it auto locks. I quit, reboot, and then I can use Touch ID.

  • brentybrenty

    AgileBits Team Member

    @Mr. K.: Can you tell me what you have set in 1Password Settings > Security and Settings > Advanced > Security? If it's simpler, take a screenshot and include it in your reply. Simply click the document button in the top of the comment field, and select the file you wish to share:


     
    Thanks in advance!

  • I see the setting was somehow changed to 1 hour to require password. I set it to 2 weeks. I'll see how that goes, but even so, quitting and relaunching 1Password does bring back the Touch ID option.

  • brentybrenty

    AgileBits Team Member

    @Mr. K.: Thanks for letting me know. 1 hour would definitely do it. Did you perhaps start seeing this issue after updating from an old version of 1Password for iOS? We haven't made changes here for a while, but I know that when we did tweak some things in the past some users reported similar issues when their existing settings did not migrate 1/1 in the new version. Let me know if you encounter any further issues.

  • "Did you perhaps start seeing this issue after updating from an old version of 1Password for iOS?"

    Not that I know, but this is less than 24 hours since I changed the setting to 2 weeks, and now again it wants my password.

    I quit, restart, and then the Touch ID is available. I think there's a problem.

  • brentybrenty

    AgileBits Team Member

    @Mr. K.: Hmm. Thanks for getting back to me! I made a bit of a silly typo there. I meant "1Password for Mac". Glad that didn't throw you off... :sweat:

    Do you have 3rd party software which may be interfering? On the Mac, Touch ID uses a local network connection between macOS and the integrated iOS device which controls the whole Touch Bar. For a while there VPN and other similar software was interfering with this, but it seemed like they released updates to address these issues since Apple probably isn't going to change how this works.

    At this point, if you're still having trouble, the best thing to do will be to restart your Mac, reproduce the same issue (no Touch ID, and then restarting 1Password to get it back), and then generate a diagnostic report so we can look at the logs to determine exactly what is happening:

    https://support.1password.com/diagnostics/

    Please send it to support@agilebits.com and add the following code (including the square brackets) to the subject of your diagnostics email before sending it:

    [#WPP-65129-795]

    This will link your diagnostics to our current discussion. Let me know once you've sent it. Once we see it we should be able to better assist you. Thanks in advance!

    ref: WPP-65129-795

  • I sent the report this morning. You ask if I have 3rd party software which may be interfering? I have a lot of 3rd party software. Is one or more interfering, who could tell! Maybe the report will give a clue.

  • brentybrenty

    AgileBits Team Member

    @Mr. K.: Thanks! I see that we've received your email, so we can continue the conversation there. We'll take a look at the diagnostics and get back to you shortly! :)

    ref: WPP-65129-795

  • Mr. K.Mr. K.
    edited September 6

    This has gotten worse with the last update. Seeing this more than before. I quit 1P, restart 1P and then I can use Touch ID again. Just a lot of extra work.

  • ag_kevinag_kevin Junior Member

    AgileBits Team Member
    edited September 11

    Hi @Mr. K.,

    Thanks for letting us know. Can you try a small test? Toggle the Touch ID preference off and on in the 1Password Security preferences, and see if that makes a difference.

    Thanks,
    Kevin

  • Will do.

  • brentybrenty

    AgileBits Team Member

    :) :+1:

  • Did that. Not fixed. Just did it for the second time today. I quit, restart 1P, and I can open with Touch ID.

  • brentybrenty

    AgileBits Team Member

    @Mr. K.: Ah, thanks for letting us know! It sounds like you're hitting an issue we're working on addressing with some changes to how this works, tentatively in 6.9. I'm sorry for the inconvenience there. I can't say more that that at this point as we have some work to do in this area, but it's on our radar.

  • Good. It's not horrible, just annoying. Certainly faster to quit and restart than to type in my super long master password, but as you agree that should not be necessary to do.

  • brentybrenty

    AgileBits Team Member

    Yeah I hear you: definitely annoying. Sorry that's necessary for the time being when that happens, but we've got some ideas that should eliminate issues like this altogether. Thanks for your patience!

  • This has gotten much worse since upgrading to OSX 10.13. It happens almost every time after 1P locks.

  • brentybrenty

    AgileBits Team Member

    @Mr. K.: We've had some similar reports on iOS, as if the OS upgrade is migrating things badly. Have you tried disabling Touch ID completely and setting it up anew? That's worked for others in some cases.

  • Mr. K.Mr. K.
    edited October 5

    @brenty, please give me your suggested step-by-step instructions to do this. Thanks

  • I can confirm that:

    • The iOS issue, where the Master Password is needed almost every time when 1P becomes inactive in the background, occurs. However, iOS 11.1 PB1 seems to have addressed this issue (still observing)

    • The macOS 10.13 issue still remains, and (by coincidence) similarly mirrors the same behaviour as the iOS one stated above (i.e. if 1PW for Mac is locked for a long period). Have tried fiddling around with the preferences for time-to-lock, but has proven fruitless

    Looks like there are still a few kinks to iron out (more so, in this case, by Apple IMHO).

  • ag_kevinag_kevin Junior Member

    AgileBits Team Member

    Thanks for the info, Kinny. We'll keep that in mind. We hope to get it all resolved soon.

  • I did some troubleshooting. First I turned off use touch ID in 1P. Then I deleted all of my fingerprints on my MacBook Pro 13" Touch Bar. I added my fingerprint again and went back to 1P and turned on use touch ID again. So far things are working OK. I will report back after a few days, or if I have the issue occur again.

  • Nope, it still does it. Very annoying.

  • brentybrenty

    AgileBits Team Member

    @Mr. K.: I'm sorry to hear that. Thanks for ruling that out and letting us know. We'll see what we can do to get it to "stick" better. :blush:

  • I gave up. I turned off all "lock" security on 1P until you get this fixed. Hope that is soon, but it is since July! At least my MacBook Pro 13" Touch Bar is somewhat secure with my fingerprint to wake it up.

«1

Leave a Comment